Does not work w/ Java 11 on Mac

Support for macOS users and the Mac App Store package
Post Reply
averell23
Posts: 1
Joined: 06 Oct 2018, 14:21

Does not work w/ Java 11 on Mac

Post by averell23 » 06 Oct 2018, 14:33

After not using filebot for a while, I got it again through homebrew. The newest version wasn't happy with Java 8 any more, and asked for the newest version of Java - this being Java 11 ATM.

I wasn't able to start it by clicking on the icon (it still complained that Java is "too old"). When started by running filebot.sh, it said:

Code: Select all

Failed to initialize JavaFX
java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel
	at net.filebot.util.ui.SwingUI.initJavaFX(SwingUI.java:519)
	at net.filebot.Main.onStart(Main.java:191)
	at net.filebot.Main.lambda$main$1(Main.java:161)
	at net.filebot.util.ui.SwingUI$SwingRunnable.doInBackground(SwingUI.java:435)
	at net.filebot.util.ui.SwingUI$SwingRunnable.doInBackground(SwingUI.java:425)
Caused by: java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
	... 5 more
It still appeared to work, only that it now requires a license. After I paid up, I realized that the one thing that did not work was the actual renaming of the file.

I finally managed to get it running properly by removing Java 11 and installing Java 10. However, it'd still be great if this was either fixed, or at least a warning added that you need exactly Java 10 at the moment, and any other version won't do. (My guess is that OpenJFX was removed from the newest Java distribution...)

User avatar
rednoah
The Source
Posts: 15960
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Does not work w/ Java 11 on Mac

Post by rednoah » 06 Oct 2018, 15:09

Yes, looks like Oracle JDK 10 exactly is required for running the GUI on Mac. The download link on the main page should have a hint on that.

Next release will support and require Java 11 but this one is a bit more complicated, so might take a few weeks before next major release is ready.
:idea: Please read the FAQ and How to Request Help.

booshtukka
Posts: 5
Joined: 08 Oct 2016, 18:16

Re: Does not work w/ Java 11 on Mac

Post by booshtukka » 11 Nov 2018, 11:07

This has also broken my version of Filebot. :( I don't really want to have to maintain an old version, or try to downgrade Java or whatever. I want it to just work. I've paid for the Mac App Store version to support the developer, but I really only need the CLI.

Any ETA for a version that works with Java 11?

User avatar
rednoah
The Source
Posts: 15960
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Does not work w/ Java 11 on Mac

Post by rednoah » 13 Nov 2018, 04:44

booshtukka wrote:
11 Nov 2018, 11:07
Any ETA for a version that works with Java 11?
Please use the self-contained macOS installer: *.pkg package, as it doesn't use or rely on the JDK installed on your system:
https://www.filebot.net/#download
:idea: Please read the FAQ and How to Request Help.

Post Reply