Preset works on Mac but not Synology

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
Post Reply
casonbang
Posts: 5
Joined: 14 Feb 2018, 20:44

Preset works on Mac but not Synology

Post by casonbang » 24 Apr 2018, 21:21

I have a FileBot preset that works on Mac, but doesn't seem to work on Synology. It's missing tags for HDR, HEVC, and DTS-HD. Is this using some options that aren't supported in Synology? (I already donated to Patreon, btw)

Code: Select all

movies/{n.colon(' - ')} ({y})  [{minutes} min, {vf}  {def mHDRCol = ["BT.709" : "NO", "BT.2020" : "YES"]; if(self.video[0].bitdepth != null && self.bitdepth == 10 && self.video[0].colourprimaries != null &&  mHDRCol.get(self.video[0].colourprimaries) == "YES") 'HDR' else 'NonHDR';}  {vc},  { def ChannelString = any{(0.0+audio.'ChannelPositionsString2'*.replaceAll(/Object\sBased\s\/|0.(?=\d.\d)/, '')*.split(' / ')*.collect{ it.split('/')*.toBigDecimal().sum() }*.max().max()).toString()}{channels}; def codecSubVersion = any{audio.any{ a -> call{a.FormatProfile} =~ 'HRA' } ? 'HRA' : null}{audio.any{ a -> call{a.FormatProfile} =~ 'X / MA / Core' } ? ' X' : null}{audio.any{ a -> call{a.FormatProfile} =~ 'MA / Core' } ? ' MA' : null}{audio.any{ a -> call{a.FormatProfile} =~ 'ES Matrix / Core' } ? '-ES' : null}{null}; def codecVersion = any{audio.Codec.join().match(/DTS-HD/)+codecSubVersion+' '+audio.Codec.join().match(/TrueHD/)}{audio.Codec.join().match(/DTS-HD/)+codecSubVersion}{audio.Codec.join().match(/TrueHD/)}{audio.Codec.join().match(/DTS/)+codecSubVersion.replaceAll(/null/)}{ac}; (allOf{' '+codecVersion.replaceAll(/null/)} {if( ((ac == 'AAC'||ac == 'MP3') && (channels != '2.0' || ChannelString != channels) ) || ( (ac == 'AC3'||ac == 'DTS'||ac == 'TrueHD') && (channels != '5.1' || ChannelString != channels) ) ) return {any{ChannelString}{channels}}} {aco.match(/Atmos/)}).join(' ') }]

User avatar
rednoah
The Source
Posts: 16123
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Preset works on Mac but not Synology

Post by rednoah » 25 Apr 2018, 04:30

Please simplify your expression to a simple testable binding that doesn't work as expected.


e.g. I'd start by confirming that you get the MediaInfo values for the same files:

Code: Select all

audio.codec

:idea: Depending on your Synology device and which libmediainfo version is installed on your system, you might get different MediaInfo values.
:idea: Please read the FAQ and How to Request Help.

Post Reply