Permission Issue: No files selected for processing

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
Post Reply
apuder
Posts: 2
Joined: 29 Jul 2018, 18:20

Permission Issue: No files selected for processing

Post by apuder » 29 Jul 2018, 18:25

Hi,

I've been using the free version of FileBot for a long time without any issues on my Synology. I've purchased a license but now FileBot does not find any files in the input folder. I have not changed any settings. I also tried uninstalling/re-installing, rebooting without success. Here is the log:

Code: Select all

filebot -script 'fn:amc' /volume1/Download/ --output /volume1/PlexMedia --action move -non-strict --order Airdate --conflict auto --lang en --def 'music=y' 'unsorted=y' 'clean=y' 'deleteAfterExtract=y' 'seriesFormat={plex}' 'animeFormat={plex}' 'movieFormat={plex}' 'musicFormat={plex}' 'unsortedFormat={plex}' 'excludeList=.excludes' --log all --log-file '/volume1/@appstore/filebot-node/data/filebot.log'

------------------------------------------

x86_64
Locking /volume1/@appstore/filebot-node/data/filebot.log
Run script [fn:amc] at [Sun Jul 29 11:12:39 PDT 2018]
Parameter: music = y
Parameter: unsorted = y
Parameter: clean = y
Parameter: deleteAfterExtract = y
Parameter: seriesFormat = {plex}
Parameter: animeFormat = {plex}
Parameter: movieFormat = {plex}
Parameter: musicFormat = {plex}
Parameter: unsortedFormat = {plex}
Parameter: excludeList = .excludes
Argument[0]: /volume1/Download
Use excludes: /volume1/PlexMedia/.excludes (10473)
Ignore system path: /volume1/Download/@eaDir
No files selected for processing
Done ヾ(@⌒ー⌒@)ノ
------------------------------------------

[Process completed]
Just to be sure: folder /volume1/Download/ does have files.

Any suggestions?

AP

apuder
Posts: 2
Joined: 29 Jul 2018, 18:20

Re: FileBot not recognizing files

Post by apuder » 29 Jul 2018, 22:36

some more info. There are a couple of errors in that log. Here is the output of System Info:

Code: Select all

filebot -script 'fn:sysinfo'

------------------------------------------

x86_64
FileBot 4.8.2 (r5768)
JNA Native: 5.2.2
MediaInfo: net.filebot.mediainfo.MediaInfoException: Unable to load amd64 (64-bit) native library libmediainfo.so: Unable to load library 'mediainfo': Native library (linux-x86-64/libmediainfo.so) not found in resource path ([file:/volume1/@appstore/filebot/jar/filebot.jar])
7-Zip-JBinding: 9.20
Chromaprint: java.io.IOException: Cannot run program "fpcalc": error=2, No such file or directory
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2018-07-15 (r530)
Groovy: 2.5.0
JRE: Java(TM) SE Runtime Environment 1.8.0_101
JVM: 64-bit Java HotSpot(TM) 64-Bit Server VM
CPU/MEM: 4 Core / 668 MB Max Memory / 12 MB Used Memory
OS: Linux (amd64)
HW: Linux NAS-AP 3.10.105 #23739 SMP Wed Jun 20 22:40:01 CST 2018 x86_64 GNU/Linux synology_cedarview_412+
DATA: /volume1/@appstore/filebot/data/admin
Package: SPK
License: FileBot License PX4150070 (Valid-Until: 2068-07-29)
Done ヾ(@⌒ー⌒@)ノ
------------------------------------------

[Process completed]

User avatar
rednoah
The Source
Posts: 16585
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Permission Issue: No files selected for processing

Post by rednoah » 30 Jul 2018, 04:39

1.
It's most likely a permission issue. The easiest solution is to create a new shared folder via DSM with default permissions and then just use that.


:idea: NOTE: (2) and (3) are unrelated to the No files selected for processing issue, but probably something you'll want to fix as well.


2.
{plex} is the default, so you can leave these parameters empty:

Code: Select all

Parameter: seriesFormat = {plex}
Parameter: animeFormat = {plex}
Parameter: movieFormat = {plex}
Parameter: musicFormat = {plex}
{plex} only works for Movie / Episode / Music objects. This will fail:

Code: Select all

Parameter: unsortedFormat = {plex}
:arrow: Just leave it empty as well, because you probably just want the default, which is currently this:

Code: Select all

Unsorted/{file.structurePathTail}

3.
The following issues can by fixed by installing MediaInfo and Chromaprint:

Code: Select all

MediaInfo: net.filebot.mediainfo.MediaInfoException: Unable to load amd64 (64-bit) native library libmediainfo.so: Unable to load library 'mediainfo': Native library (linux-x86-64/libmediainfo.so) not found in resource path

Code: Select all

Chromaprint: java.io.IOException: Cannot run program "fpcalc": error=2, No such file or directory
:arrow: Please read Optional Features for details.
:idea: Please read the FAQ and How to Request Help.

Post Reply