Filebot amc renaming some movies as NULL

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
Arturoe
Posts: 8
Joined: 17 Dec 2019, 03:57

Filebot amc renaming some movies as NULL

Post by Arturoe »

some movies are renamed as null, i'd like any help to fix this issue.
This happens to some movies, not all of them but still is very annoying as it destroys the movies when they are ovewriten by other with the same null destination.

log example:

Code: Select all

Run script [fn:amc] at [Tue Dec 17 04:00:42 CET 2019]
Parameter: movieFormat = {plex.derive{[vf]}}
Parameter: seriesFormat = {plex.derive{[vf]}}
Parameter: animeFormat = {plex.derive{[vf]}}
Parameter: music = y
Parameter: subtitles = en
Parameter: clean = y
Parameter: deleteAfterExtract = y
Parameter: artwork = y
Parameter: plex = *****
Argument[0]: D:\temp
Input: D:\temp\Cinderella (2015) [1080p]\Cinderella.2015.1080p.BluRay.x264.YIFY.mp4
Input: D:\temp\Clash of the Titans (2010) [1080p]\Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.mp4
Input: D:\temp\Clash of the Titans (2010) [1080p]\Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.srt
Group: [Movie:Cinderella (2015)] => [Cinderella.2015.1080p.BluRay.x264.YIFY.mp4]
Group: [Movie:Clash of the Titans (2010)] => [Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.mp4, Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.srt]
Get [English] subtitles for 1 files
Looking up subtitles by hash via OpenSubtitles
Fetching [English] subtitles [Cinderella.2015.1080p.BluRay.x264-SPARKS.srt] from [OpenSubtitles]
Export [Cinderella.2015.1080p.BluRay.x264-SPARKS.srt] as [SubRip / UTF-8]
Writing [Cinderella.2015.1080p.BluRay.x264-SPARKS.srt] to [Cinderella.2015.1080p.BluRay.x264.YIFY.eng.srt]
Rename movies using [TheMovieDB]
Auto-detect movie from context: [D:\temp\Cinderella (2015) [1080p]\Cinderella.2015.1080p.BluRay.x264.YIFY.mp4]
[MOVE] from [D:\temp\Cinderella (2015) [1080p]\Cinderella.2015.1080p.BluRay.x264.YIFY.mp4] to [\\wdmycloudex2\Public\media\Movies\Cinderella (2015)\Cinderella (2015)[1080p].mp4]
[MOVE] from [D:\temp\Cinderella (2015) [1080p]\Cinderella.2015.1080p.BluRay.x264.YIFY.eng.srt] to [\\wdmycloudex2\Public\media\Movies\Cinderella (2015)\Cinderella (2015)[1080p].eng.srt]
Failed to set xattr: NoSuchFileException: \\wdmycloudex2\Public\media\Movies\Cinderella (2015)\Cinderella (2015)[1080p].mp4:net.filebot.metadata
Failed to set xattr: NoSuchFileException: \\wdmycloudex2\Public\media\Movies\Cinderella (2015)\Cinderella (2015)[1080p].eng.srt:net.filebot.metadata
Processed 2 files
Fetching movie artwork for [null] to [\\wdmycloudex2\Public\media\Movies\Cinderella (2015)]
FileNotFoundException: Resource is empty: {} => https://api.themoviedb.org/3/movie/null?append_to_response=alternative_titles%2Crelease_dates%2Ccredits%2Cvideos&language=en-US&api_key=28bce8224bd3282a41bec4c5df528249
Get [English] subtitles for 1 files
Looking up subtitles by hash via OpenSubtitles
Fetching [English] subtitles [Clash.of.the.Titans.2010.720p.BRRip.XviD.AC3-ViSiON.srt] from [OpenSubtitles]
Export [Clash.of.the.Titans.2010.720p.BRRip.XviD.AC3-ViSiON.srt] as [SubRip / UTF-8]
Writing [Clash.of.the.Titans.2010.720p.BRRip.XviD.AC3-ViSiON.srt] to [Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.eng.srt]
Rename movies using [TheMovieDB]
Auto-detect movie from context: [D:\temp\Clash of the Titans (2010) [1080p]\Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.mp4]
[MOVE] from [D:\temp\Clash of the Titans (2010) [1080p]\Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.mp4] to [\\wdmycloudex2\Public\media\Movies\null (2010)\null (2010)[1080p].mp4]
[MOVE] from [D:\temp\Clash of the Titans (2010) [1080p]\Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.eng.srt] to [\\wdmycloudex2\Public\media\Movies\null (2010)\null (2010)[1080p].eng.srt]
[OVERRIDE] Delete [\\wdmycloudex2\Public\media\Movies\null (2010)\null (2010)[1080p].eng.srt]
[MOVE] from [D:\temp\Clash of the Titans (2010) [1080p]\Clash Of The Titans (2010) 1080p BrRip x264 - 1.5GB - YIFY.srt] to [\\wdmycloudex2\Public\media\Movies\null (2010)\null (2010)[1080p].eng.srt]
Failed to set xattr: NoSuchFileException: \\wdmycloudex2\Public\media\Movies\null (2010)\null (2010)[1080p].mp4:net.filebot.metadata
Failed to set xattr: NoSuchFileException: \\wdmycloudex2\Public\media\Movies\null (2010)\null (2010)[1080p].eng.srt:net.filebot.metadata
Failed to set xattr: NoSuchFileException: \\wdmycloudex2\Public\media\Movies\null (2010)\null (2010)[1080p].eng.srt:net.filebot.metadata
Processed 3 files
Fetching movie artwork for [null] to [\\wdmycloudex2\Public\media\Movies\null (2010)]
FileNotFoundException: Resource is empty: {} => https://api.themoviedb.org/3/movie/null?append_to_response=alternative_titles%2Crelease_dates%2Ccredits%2Cvideos&language=en-US&api_key=28bce8224bd3282a41bec4c5df528249

Clean clutter files and empty folders
Delete D:\temp\Cinderella (2015) [1080p]\WWW.YTS.TO.jpg
Delete D:\temp\Clash of the Titans (2010) [1080p]\Other
Delete D:\temp\Clash of the Titans (2010) [1080p]
Delete D:\temp\Cinderella (2015) [1080p]
Done ヾ(@⌒ー⌒@)ノ
Command line used:

Code: Select all

filebot.exe -script fn:amc --output "\\wdmycloudex2\Public\media" --log-file D:\amctor.log --action move --conflict override -non-strict --def movieFormat={plex.derive{"[vf]"}} seriesFormat={plex.derive{"[vf]"}} animeFormat={plex.derive{"[vf]"}} music=y subtitles=en clean=y deleteAfterExtract=y artwork=y plex=127.0.0.1:xxxxxxx "D:\temp"


Why i do get those NULL folders/filenames and how can i fix it?
User avatar
rednoah
The Source
Posts: 19159
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Filebot amc renaming some movies as NULL

Post by rednoah »

It works for me now:

Code: Select all

$ filebot -rename Cinderella.2015.1080p.BluRay.x264.YIFY.mp4
Rename movies using [TheMovieDB]
Auto-detect movie from context: [Cinderella.2015.1080p.BluRay.x264.YIFY.mp4]
[MOVE] from [Cinderella.2015.1080p.BluRay.x264.YIFY.mp4] to [Cinderella (2015).mp4]
Processed 1 files
:!: Probably a temporary issue with TheMovieDB not working correctly. If you clear the cache it'll probably work again.

:!: You can enable full debug logging and dump everything that gets sent back form TheMovieDB, that would help us figure out why the response doesn't make sense: viewtopic.php?t=3913



EDIT:

The API indeed returns bad data for Clash of the Titans:

Code: Select all

"title":"",

Code: Select all

{ 
   "adult":false,
   "backdrop_path":"/ma5Ps40txofscTtWpjs39swMnwZ.jpg",
   "belongs_to_collection":{ 
      "id":86780,
      "name":"Clash of the Titans Collection",
      "poster_path":"/3TXIuCHr2m9oZcLJOc5qo9o5WsT.jpg",
      "backdrop_path":"/vmE52XvE2yWWQFt4g1x17K070gY.jpg"
   },
   "budget":125000000,
   "genres":[ 
      { 
         "id":12,
         "name":"Adventure"
      },
      { 
         "id":14,
         "name":"Fantasy"
      },
      { 
         "id":28,
         "name":"Action"
      }
   ],
   "homepage":"http://www.clash-of-the-titans.com/",
   "id":18823,
   "imdb_id":"tt0800320",
   "original_language":"en",
   "original_title":"Clash of the Titans",
   "overview":"Born of a god but raised as a man, Perseus is helpless to save his family from Hades, vengeful god of the underworld. With nothing to lose, Perseus volunteers to lead a dangerous mission to defeat Hades before he can seize power from Zeus and unleash hell on earth. Battling unholy demons and fearsome beasts, Perseus and his warriors will only survive if Perseus accepts his power as a god, defies fate and creates his own destiny.",
   "popularity":16.423,
   "poster_path":"/n8W2Y72VzSi8Yz6IvYWwfoiMTS6.jpg",
   "production_companies":[  ],
   "production_countries":[  ],
   "release_date":"2010-04-01",
   "revenue":232713139,
   "runtime":106,
   "spoken_languages":[  ],
   "status":"Released",
   "tagline":"Titans will clash.",
   "title":"",
   "video":false,
   "vote_average":5.7,
   "vote_count":3970
}
:arrow: I'll shall update the code to default to original_title if title is undefined.



EDIT 2:

Fixed with FileBot r6973.
:idea: Please read the FAQ and How to Request Help.
MickeMM
Posts: 30
Joined: 03 Apr 2019, 10:52

Re: Filebot amc renaming some movies as NULL

Post by MickeMM »

Same problem for me, happend this morning (05 CET).
User avatar
rednoah
The Source
Posts: 19159
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Filebot amc renaming some movies as NULL

Post by rednoah »

MickeMM wrote: 17 Dec 2019, 14:48 Same problem for me, happend this morning (05 CET).
Fixed with FileBot r6973.

Try the latest beta: viewtopic.php?t=1609
:idea: Please read the FAQ and How to Request Help.
Arturoe
Posts: 8
Joined: 17 Dec 2019, 03:57

Re: Filebot amc renaming some movies as NULL

Post by Arturoe »

rednoah wrote: 17 Dec 2019, 15:52
MickeMM wrote: 17 Dec 2019, 14:48 Same problem for me, happend this morning (05 CET).
Fixed with FileBot r6973.

Try the latest beta: viewtopic.php?t=1609
I can not test the beta version because it gives the error Unlicensed.
I brought filebot in the windows store, How can i fix the issue with the NULL folders? Can i download 4.9 from the windows store?
User avatar
rednoah
The Source
Posts: 19159
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Filebot amc renaming some movies as NULL

Post by rednoah »

Looks like the issue has been fixed on the TheMovieDB server-side already:
https://www.themoviedb.org/talk/5df84f8 ... 001755bc65

Try a clear cache if it doesn't work right away:
viewtopic.php?f=3&t=1996
:idea: Please read the FAQ and How to Request Help.
Arturoe
Posts: 8
Joined: 17 Dec 2019, 03:57

Re: Filebot amc renaming some movies as NULL

Post by Arturoe »

rednoah wrote: 17 Dec 2019, 17:35 Looks like the issue has been fixed on the TheMovieDB server-side already:
https://www.themoviedb.org/talk/5df84f8 ... 001755bc65

Try a clear cache if it doesn't work right away:
viewtopic.php?f=3&t=1996
Ok.

Just as a suggestion, can you include the exception if the programm fails to retrieve a value for the naming format requested (name, year, quality...) to do not do anything with that file?
Making a null folder \ null file should not be a feature of this renaming tool as it destroyed some of my library in the process of upgrading to better quality.

Thank you.
User avatar
rednoah
The Source
Posts: 19159
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Filebot amc renaming some movies as NULL

Post by rednoah »

Yes, future revisions will include additional sanity checks for this kind of issue.

Additionally, you can use --conflict skip (default) instead of --conflict override if you're worried about accidentally overriding things.


Typically, I'd recommend these combinations:

1. Copy and override if necessary, if the new file is of higher quality compared to the existing one:

Code: Select all

--action duplicate --conflict auto
2. Move but skip if the target file already exists:

Code: Select all

--action move --conflict skip
:idea: This is default if neither --action nor --conflict specify otherwise.
:idea: Please read the FAQ and How to Request Help.
Arturoe
Posts: 8
Joined: 17 Dec 2019, 03:57

Re: Filebot amc renaming some movies as NULL

Post by Arturoe »

Thank you again, you have been really helpfull.
Have a great week.
MickeMM
Posts: 30
Joined: 03 Apr 2019, 10:52

Re: Filebot amc renaming some movies as NULL

Post by MickeMM »

Upgrade to beta was wonderful :)
Everything goes so fast now and no errors with name.
Post Reply