Page 1 of 1

issue with {group}

Posted: 28 Apr 2012, 04:57
by sabu
Hi there,

I'm receiving an error when trying to use {group} in my naming format. Not sure if this is a bug or my error.

The error message is: BindingError: "group": Cannot cast java.util.Properties to [Ljava.lang.String;

The naming format I've tried to use is: {file.path[0]}:/movies/{n.upperInitial().space('_').lowerTrail().replaceTrailingBrackets().replaceAll(/[!?.]+$/).replaceAll(/[`´‘’?]/, "'").replaceAll(/[:. ]+/, '.')}.{y}.{source}.{vc}{".CD$pi"}-{group}

I've tried using various versions and the error always seems to arise with {group}. I noticed that when I click on the (x)= to get to the Movie Bindings, no matter which movie folder I choose it will always come up with group "undefined".

Any insights into this issue?

PS. Also would appreciate any feedback regarding the above naming format, particularly around the replaceAll which i copied from other examples


Re: issue with {group}

Posted: 28 Apr 2012, 05:13
by rednoah
EDIT: First of all can you run with console and send me the error output for that problem?

1. Might be a odd caching problem? Try running filebot -clear once.

2. The format looks good to me. But -{group} might leave you with trailing - so put - into the {}, e.g. {"-$group}

Re: issue with {group}

Posted: 28 Apr 2012, 06:11
by sabu
Thanks rednoah, clearing the cache seemed to fix the problem. If this is a recurring problem (as it happened again after) what else can I look at for a long term solution?

Also how can I add the - into the group? I tried {"-$group} as per your suggestion although I receive an error.

Re: issue with {group}

Posted: 28 Apr 2012, 06:58
by rednoah
1. Are you using the latest version? If it happens again send me the console log so I can fix it.

2. Typo... should be {"-$group"}