Utorrent Script stopped working.

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
eriv85
Posts: 2
Joined: 16 Oct 2012, 00:14

Utorrent Script stopped working.

Post by eriv85 »

Ok, so this script was working wonderfully until today when I get this error.

Code: Select all

C:\Windows\System32>filebot -script "C:\Users\Elvy Rorie\Documents\I\Incoming Me
dia\utorrent-postprocess.groovy" "C:\Users\Elvy Rorie\Documents\I\Incoming Media
\Torrents in Progress" --output "D:\Videos" --action copy --conflict skip -non-s
trict
MissingPropertyException: No such property: ut_kind for class: Script3
groovy.lang.MissingPropertyException: No such property: ut_kind for class: Scrip
t3
        at Script3.run(Script3.groovy:47)
        at net.sourceforge.filebot.cli.ScriptShell.evaluate(Unknown Source)
        at net.sourceforge.filebot.cli.ScriptShell.runScript(Unknown Source)
        at net.sourceforge.filebot.cli.ArgumentProcessor.process(Unknown Source)

        at net.sourceforge.filebot.Main.main(Unknown Source)
Failure (░_░)
Can anyone tell me what happened and how to fix it?
User avatar
rednoah
The Source
Posts: 18830
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Utorrent Script stopped working.

Post by rednoah »

Ups, my fault. Latest update broke the standalone usage. Try again tomorrow and it'll work again.
:idea: Please read the FAQ and How to Request Help.
eriv85
Posts: 2
Joined: 16 Oct 2012, 00:14

Re: Utorrent Script stopped working.

Post by eriv85 »

Its working now, thanks!
maxazor
Posts: 2
Joined: 13 Nov 2012, 01:16

Re: Utorrent Script stopped working.

Post by maxazor »

What version was this fixed in?
I'm running on 3.1 r1296 and trying to run via command line.
Getting same or similar error as the OP.

Code: Select all

C:\Users\Josh's HTPC>filebot -script fn:sysinfo
FileBot 3.1 (r1296)
MediaInfo: MediaInfoLib - v0.7.61
7-Zip-JBinding: OK
Extended Attributes: OK
Java(TM) SE Runtime Environment 1.7.0_09
64-bit Java HotSpot(TM) 64-Bit Server VM
Windows 7 (amd64)
Done ?(?????)?

filebot -script fn:utorrent-postprocess --output "J:/Downlo
ads/Completed" --action copy --conflict override -non-strict --def subtitles=y a
rtwork=y "ut_dir=%J:/Downloads/Incomplete "ut_file=%F" "ut_kind=%K" "ut_title=%N
" "ut_label=%L" "ut_state=%S"
Parameter: subtitles = y
Parameter: artwork = y
Parameter: ut_dir = %J:/Downloads/Incomplete ut_file=%F ut_kind=%K ut_title=%N u
t_label=%L ut_state=%S
MissingPropertyException: No such property: ut_kind for class: Script3
groovy.lang.MissingPropertyException: No such property: ut_kind for class: Scrip
t3
        at Script3.run(Script3.groovy:58)
        at net.sourceforge.filebot.cli.ScriptShell.evaluate(Unknown Source)
        at net.sourceforge.filebot.cli.ScriptShell.runScript(Unknown Source)
        at net.sourceforge.filebot.cli.ArgumentProcessor.process(Unknown Source)

        at net.sourceforge.filebot.Main.main(Unknown Source)
Failure (░_░)
maxazor
Posts: 2
Joined: 13 Nov 2012, 01:16

Re: Utorrent Script stopped working.

Post by maxazor »

Nevermind....those tags are not allowed in command line, just client "uTorrent" will retest with you command line code.
ramsundaram
Posts: 24
Joined: 13 Oct 2012, 18:32

Re: Utorrent Script stopped working.

Post by ramsundaram »

I get the same error now.

My utorrent cmd is

Code: Select all

filebot -script fn:amc --output "z:\" --action copy --conflict override -non-strict --def music=n subtitles=en artwork=y --def clean=y --def xbmc=xultra.sundar.am "ut_dir=%D" "ut_file=%F" "ut_kind=%K" "ut_title=%N" "ut_label=%L" "ut_state=%S" >>"D:/log.txt" 2>&1
amc.groovy is an exact local copy.

My log output is

Code: Select all

MissingPropertyException: No such property: ut_kind for class: Script3
groovy.lang.MissingPropertyException: No such property: ut_kind for class: Script3
	at Script3.run(Script3.groovy:71)
	at net.sourceforge.filebot.cli.ScriptShell.evaluate(Unknown Source)
	at net.sourceforge.filebot.cli.ScriptShell.runScript(Unknown Source)
	at net.sourceforge.filebot.cli.ArgumentProcessor.process(Unknown Source)
	at net.sourceforge.filebot.Main.main(Unknown Source)
Failure (°_°)
My sysinfo is

Code: Select all

FileBot 3.4 (r1467)
JNA Native: 3.5.0
MediaInfo: MediaInfoLib - v0.7.61
7-Zip-JBinding: OK
Extended Attributes: OK
Java(TM) SE Runtime Environment 1.7.0_17
64-bit Java HotSpot(TM) 64-Bit Server VM
Windows 7 (amd64)
Done ?(?????)?
Any pointers?

Ram
User avatar
rednoah
The Source
Posts: 18830
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Utorrent Script stopped working.

Post by rednoah »

The backslash is escaping the double-quote. These Windows cmd pitfalls are explained plenty in the docs.

Code: Select all

--output "z:\"
:idea: Please read the FAQ and How to Request Help.
ramsundaram
Posts: 24
Joined: 13 Oct 2012, 18:32

Re: Utorrent Script stopped working.

Post by ramsundaram »

rednoah wrote:The backslash is escaping the double-quote. These Windows cmd pitfalls are explained plenty in the docs.

Code: Select all

--output "z:\"
Stupid of me. Thanks, that fixed it.

Ram
Post Reply