[3.2] GConf-WARNING **: Client failed to connect to the D-BU

All your suggestions, requests and ideas for future development
Post Reply
verysofttoiletpaper
Posts: 141
Joined: 05 Jul 2012, 09:44

[3.2] GConf-WARNING **: Client failed to connect to the D-BU

Post by verysofttoiletpaper »

Code: Select all

GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
GConf Error: No D-BUS daemon running
Since 3.2, filebot runs fine but the command line output is full this message.
I'm running ubuntu 12.04 headless.
Any idea on how to fix the problem or suppress the message?

Cheers
User avatar
rednoah
The Source
Posts: 19004
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by rednoah »

Wouldn't know where that'd come from.

Do you also get those GConf messages if you run basic cmdline calls like filebot -version?
:idea: Please read the FAQ and How to Request Help.
verysofttoiletpaper
Posts: 141
Joined: 05 Jul 2012, 09:44

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by verysofttoiletpaper »

No, filebot -verison or -clear don't throw errors.

But -list for example does:

Code: Select all

filebot -list
IllegalArgumentException: query is not defined
java.lang.IllegalArgumentException: query is not defined
	at net.sourceforge.filebot.cli.CmdlineOperations.fetchEpisodeList(Unknown Source)
	at net.sourceforge.filebot.cli.ArgumentProcessor.process(Unknown Source)
	at net.sourceforge.filebot.Main.main(Unknown Source)
Failure (°_°)

(process:23010): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
GConf Error: No D-BUS daemon running


(process:23010): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
GConf Error: No D-BUS daemon running
User avatar
rednoah
The Source
Posts: 19004
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by rednoah »

Guess it's somewhere in the JRE. Maybe forcing headless via -Djava.awt.headless=true helps? Other than that I have no idea.
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 19004
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by rednoah »

This setting may do the trick:

Code: Select all

-Djava.net.useSystemProxies=false
:idea: Please read the FAQ and How to Request Help.
verysofttoiletpaper
Posts: 141
Joined: 05 Jul 2012, 09:44

Post by verysofttoiletpaper »

not a valid option?
User avatar
rednoah
The Source
Posts: 19004
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by rednoah »

The -D Java system properties you have to set in the filebot startup script.
:idea: Please read the FAQ and How to Request Help.
verysofttoiletpaper
Posts: 141
Joined: 05 Jul 2012, 09:44

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by verysofttoiletpaper »

Oh... I understand.
Unfortunately that didn't get rid of the messages :(
User avatar
rednoah
The Source
Posts: 19004
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by rednoah »

Try the latest and set this:

Code: Select all

-DuseGVFS=false
Also make sure that the locale is set on your system. Maybe Java tries to talk to Gnome to figure out the language settings:

Code: Select all

export LANG=en_US.utf8
:idea: Please read the FAQ and How to Request Help.
verysofttoiletpaper
Posts: 141
Joined: 05 Jul 2012, 09:44

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by verysofttoiletpaper »

Tried all 3 at the same time, but the messages are still there :S
User avatar
rednoah
The Source
Posts: 19004
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by rednoah »

With all these settings I'm definitely don't hook into any gnome libraries. Might be a general Java issue.
:idea: Please read the FAQ and How to Request Help.
abc123456
Posts: 3
Joined: 01 Feb 2013, 08:30

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by abc123456 »

Hi there,

I can confirm I am experiencing this bug also. Running Ubuntu 12.04 LTS. I didn't see this bug when still using 3.1 but I am seeing it after upgrading to 3.3.

I thought it was perhaps a mismatch Java OpenJDK version so I upgraded to Oracle's 1.7 but that didn't make any difference.

I'd like to give this a try:
Try the latest and set this:
CODE: SELECT ALL
-DuseGVFS=false

Also make sure that the locale is set on your system. Maybe Java tries to talk to Gnome to figure out the language settings:
CODE: SELECT ALL
export LANG=en_US.utf8
But I'm not exactly sure what you mean by it or how to go about it.

I went through your commits to see if anything after 3.3 release related to this but I didn't find anything..

Finally, just wanted to say thanks for a great piece of software.
User avatar
rednoah
The Source
Posts: 19004
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by rednoah »

Try downgrading to 3.1 again and running with your current Java.

It's either a general Java thing or related to libgio which is used in DnD to translate GVFS URIs into ~/.gvfs paths. Though with no DnD happening this native lib will never be loaded.
:idea: Please read the FAQ and How to Request Help.
abc123456
Posts: 3
Joined: 01 Feb 2013, 08:30

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by abc123456 »

Thanks for the reply.

Silly question perhaps but.. how do I downgrade Filebot?

Do you have an archive of old releases?

Thanks.
User avatar
rednoah
The Source
Posts: 19004
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by rednoah »

It's all on sourceforge, but never mind, already found a fix. You'll need to update to the latest HEAD jar and then just follow this thread:
http://filebot.sourceforge.net/forums/v ... ?f=4&t=500
:idea: Please read the FAQ and How to Request Help.
abc123456
Posts: 3
Joined: 01 Feb 2013, 08:30

Re: [3.2] GConf-WARNING **: Client failed to connect to the

Post by abc123456 »

Wicked, that worked very well. Thank you!
Post Reply