-r recurse isn't working and a few requests/questions

All your suggestions, requests and ideas for future development
Post Reply
randyest
Posts: 2
Joined: 17 Jan 2018, 05:19

-r recurse isn't working and a few requests/questions

Post by randyest » 17 Jan 2018, 05:40

I recently updated to Windows 10 and bought filebot from the windows store because it is fantastic and well worth $20. But one thing that was working under windows 7 using an old filebot version (sorry I'm not sure which version, probably the last free one) that no longer works for me is argument "-r" to recurse directories. Here's my command line, the same as I was using successfully before:

Code: Select all

filebot -script fn:amc --action move --conflict auto -non-strict -r --output \\fatty\video --log-file \\fatty\video\logs\log.txt --def excludelist=\\fatty\video\logs\amc.txt --def minFileSize=0  --def minLengthMS=0
Does the "-r" have to be in a certain place in the command? There are no errors or warnings in any log that indicates why filebot might be skipping over directories. All files and folders are read/write by anyone, and I've tried running filebot as administrator. Thanks in advance for any hints as to what I'm doing wrong.


My requests (these may exist already but I can't find out how to do them):

1. For "--conflict" it would be nice to have an option to ignore extensions and save the highest resolution file instead of the largest. i.e. foo.avi is 320x200 / 500MB and foo.mkv is 200MB and 1920x720. Currently filebot keeps both when I use "-conflict auto". Of course I'd like to keep foo.mkv and skip/delete foo.avi.

2. I was in the hospital for a few weeks and came back to quite a mess of files to sort out and lost my amc.txt file. I had a few dozen of these, as expected:

Code: Select all

CmdlineException: Failed to process [F:\pub\new\foo.mp4] because [\\fatty\video\TV Shows\foo.mp4] is an exact copy and already exists
I understand that is in place to reduce the load on TVDB, but if there were a way to skip these and proceed (which sometimes filebot seems to do) as long as an excludefile is specified that would be a handy feature.

Thank for the great tool!

User avatar
rednoah
The Source
Posts: 14145
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: -r recurse isn't working and a few requests/questions

Post by rednoah » 17 Jan 2018, 14:26

Please run tests locally (e.g. on C:/test) instead of your NAS to narrow down the source of the problem. If -r doesn't work as expected, then it's most likely a permission issue.


:idea: If you're using the amc script, then you should not use the -r option, as it will either have no effect, or bad effects in some corner cases (e.g. disk folders).


1.
The --conflict option deals with cases where two files should have the same path, and thus can't exist at the same time. If you have an avi file and a mkv file then there is no conflict.

:idea: The duplicates script can help you delete logical duplicates. (Note: this won't work if the Extended Attributes feature isn't enabled or supported on your network drive)


2.
This sanity check is internal to FileBot, and not part of the amc script, which usually ensures this never happens via it's own exclude list of previously processed files.

The only thing you can do is to not process files that have already been processed. If you've lost your exclude list, then you may be able to just move files that have been created before a certain date and then deal with the rest which presumably hasn't been processed yet.
:idea: Please read the FAQ and How to Request Help.

randyest
Posts: 2
Joined: 17 Jan 2018, 05:19

Re: -r recurse isn't working and a few requests/questions

Post by randyest » 25 Jan 2018, 07:35

Thank you for the quick and helpful reply. Everything is now fine; your software is excellent.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests