FileBot CLI ignoring audio files

Any questions? Need some help?
Post Reply
jrogalsk
Posts: 2
Joined: 28 May 2019, 20:29

FileBot CLI ignoring audio files

Post by jrogalsk » 28 May 2019, 20:44

I have a script that runs whenever my torrent application finishes a download. This script has been working fine for movies and tv shows.

This is the original script that I used:

Code: Select all

filebot -script fn:amc --output "D:/Media" --action move -non-strict "D:/Torrents" --log-file "C:/Users/ME/Documents/FileBot/logs/amc.log" --def excludeList="C:/Users/ME/Documents/FileBot/amc.txt" seriesFormat="D:/Media/Shows/{n}/{episode.special ? 'Special' : 'Season '+s}/{n} - {episode.special ? 'S00E'+special.pad(2) : s00e00} - {t}" subtitles=en movieFormat="D:/Media/Movies/{n}/{n} ({y})" clean=y
I recently added

Code: Select all

musicFormat="D:/Media/Music/{n} - {album+'/'}{pi.pad(2)} - {t}"
so that the entire script looks like:

Code: Select all

filebot -script fn:amc --output "D:/Media" --action move -non-strict "D:/Torrents" --log-file "C:/Users/ME/Documents/FileBot/logs/amc.log" --def excludeList="C:/Users/ME/Documents/FileBot/amc.txt" seriesFormat="D:/Media/Shows/{n}/{episode.special ? 'Special' : 'Season '+s}/{n} - {episode.special ? 'S00E'+special.pad(2) : s00e00} - {t}" subtitles=en movieFormat="D:/Media/Movies/{n}/{n} ({y})" musicFormat="D:/Media/Music/{n} - {album+'/'}{pi.pad(2)} - {t}" clean=y
My problem is that FileBot ignores all audio files and I'm not sure what I'm doing wrong. When I try to rename the files using the GUI I have no issues. This is the log output when I download an album:

Code: Select all

Run script [fn:amc] at [Tue May 28 15:46:56 EDT 2019]
Parameter: excludeList = C:/Users/ME/Documents/FileBot/amc.txt
Parameter: seriesFormat = D:/Media/Shows/{n}/{episode.special ? 'Special' : 'Season '+s}/{n} - {episode.special ? 'S00E'+special.pad(2) : s00e00} - {t}
Parameter: subtitles = en
Parameter: movieFormat = D:/Media/Movies/{n}/{n} ({y})
Parameter: musicFormat = D:/Media/Music/{n} - {album+'/'}{pi.pad(2)} - {t}
Parameter: clean = y
Argument[0]: D:\Torrents
Use excludes: C:\Users\ME\Documents\FileBot\amc.txt (383)
No files selected for processing
Done ¯\_(ツ)_/¯
Any help with this would be greatly appreciated. I bought this app through the windows store when it was on sale a few months ago and this has made my media organization incredibly simple, it would be awesome to be able to use this for music too.

kim
Power User
Posts: 779
Joined: 15 May 2014, 16:17

Re: FileBot CLI ignoring audio files

Post by kim » 28 May 2019, 23:02

What is type / ext. of files ?
e.g. *.mp3

User avatar
rednoah
The Source
Posts: 16308
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: FileBot CLI ignoring audio files

Post by rednoah » 29 May 2019, 05:37

I think there's an option to enable music processing. See amc manual for details.
:idea: Please read the FAQ and How to Request Help.

jrogalsk
Posts: 2
Joined: 28 May 2019, 20:29

Re: FileBot CLI ignoring audio files

Post by jrogalsk » 29 May 2019, 12:54

What is type / ext. of files ?
e.g. *.mp3
They are indeed .mp3 files.
I think there's an option to enable music processing. See amc manual for details.
That was it! I feel pretty dumb for missing such a simple fix. All I had to do was add

Code: Select all

music=y
after my exludeList

Thank you so much!

Post Reply