Complete Beginner

Any questions? Need some help?
User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 07 Nov 2012, 15:07

As fat as I know uTorrent just passes the cmdline directly to an new cmd window. Definitely an issue with how uTorrent calls the cmd... Very odd.

What happens if set it to lets say "notepad", does it popup notepad or explorer? Or if you do filebot -version > C:/log.txt 2>&1, does that do anything?
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 08 Nov 2012, 00:48

to test I have been downloading a new torrent, is there a quicker way to test each change?

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 08 Nov 2012, 01:09

You can just put the cmd into the "whenever torrent changes state" box and then start/stop torrents to trigger it.
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 08 Nov 2012, 02:02

Ok notepad pops up when I do notepad. filebot -version > C:/log.txt 2>&1 does not cause anything to happen. This is probably something simple I am missing, thanks for the help.

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 08 Nov 2012, 03:11

Well, the filebot call should create a txt file in C:\ called log.txt with filebot version output.

Since that works I suppose there must be something wrong with the command, or how uTorrent executes it. Can u send me a screenshot of utorrents logger tab?
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 08 Nov 2012, 03:20

Its not creating the txt file actually, this is the info am I missing anything after my reinstall?

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Jason>filebot -script fn:sysinfo
Nov 07, 2012 10:16:48 PM net.sf.ehcache.store.disk.DiskStorageFactory <init>
WARNING: The index for data file C:\Users\Jason\AppData\Roaming\FileBot\cache\0\
web-persistent-datasource.data is out of date, probably due to an unclean shutdo
wn. Deleting index file C:\Users\Jason\AppData\Roaming\FileBot\cache\0\web-persi
stent-datasource.index
FileBot 3.1 (r1296)
MediaInfo: MediaInfoLib - v0.7.61
7-Zip-JBinding: OK
Extended Attributes: OK
Java(TM) SE Runtime Environment 1.7.0_09
32-bit Java HotSpot(TM) Client VM
Windows 7 (x86)
Done ?(?????)?

C:\Users\Jason>filebot -script fn:sysinfo
FileBot 3.1 (r1296)
MediaInfo: MediaInfoLib - v0.7.61
7-Zip-JBinding: OK
Extended Attributes: OK
Java(TM) SE Runtime Environment 1.7.0_09
32-bit Java HotSpot(TM) Client VM
Windows 7 (x86)
Done ?(?????)?

C:\Users\Jason>filebot -script fn:sysinfo
FileBot 3.1 (r1296)
MediaInfo: MediaInfoLib - v0.7.61
7-Zip-JBinding: OK
Extended Attributes: OK
Java(TM) SE Runtime Environment 1.7.0_09
32-bit Java HotSpot(TM) Client VM
Windows 7 (x86)
Done ?(?????)?

C:\Users\Jason>

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 08 Nov 2012, 04:12

well, filebot itself works perfectly, just something odd with uTorrent calling filebot. Though if it works in cmd, but not in uT I have no idea what's going on. Should be the same thing.

Send me some screenshots of the uTorrent logger tab so I can make sure the cmds are alright.
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 08 Nov 2012, 23:38


User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 09 Nov 2012, 03:12

Full resolution please. Can't read anything on 100x100.
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 09 Nov 2012, 03:40

not sure if this better....

http://s8.postimage.org/3om2i7cc5/utor.jpg

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 09 Nov 2012, 03:43

here is a copy paste as well

[2012-11-07 20:56:27] Executing: filebot -script fn:utorrent-postprocess --output "C:\Users\Jason\Videos" --action copy --conflict override -non-strict --def subtitles=y artwork=y "ut_dir=C:\Users\Jason\Downloads\Incomplete\Ted.2012.WEBRip.x264-LiFT" "ut_file=" "ut_kind=%K" "ut_title=Ted.2012.WEBRip.x264-LiFT" "ut_label=" "ut_state=10"
[2012-11-07 20:56:27] Executing: filebot -script fn:utorrent-postprocess --output "C:\Users\Jason\Videos" --action copy --conflict override -non-strict --def subtitles=y artwork=y "ut_dir=C:\Users\Jason\Downloads\Incomplete\Ted.2012.WEBRip.x264-LiFT" "ut_file=" "ut_kind=%K" "ut_title=Ted.2012.WEBRip.x264-LiFT" "ut_label=" "ut_state=5"
[2012-11-07 20:56:47] Executing: notepad
[2012-11-07 20:56:52] Executing: notepad
[2012-11-07 20:56:53] Executing: notepad
[2012-11-07 20:59:07] Executing: filebot -version > C:/log.txt 2>&1
[2012-11-07 20:59:12] Executing: filebot -version > C:/log.txt 2>&1
[2012-11-07 20:59:12] Executing: filebot -version > C:/log.txt 2>&1
[2012-11-07 22:17:43] Executing: filebot -version > C:/log.txt 2>&1
[2012-11-07 22:17:45] Executing: filebot -version > C:/log.txt 2>&1
[2012-11-08 18:27:05] Executing: filebot
[2012-11-08 18:27:10] Executing: filebot

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 09 Nov 2012, 04:16

That looks perfectly fine as well. I suppose it works perfectly if you just copy whole line into the cmd window. Also when it's just calling "filebot" it's starting the GUI application right? Can't see why uTorrent would open an explorer window like this.
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 09 Nov 2012, 09:56

When it calls filebot nothing happens, the explorer window is not opening anymore. When it calls notepad, notepad opens. Could I have filebot installed wrong or in a place utorrent can't call it from?

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 09 Nov 2012, 11:13

Tested with uT 2.2.1. Works fine for me, startup anyway, though the script doesn't work well with single-file torrents since 2.2.1 doesn't pass the single|multi variable like 3.x does. I guess for some reason utorrent isn't able to run filebot, but by know i've run out of ideas why that would be the case.
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 09 Nov 2012, 12:39

I am going to try updating utorrent and see if it works from there, maybe I have something installed wrong

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 10 Nov 2012, 05:45

I updated and it still did not work, so i gave up and reinstalled 2.2.1. When I installed I right clicked and ran as administrator......and that fixed it all, it works now. Sorry for the trouble and thank you for the help.

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 10 Nov 2012, 06:51

Ok the fix was to install uTorrent as admin? Or run as admin? Did you have to install Java/FileBot as admin as well?

PS: I updated the uTorrent script to work better uT 2.2.1
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 10 Nov 2012, 17:48

Install as admin, and works perfect with the 2.2.1. Now I want to experiment with the hardlink to save space but continue seeding.

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 10 Nov 2012, 18:08

Hardlinks obviously only work on the se drive, also make sure uTorrent is running as admin, because filebot needs admin priviledges to create Hardlinks on windows.
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 10 Nov 2012, 20:06

What is a se drive?

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 10 Nov 2012, 20:12

*typo: same

hardlinks only work on the same filesystems since the point is there is only one physical file but multiple filesystem entries.
:idea: Please read the FAQ and How to Request Help.

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 10 Nov 2012, 20:31

would I just change the action to hardlink?

User avatar
rednoah
The Source
Posts: 18538
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Complete Beginner

Post by rednoah » 11 Nov 2012, 02:45

Yep, --action hardlink
:idea: Please read the FAQ and How to Request Help.

kiloback
Posts: 10
Joined: 11 Nov 2012, 05:57

Re: Complete Beginner

Post by kiloback » 11 Nov 2012, 13:32

hi just wanna know if there is a way to redirect the cmdline output to a text file but still view the cmdline output on the console?

buck3y3
Donor
Posts: 37
Joined: 05 Nov 2012, 01:19

Re: Complete Beginner

Post by buck3y3 » 11 Nov 2012, 14:07

Does the hardlink delete the original file automatically?

Post Reply