Page 1 of 1

'java' is not recognized (...)

Posted: 02 Nov 2012, 08:44
by cybirg
OS: Windows Server 2012
Programs: FileBot x64, uTorrent (x86), Java (x64)

I have a strange problem that only occurs when I call FileBot from uTorrent. The log file outputs the following error:
'java' is not recognized as an internal or external command,
operable program or batch file.
The command I run (from uTorrent logger) is:

Code: Select all

[2012-11-02 09:18:47]  Executing: filebot -script fn:utorrent-postprocess --output "D:/" --action move --conflict override -non-strict --def gmail=xxx:yyy --def subtitles=y artwork=n "ut_dir=C:\Users\Administrator\Downloads\Homeland.S02E04.720p.HDTV.x264-EVOLVE" "ut_file=homeland.s02e04.720p.hdtv.x264-evolve.nfo" "ut_kind=multi" "ut_title=Homeland.S02E04.720p.HDTV.x264-EVOLVE" "ut_label=" "ut_state=5" >> "C:\Users\Administrator\Downloads\Homeland.S02E04.720p.HDTV.x264-EVOLVE\filebot.log" 2>&1
When I run the above command in cmdline, the job runs successfully. :?

The Path variable is

Code: Select all

C:\Program Files (x86)\PHP\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files\FileBot\;C:\Program Files\Java\jre7\bin 

Re: 'java' is not recognized (...)

Posted: 02 Nov 2012, 15:03
by rednoah
Not sure what's going on. Looks like it can find 'filebot' but not 'java' that filebot.cmd would be calling. I think Windows has two PATH variables for 32/64-bit mode each. Make sure jre7/bin is in both. Otherwise you can edit filebot.cmd make it call the jre7/bin/java.exe directly rather than 'java' which it apparently cant find.

Re: 'java' is not recognized (...)

Posted: 20 Nov 2012, 11:50
by cybirg

I could not find a way to set PATH variables for both 32/64 bit modes, but including the directory in filebot.cmd fixed the issue.

By the way, on a new Windows 8 installation, I got the same error message 'Filebot is not recognized...' Reinstalling Filebot did the trick.