Page 1 of 1

CacheException error on OS X

Posted: 20 Jan 2013, 20:11
by birax
I'm trying to get Filebot running on OS X Lion, I downloaded the .app and ran it, which opened, showed the Filebot menu and then closed. I ran term and ran in case that was needed but it still does the same thing. Next I downloaded Filebot-3.jnlb and opened that, which gives me the GUI OK but when I try to match episodes in rename it gives the error 'CacheException: Disk store path can't be created'. I also get the error 'Disk store path can't be created' when I try a search from episodes (though without the CacheException part).

Any help in getting this running (preferably the .app version, but either would be great) appreciated!


Re: CacheException error on OS X

Posted: 21 Jan 2013, 02:10
by rednoah
Isn't that Apples new features? Controlling what can and cannot run on your Mac? :P

Have u tried running from console? What's the error messages? I guess OSX is blocking filesystem access with the new "security features" so Java and FileBot can't initialize.

There must be away around this somehow, but since I don't have a Mac so I can't really figure out a fix myself. Maybe you can run it as admin user? Or maybe there's a way to tell OSX to trust this app and not sandbox it.