(Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Any questions? Need some help?
GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

(Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 17 Mar 2019, 21:07

Okay I am using Windows 10
Using SABnzbd, Sonarr, Radarr, Filebot, Plex. (ALL latest versions)
I also have uTorrent but currently don't use it for my media as most things I get are from nzb.

I can not find any videos or tutorials for my needs. OR maybe I am just that noob that I don't know what I should be searching for. Videos help me more than guides, I am much more of a visual learner in the most part.

I don't have any idea on how to use AMC, scripts, or cmd line functions, or any other such thing. So if you tell me to run a script I will not be able to unless you tell me something like (open cmd or powershell and type xxxx) or (open notepad and make .bat file with this in it xxxx) other than that I'm a complete idiot as far as scripting and such. I'd love to learn it but haven't found very many dummy guides yet.
I have tried to learn but every guide or video I have tried to follow usually ends up being dedicated to scipts for software like uTorrent or qTorrent or docker or some other program. With fiddling around with Filebot, I have really tried to figure out how to correctly use the renaming schemes to match everything. What I usually come across with is that I apparently have something messed up somewhere because I have several of the same shows and movies multiply times throughout my drives. I have spent over a week trying to fix it all but I feel it will take several more weeks to correct all of this mess. I have put my full focus on TV shows for the moment so I will not dip into the Radarr settings yet as I will hopefully be able to figure out the TV and learn from it so I can then go to Radarr and fix the same issues.

ALSO- In 4th picture down you will see-- "SONARR Diskspace/Drives?-- Z: Drive (NAS) Not shown? Maybe reason for multiple downloads including renaming issues?"
I have also been working on how to fix my Z: drive not showing up in here but kinda gave up on it after none of the solutions helped me that I found.

I added a few notes to the side/beneath each image I attached for better viewing. I also added some logs to show that I have "tried" to use some of the scripts and things that I have seen in forums to help me but apparently I am doing something really wrong.


I want to figure out how to use FreeNAS and docker soon but right now I am a bit overwhelmed with trying to set my media up correctly before stressing myself out even more.

I've spent half the day with writing this post to include as much as I possibly can. Hopefully it is enough that someone, if not rednoah, can help me out and lend a hand.

Using Filebot 4.8.5--

SONARR IMAGES--
Image - SONARR Rename page?
Image - SONARR Drone?
Image - SONARR Metadata?
Image - SONARR Diskspace/Drives?
-- Z: Drive (NAS) Not shown? Maybe reason for multiple downloads including renaming issues?

SABNZBD IMAGES--
Image - SABnzbd General
Image - SABnzbd Catagories
Image - SABnzbd Sorting Config
Image - SABnzbd Config Special

FILEBOT IMAGES--
Image - One preset I have tried
Image - Another preset
Image - And another preset

WINDOWS EXPLORER IMAGES--
Image - Showing my NAS Drive 'Z:' (can see all the multiple duplicates)
Image - Showing my E: drive (used to be where I had all my tv and movies downloading to before transferring them to my NAS (Z:) before buying Filebot

AMC.LOG--
Image

FILEBOT ERROR LOG--
https://pastebin.com/77cKpYKW

SABNZB LOG--
https://pastebin.com/MpchnrX9

NZBDRONE LOG--
https://pastebin.com/R0Ezzm3A

Not sure what PLEX IMAGES may be needed but let me know and I'll get any that you may need to better help me

User avatar
rednoah
The Source
Posts: 15527
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by rednoah » 18 Mar 2019, 09:15

There's why to many questions here. I'll just give you a few tips relating to FileBot. There other tools aren't really my expertise, but other users here in the forums, or other forums, might be able to help out with that.


1.
Here's a very old and completely outdated video on how to use the command-line tools:
https://www.youtube.com/watch?v=brGyo2uQzSs

* The video content is outdated, but generally speaking, using CMD hasn't really changed since Windows 95. ;)


2.
You'll want to be familiar with command-line argument passing:
viewtopic.php?f=4&t=1899

The amc.log screenshot shows that \ is interpreted somehow, and stripped, so an invalid path is passed to FileBot for processing, the amc script promptly errors out in response with a clear and descriptive error message. Not sure how FileBot is called, but you'll have to fix this one in the upstream program, and make it call filebot correctly.


3.
Here's how to use the {plex} binding:
viewtopic.php?f=5&t=4116

* For most users, just doing something like X:/Media/{plex} will work just fine. I'd stick to the defaults first, and make modifications later once you've got something basic working.


4.
If you have problems with 3rd party tools, then I can only give you general advice, and not step by step instructions, since I don't use these tools. Other people might be able to help. As far as filebot is concerned, the command-line tools are the common interface, and can be called by you or any 3rd party program, and filebot doesn't know or care who or what is making the call.
:idea: Please read the FAQ and How to Request Help.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 18 Mar 2019, 21:37

Thanks a lot for your responses rednoah! I was hoping I'd have a few people chime in due to the amount of chaos I have going on right now. I greatly appreciate you attempting to help me out.


1. Watching the video again now. I've seen this video about 5 or 6 times. I get stumped because he is configuring it with uTorrent which I am not trying to do. I have looked at his scripts to try them out after making adjustments.


2. Reviewing thread now to help better understand argument passing. You mentioned that I need "to fix this error in a upstream program and make it call Filebot correctly". How would you recommend me fixing it? Any threads or steps to take to fix?


3. I've tested several {plex} bindings. The problem is that I can't use the GUI Filebot for several reasons. One reason is I constantly get errors about duplicate content and the override is greyed out, I also get SOOO many several other errors about Filebot not pulling correct Names and needs me to pick from a drop down list, however most of the time the shows I'm looking for are not even listed in the "pick name box". So I have to end up skipping the Movie/TV show.


4. You offered to give me some general advice that could really help me? What advice could you offer?


--


+ 5. Is it possible to use the same exact input that I have set for my filebot {plex} binding in all tools and programs? So for instance, is it possible to use {plex.tail} in Sabnzb as well as Sonarr/Radarr in the renaming settings configuration? Would it be easier at this point to stop all renaming configurations in 3rd party tools until filebot has got me all caught up with everything? I'm not trying to download a lot currently until I'm caught up, however, if there is a show that becomes available that I'm currently watching I will download it even with the current status of my chaos. Yea, I know its bad to add more to the problem but, I have got to have something going on in background while I've been at my computer for all these hours/days/week trying to figure all of this out.


I wish I could get some serious help with all of this so I didn't have to continue wasting so many hours on this. It's really been a dread wasting so much time on this when I know there has to be a very easy solution out there for me that I haven't learned or figured out about yet! :(


It seems that (after I'm caught up with the naming and duplicates) that I should be able to schedule a script to run every other day or whatever. It's just getting to that point where I'm caught up is the problem.


I've been able to run a few scripts to rename and what's happening is that it's only copying/duplicating from the input folder to the output folder, however with saying, that it is at least correctly renaming the video files. It leaves all the other stuff like subs and art though. I don't mind going back, for now, and manually moving subs until I learn a new script that moves all of its contents. What's driving me up the wall is that its MAKING MORE DUPLICATES! Grrr!!


I have been trying out a few cmd line scripts lately but still haven't been able to achieve my goal.

Code: Select all

filebot -script fn:amc --output "Z:\SortedMaybeIDK" --action duplicate -non-strict "Z:\1. Movies" --log-file amc.log --def excludeList=amc.txt

Code: Select all

filebot -script fn:amc "Z:\1. Movies" -non-strict --output "Z:\1a. SortedMoviesMaybeIDK" --def subtitles=en music=n clean=n --action move --conflict override

Code: Select all

filebot -script fn:duplicates "Z:\1. Movies" --action delete

Code: Select all

filebot -script fn:duplicates "Z:\1a. SortedMoviesMaybeIDK" --action delete

Code: Select all

filebot -script fn:duplicates "Z:\2. TV" --action delete

Code: Select all

filebot -script fn:duplicates "Z:\1. Movies" --action delete

Code: Select all

filebot -script fn:duplicates "Z:/" --action delete

Code: Select all

filebot -script -rename "Z:\1. Movies" -non-strict --format "{home}/Movies/{ny}" --db TheMovieDB --def target=folder

Code: Select all

filebot -script fn:amc --output "Z:1. Movies" --action duplicate -non-strict "Z:1. Movies" --log-file amc.log --def excludeList=amc.txt
Had an error message last night after apparently keying in something wrong. Also had a few other errors and after much research I decided to uninstall all java and reinstall latest because I had a few MEM errors and it was also being very slow.

Code: Select all

filebot -script fn:amc --output "Z:1. Movies" --action duplicate -non-strict "Z:1. Movies" --log-file amc.log --def excludeList=amc.txt

Code: Select all

PS Z:\1. Movies> filebot -script fn:amc --output Z:\1. Movies\test --action duplicate -non-strict Z:\1. Movies --log-file amc.log --def excludeList=amc.txt


A few bindings I have tried, which I do like however I do not know how to do the entire folder without the Filebot GUI. I have profiles set up in Sonarr that will download a better quality when it becomes available so I would def need something that shows the resolution of the video I currently have.

Code: Select all

Z:/1. Movies/{n.colon(' - ')} ({y})/{n.colon(' - ')} ({y}){subt} {n}/{'Season '+s}/{n} - {s00e00} - {t}

Code: Select all

Z:/2. TV/{n}/Season {s.pad(2)}/{n} - {s00e00} - {t}

Code: Select all

Z:/1. Movies/{n.colon(' - ')} ({y})/{n.colon(' - ')} ({y}){subt}{plex.derive{' ' + [resolution]}}

Code: Select all

X:/Media/{plex.derive{' ' + [resolution]}}


I really appreciate your time and help rednoah! I know you have A LOT of things to keep up with since you have created this nice program for all of us to use. I also will guess that you probably don't have a lot of time to devote in getting me on track with step by step help. I was really hoping others would chime into my post since I tried to be as detailed and through as I possible could, being as noob and dumb as I have. I know my problem looks bigger to me than it really is, I just hope I am able to find a solution for it and help me get rid of duplicates, get rid of lower quality videos, and renamed all correctly.

I've done a lot of searching in forums as well as reddit for help. Hours upon hours. I wanted to be sure I didn't miss anything before registering on the forum and taking up anymore space and time of someone elses. If anything, I hope that others that ever (or will ever) experience this and are completely oblivious to cmd and such that they are able to find this posting and find some help. Rather it be a search engine, Google, or someone else pointing them to this post.

I've already supported you by buying the software and I surely wouldn't mind sending a donation for your time and trouble after all said and done. To me it would be worth the time and headache saved to get this knocked out ASAP and not waste another day dealing with it! Don't care if you need Teamviewer access or what! Just please, any help at all would be MUCH appreciated!! I just looked at my browser history and I have seriously viewed over 316 pages of filebot info rather it be from this forum, other forums, or youtube. Banging my head against the wall right now, feeling really stupid!

I'd be OH SO VERY GRATEFUL for any help! I got a big ole' mess right now! :(



What my NAS drive currenly looks like as of right now -

Main - Z: Drive - Z:\
Image

Z: Drive First Folder - Z:\1. Movies
Image

Z: Drive Second Folder - Z:\1a. SortedMoviesMaybeIDK\Movies
Image

Z: Drive Third Folder - Z:\2. TV
Image

Z: Drive Fourth Folder - Empty for now
Z: Drive Fifth Folder - Empty for now

Z: Drive Sixth Folder - Z:\4. SUBs
Image

Z: Drive Seventh Folder - Empty for now
Z: Drive Eighth Folder - Empty for now

User avatar
rednoah
The Source
Posts: 15527
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by rednoah » 18 Mar 2019, 21:58

1.
Looks like Z: is a remote network drive, which means that it likely doesn't support xattr metadata, which means FileBot won't be able to store metadata to xattr when first processing the files, which means the duplicates script won't be able to do anything:
viewtopic.php?f=4&t=5#p23171


2.
FileBot format expressions and the {plex} binding are, well, a FileBot thing. You can use formats in FileBot GUI and CLI. All the same.
https://www.filebot.net/naming.html

:idea: You cannot use FileBot format expressions in other 3rd party tools, which may or may not have their own format engines.
:idea: Please read the FAQ and How to Request Help.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 18 Mar 2019, 23:06

1. Yes, I was told to make sure it was mapped as a UNC. So I mapped it with device name instead of the IP address. From what you are saying it wouldn't matter how it was mapped it still wouldn't work?

With saying all the above what options do I have left in order to do what I am wanting to do?
Any recommended programs or software? Anything at all to help me figure out what I need to do?


2. Okay understood

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 19 Mar 2019, 01:44

I have read that I should try SickRage however it has same issues. It doesn't see my network drive.
I have made NTFS symbolic links in my C: Drive and I have been able to do it successfully however SickRage still can not see the drive contents. I have also tried to edit my registry with same outcome. I seriously don't know what to do at this point.

https://stackoverflow.com/questions/182 ... -a-service
https://superuser.com/questions/650025/ ... 015#651015
https://en.wikipedia.org/wiki/NTFS_symbolic_link
https://en.wikipedia.org/wiki/Symbolic_link

User avatar
rednoah
The Source
Posts: 15527
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by rednoah » 19 Mar 2019, 05:52

There's nothing you can do about xattr not working for remote SMB shares. Depending on the device, it may not be possible to enable xattr. Creating symbolic links on your machine certainly won't help with server-side limitations, so you're out of luck in this regard.
:idea: Please read the FAQ and How to Request Help.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 19 Mar 2019, 14:56

Thanks for your advice. It's a WD MyBookLive directly connected to my router. It doesnt have any port on it except the ethernet port on back of it.

So if you were me dealing with what I am dealing with and trying to do what I am trying to do what would you do at this point?

Thinking about buying a harddrive and installing it into my PC and transferring all the data to it and getting the xattr data for it. Renaming and getting rid of duplicates and transferring it back to the NAS. Would that work or would I be back dealing with this issues again?

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 19 Mar 2019, 15:00

I know if there are any alternatives, tools, programs, or solutions you would definitely be the person that would know about them so I'm hoping you can tell me what you personally would do in my situation since you know what I am trying to achieve and do right now.

User avatar
rednoah
The Source
Posts: 15527
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by rednoah » 19 Mar 2019, 20:32

Newer revisions allow you to configure FileBot to store xattr metadata in plain text files instead of filesystem xattr streams:
viewtopic.php?f=3&t=324

e.g. Store metadata to hidden folders named .xattr:

Code: Select all

filebot -script fn:properties --def net.filebot.xattr.store=.xattr
:idea: Please read the FAQ and How to Request Help.

User avatar
devster
Posts: 197
Joined: 06 Jun 2017, 22:56

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by devster » 20 Mar 2019, 23:20

I believe there's a lot of confusion regarding how to do post-processing but most of it isn't particularly pertinent to FileBot.
In short what I do, and I believe to be the "right" way to do it, is disable any kind of post-processing from both Sonarr/Radarr and Sabnzbd/Nzbget except to call the a script with appropriate arguments.
The script in question will then take care of renaming files with FileBot and communicate to Sonarr/Radarr that rename has been completed and files can be imported in the database.
Regarding the fact that Sonarr doesn't see the remote folders please see this FAQ Why can't Sonarr see my files on a remote server
I only work in black and sometimes very, very dark grey. (Batman)

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 30 Mar 2019, 23:26

Okay so since I was unable to get anything to work for me to use Filebot on my NAS drive ("Z: Drive") I decided to purchase a brand new hard drive and it came in this week. I have now moved every movie and tv to the drive. The only thing on the drive (F: Drive) is media rather it be TV or movies. The folders are a mess and very unorganized/unsorted. I am really hoping to put Filebot to the test and actually see its true potential now that I am no longer using multiply drives or any network attachments.

So now back to researching best script for me to do all the organizing, un-archiving, delete dupes, sorting, and renaming! Only using SINGLE drive this time. I made 3 folders. One named "Unsorted" (has the chaos in it) One named "Sorted" (will be the destination for filebot) and another One named "Downloading" (will be for the grabs from usenet).

Would this be the code I would use to do everything needed as far as un-archive (if needed), delete if has a better quality, rename, and sort?

Code: Select all

filebot -script fn:amc --output "F:Sorted" --action duplicate -non-strict "F:/Unsorted" --log-file amc.log --def excludeList=amc.txt --def music=y --conflict auto --def subtitles=en --def artwork=y --def deleteAfterExtract=y --def clean --def unsorted=y 
Last edited by GtownE on 31 Mar 2019, 00:53, edited 1 time in total.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 30 Mar 2019, 23:28

Last time I used this script it was on my NAS drive and it just duplicated everything. Hoping it doesn't duplicate this time and actually does what I need it to (organize, unarchive, delete dupes, sort, and rename) in any given order that is acceptable

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 30 Mar 2019, 23:50

Is this the correct code for me?

Code: Select all

filebot -script fn:amc --output "F:Sorted" --action duplicate -non-strict "F:/Unsorted" --log-file amc.log --def excludeList=amc.txt --def music=y --conflict auto --def subtitles=en --def artwork=y --def deleteAfterExtract=y --def clean --def unsorted=y

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 30 Mar 2019, 23:51

Just nervous about the "--action duplicate" because I do not want duplicates again making more of a mess. But this looks like correct script for me to use, will wait for confirmation before actually using but I seriously can't wait for this nightmare to be over!

User avatar
rednoah
The Source
Posts: 15527
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by rednoah » 31 Mar 2019, 04:18

1.
F:Sorted is not a valid file path, and FileBot will fail with an error message that says something akin to output folder not being valid:

Code: Select all

"F:/Sorted"

2.
--action duplicate will indeed create hardlinks. You'll want to create hardlinks. Why not keep both original files and organized files? The file will only use physical space once, even if you have file system entries in different places.

:idea: If you do want to move files for some reason, then you can use --action move, but make sure you read up on and understand how hardlinks work first, because that's the way to go. Keeping both sorted and unsorted files, because there's no reason not to.
:idea: Please read the FAQ and How to Request Help.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 31 Mar 2019, 04:28

After reading through forums last few hours I read in this thread viewtopic.php?f=3&t=324
As such, xattr requires a filesystem that supports xattr, and xattr may be silently lost if files are moved to a filesystem that doesn't support xattr.
So since I moved from a NTFS to a NAS then back to a internal NTFS drive that I have more than likely lost my xattr on all the files? If so, is it possible to gather it back?
Surely I am asking a very dumb question to most but as thread states I am completely a noob about all of this and any help would be much appreciated!

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 31 Mar 2019, 04:34

Okay thanks a lot for stopping in today and letting me know. I will read up on hardlinks now so I better understand it. For now, I will do as you suggested and keep both sorted and unsorted. Other than that error in script, does everything else look like it will do as I am trying to do? As far as organize, unarchive ( and delete archive after), delete dupes, sort, and rename?

User avatar
rednoah
The Source
Posts: 15527
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by rednoah » 31 Mar 2019, 06:51

1.
Maybe. IDK. What does the log say? Does it say that it's doing what it's supposed to be doing?


2.
You can view xattr with the xattr script, so you can see what files have xattr and what files don't. Indeed, they're likely lost, or never stored in the first place, if you copy to / from file systems that don't support xattr. NTFS generally always supports xattr. Some NAS manufacturers enable xattr by default (e.g. Synology) but that one is not guaranteed, and often case just doesn't work.
:idea: Please read the FAQ and How to Request Help.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 31 Mar 2019, 08:03

Ok thanks

1.
Running this script now:

Code: Select all

filebot -script fn:amc --output "F:/Sorted" --action duplicate -non-strict "F:/Unsorted" --log-file amc.log --def excludeList=amc.txt --def music=y --conflict auto --def subtitles=en --def artwork=y --def deleteAfterExtract=y --def clean --def unsorted=y
So far only odd thing I see at the start of script is

Code: Select all

Locking C:\Users\E\AppData\Roaming\FileBot\logs\amc.log
Illegal Argument: java.nio.file.NoSuchFileException: C:\WINDOWS\system32\clean (clean)
Run script [fn:amc] at [Sun Mar 31 02:39:22 CDT 2019]
Parameter: excludeList = amc.txt
Parameter: music = y
Parameter: subtitles = en
Parameter: artwork = y
Parameter: deleteAfterExtract = y
Parameter: unsorted = y
Argument[0]: F:\Unsorted
Argument[1]: File does not exist: clean
It will probably take awhile to fully run as there is almost 4 TB of files on F: drive.
I will let it run through the night and hopefully have something to to show after. Not sure if it will sort the Movies from the TV from the Music but I guess I will find out soon enough! All I currently see is a bunch of extracting going on right now. I'm excited to see the results though!! Thanks for getting me to this point of feeling comfortable enough to actually executing the script I used!! :)



2.
I used

Code: Select all

filebot -script fn:xattr F:/
and it gave me a "Done???" at the end. When I went to

Code: Select all

C:\Users\E\AppData\Roaming\FileBot
I couldn't find the log, I also checked

Code: Select all

C:\Users\E\AppData\Roaming\FileBot\Logs
and only saw a blank amc.txt file there. So not really sure where I was suppose to look after running script for the log. I even tried to run it with

Code: Select all

filebot -script fn:xattr F:/ --log
but that gave me an error.



--3. In my previous question, I was asking if there was a way to "re-get" the xattr data for all files. I think I might have used the clear/delete xattr script at one point when experimenting with getting all this working when I was using the NAS drive during first week of March and I have also completely gone deep into the registry to delete all filebot existences and have also deleted my filebot %appdata% and reinstalled 4.8.5 before doing it this time. Might have been the stupidest thing to do but I just wanted to make sure I was doing it correctly this time.





Update:
Before lights out I checked cmd and I saw this:

Code: Select all

Input: F:\Unsorted\Z\UN-SORTED\The Resident S02E17 1080p AMZN WEB-DL DDP5 1 H 264 1-KiNGS-xpost\ab027667f99342439a20c2cd9ffb522a.mkv
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6742252
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt3606888
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5709188
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt3532216
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6131450
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt0373126
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt3208026
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6640390
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2531344
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt3769038
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4465438
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6857166
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6167116
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt7608534
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4575576
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4680182
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1403144
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt0433362
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1389072
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt8632862
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4477536
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2039338
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4158096
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt8805150
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2315596
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1981128
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1219827
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt0123865
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5702446
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt7521990
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1999890
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2392383
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1846589
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6360332
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5607096
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6684884
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6083648
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt9083724
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6303872
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2103217
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5613484
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt3402236
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5741770
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2226495
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5208252
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1563742
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6850820
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4446472
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6280608
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1392214
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt7493804
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2034176
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4106376
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt9033646
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1270114
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5314190
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4874350
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5691024
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5052474
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4573516
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6182908
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5639898
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5180888
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1386697
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2854926
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5977276
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2034800
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1268970
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt9059048
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2709768
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt5580390
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1758810
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4768586
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6984258
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt6603378
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt0218967
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt8262802
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt2119543
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt3829266
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt3152624
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1270797
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1107365
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4276990
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt0400717
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1253863
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt0961713
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1646926
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt4938374
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt1377396
Resource not found: https://api.thetvdb.com/search/series?imdbId=tt3279276
Seems to be stuck at this point, not sure. Will leave it and see what happens. Will report back in about 6 hours.

User avatar
rednoah
The Source
Posts: 15527
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by rednoah » 31 Mar 2019, 08:48

1.
It's --def name=value so:

Code: Select all

--def clean=y

2.
If the xattr script doesn't print anything, then none of the files have any xattr metadata.

It's --log /path so:

Code: Select all

--log /path/to/log/file.text

3.
The way to "re-get" xattr metadata is to just process all files again as usual, which should work quite well if files are already well-named.


4.
Why not have a small set of sample files to run a few tests first, before letting it loose on your entire library?
:idea: Please read the FAQ and How to Request Help.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 01 Apr 2019, 04:29

Well my log's from the script are pretty long.
Not as happy as I thought I was going to be. Seems that there are some things that still need to be tweaked some.
Seems many Movies and TVs were renamed incorrectly. I had other things on that drive that I didn't realize was hidden within some of the folders. Like old programs and old family photos and other personal documents.
So at this point I this I was revert everything done last night and buckle down and manually start going to work on these. I think it will take me long time doing it manually but I really care get a script that does everything I need it to. I have given my examples of what my drives look like and folders and given screen shops and repeated many many times what kinda script I needed it to do what I needed it to do and no one has come along and just been my savior. I have legit spent SOOO much time, OVER a month on working on using filebot and I can't find a single person that would reach out and work with me to get this knocked out. I will admit that rednoah, you have really helped me gain a lot of knowledge directing and sending me to different links to forums over and over again to reread them. Not trying to be a downer about it, I have just got to the point that this isn't working for me and it seems I have wasted my money and dreams on the program to save me from this chaos. I'm just really tired of hoping for the impossible and this be fixed when I excute a command that the developer says will work it, it doesn't. So going manual seems to be my only go to now, I'm amazed that no one has offered me any much help in these forums after they have read how much I am struggling with, noto to mention I offered anyone $$$ to help me get this done, $ for their time to help me get this all situated for me, and no one really wants to just work with me and get it knocked out. Sorry just really in the dumps right now because I can't get things :(

After running script last night I see a lot of mismatched. I see a lot that I do not like.

Another thing is while I have been renaming manually I have seen that the when I am in the console using rename will move my files from F: drive to C:\Users\E\Media which is a big no no. My media all stays on F:. I have searched forums and player around looking on the internet but all the pref log files I came across doesn't have a place that shows anything about %appdata% where I am able to change destination folder.. Maybe I am just that tired, worn out, tired, and missing it somewhere. I havent got much sleep over the week end due to really trying to focus on being done with this mess

I know you need error logs and such and I will get them to you soon, Apologize, I am just extremely bummed about burning the last 3 days on this month long craze I have going on here and I am very tired.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 01 Apr 2019, 04:51

I will explain in better details tomorrow if above isn't explained very well. I am super tired and can barely keep my eyes open or make sense when typing. Will add details about it, when I wake up and have a fully working brain. Sorry if some of the things above don't make sense. Pushed myself these last 3 days to have this finished and I have failed and wasted my last 3 days off I'll have for awhile :( :(

User avatar
rednoah
The Source
Posts: 15527
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by rednoah » 01 Apr 2019, 04:56

Sorry to hear that.

But without commands & console logs not much we can do here in terms of troubleshooting.

Like I said. Best to work with a small example folder, make sure everything works, expand your test case with more and more tricky example, only run things on your entire structure once you've got a good grasp on how it works through your tests.

That being said, there is no shame in using the GUI, especially if it's effectively a one-off task.
:idea: Please read the FAQ and How to Request Help.

GtownE
Posts: 18
Joined: 17 Mar 2019, 19:26

Re: (Noob ALERT!!) - Needing some help! - (Would be SO GRATEFUL!!)

Post by GtownE » 01 Apr 2019, 05:03

Can you please tell me why my renaming files through the GUI are being sent to C:\Users\E\Media instead of on the F: Drive? Do I need to type a cmd in order to change that? I dont see any settings within filebot to change such.

I would also like to know which logs would best help you understand my current state of chaos right now? I will make sure I post them tomorrow for you and anyone else wanting to chime in and have a gander.
No rush responding, Im actually on my way out right now, can't keep my eyes open and got an extremely long day at work tomorrow that starts in 6 hours.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests