[OpenSubtitles] 401 Unauthorized

Any questions? Need some help?
Post Reply
User avatar
rednoah
The Source
Posts: 23142
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

[OpenSubtitles] 401 Unauthorized

Post by rednoah »

FileBot 4.9.4 and earlier only store the MD5 hash of the password you enter via filebot -script fn:configure and thus uses the MD5 hash as password, instead of sending your password verbatim over the internet.

Subtitles API wrote:Important: for security improvement, you can use HTTPS and/or send $password as MD5($password) hash.
https://trac.opensubtitles.org/projects ... LRPC#LogIn


Presumably, this mode of login is no longer possible due to server-side changes in how passwords are stored and verified:
https://forum.opensubtitles.org/viewtopic.php?t=17685

Error: Select all

401 Unauthorized
redstone.xmlrpc.XmlRpcFault: 401 Unauthorized
      at net.filebot.web.OpenSubtitlesXmlRpc.checkResponse(Unknown Source)
      at net.filebot.web.OpenSubtitlesXmlRpc.invoke(Unknown Source)
      ...
      net.filebot.web.OpenSubtitlesXmlRpc.login(Unknown Source)
      ...



UPDATE: 20 Jan 2022
• The configure script has been updated and will now correctly configure the OpenSubtitles login details for all FileBot 4.* versions, so filebot -script fn:configure will just work again.
• The Image Login button in the GUI no longer works in older versions, but you can use filebot -script fn:configure from the command-line instead. The entered login details will work for both GUI and CLI. Please press WIN+R and then paste filebot -script fn:configure to run the command.



UPDATE: 28 Mar 2022
• You must use your username and password from www.opensubtitles.org (main site) and not www.opensubtitles.com (beta site) because login details are not interchangeable between the two sites.
:idea: Please read the FAQ and How to Request Help.
GavG
Posts: 1
Joined: 16 Jun 2023, 23:11

Re: [OpenSubtitles] 401 Unauthorized

Post by GavG »

Hello! Just chiming in to hopefully help others in my situation down the line:

I've run the command from the March 28th update edit. I've paid for VIP for both OpenSubtitles dot com and dot org (I originally was only on .com for my Jellyfin server but having Filebot auto-download for TV show episodes would be a GODSEND to be able to verify the subs work before uploading them to the server). No matter what I do, I'm still getting the 401 Unauthorized in Filebot. Is this a known issue? I've gone as far as to re-install FB to log in from a fresh copy.
User avatar
rednoah
The Source
Posts: 23142
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [OpenSubtitles] 401 Unauthorized

Post by rednoah »

OpenSubtitles login works with FileBot 5.* at this moment in time:

Console Output: Select all

$ filebot -script fn:configure --def osdbUser="YOUR_USERNAME" --def osdbPwd="YOUR_PASSWORD"
Set OpenSubtitles login details
Checking... OK

limit_check_by: user_id
...
global_24h_download_limit: 200
...
client_24h_download_count: 0
client_download_quota: 200
:idea: Please read the FAQ and How to Request Help.
Post Reply