[FreeBSD] MediaInfo bindings not working

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
generic123
Posts: 2
Joined: 17 May 2019, 09:21

[FreeBSD] MediaInfo bindings not working

Post by generic123 » 17 May 2019, 09:26

Hi all,

sysinfo

Code: Select all

FileBot 4.8.5 (r6224)
JNA Native: 5.2.2
MediaInfo: net.filebot.mediainfo.MediaInfoException: Unable to load amd64 (64-bit) native library libmediainfo.so: Unable to load library 'mediainfo': Native li                                           brary (freebsd-x86-64/libmediainfo.so) not found in resource path ([file:/usr/local/etc/filebot/jar/filebot.jar])
p7zip: java.io.IOException: Cannot run program "7z": error=2, No such file or directory
FFprobe: java.io.IOException: Cannot run program "ffprobe": error=2, No such file or directory
Chromaprint: java.io.IOException: Cannot run program "fpcalc": error=2, No such file or directory
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2019-05-15 (r565)
Groovy: 2.5.6
JRE: OpenJDK Runtime Environment 1.8.0_212
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 4 Core / 902 MB Max Memory / 16 MB Used Memory
OS: FreeBSD (amd64)
HW: FreeBSD transmission 11.2-STABLE FreeBSD 11.2-STABLE #0 r325575+95cc58ca2a0(HEAD): Fri May 10 15:57:35 EDT 2019     [email protected]:/freenas-rele                                           ng/freenas/_BE/objs/freenas-releng/freenas/_BE/os/sys/FreeNAS.amd64  amd64
DATA: /usr/local/etc/filebot/data/root
Package: TAR
License: FileBot License P7XXXXXX (Valid-Until: 2020-05-23)
attempted script

Code: Select all

./filebot.sh -script fn:amc --output "/media/" --mode interactive --format "{plex.derive{" [$vf.$vc.$ac]"}}" --action duplicate "/mnt/torrents/completed" --log-file amc.log  
I want the standard plex file structure but details of quality included in the file name, I did a google and posts on the forum indicated this may work.
Movies/Avatar (2009)/Avatar (2009) [720p, x264, AC3]

I am getting "vf: Undefined variable.".

I am really new here so fully expecting that I have misunderstood something. If there are resources on this already I havent found them, but would appreciate being pointed in the right direction!

Cheers.

User avatar
rednoah
The Source
Posts: 15813
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: CLI attempting to use $vf

Post by rednoah » 17 May 2019, 10:54

1.
libmediainfo.so is not working on your machine, which means that MediaInfo bindings won't work:

Code: Select all

MediaInfo: net.filebot.mediainfo.MediaInfoException: Unable to load amd64 (64-bit) native library libmediainfo.so
You could try to make it work. Google will help. Maybe your distribution provides a working libmediainfo.so that you can just install and use. Maybe the one that's included in the TAR package works, but doesn't due to missing dependencies.


2.
The easiest solution is to just use docker:
https://hub.docker.com/r/rednoah/filebot/
:idea: Please read the FAQ and How to Request Help.

generic123
Posts: 2
Joined: 17 May 2019, 09:21

Re: [FreeBSD] MediaInfo bindings not working

Post by generic123 » 20 May 2019, 14:32

Thanks for that. That fixed the issue.

I installed MediaInfo by using

Code: Select all

pkg install mediainfo
Cheers.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests