Page 1 of 1

Filebot: Node. Lastest Docker failing to start.

Posted: 29 Sep 2026, 15:51
by vdera
Just updated to the newest build and the container is failing to start, noting an issue with PUID.

sudo: preserving the entire environment is not supported, '--preserve-env' is ignored
/opt/filebot-node/start: 7: PUID: parameter not set

Docker Compose:

Code: Select all

filebot-node:
    image: rednoah/filebot:node
    container_name: filebot-node
    hostname: filebot-node
    profiles:
      - torrents
    networks:
      - vdera_bridge
    restart: unless-stopped
    environment:
      - PUID=996
      - PGID=1001
      - FILEBOT_NODE_AUTH=BASIC
      - FILEBOT_NODE_AUTH_USER=****
      - FILEBOT_NODE_AUTH_PASS=****
    volumes:
      - '/home/vdera/config/filebot-node:/data'
      - '/home/vdera:/home/vdera'
      - '/home/vdera/config/filebot/filebotlicense.psm:/data/filebot/license.txt'
    ports:
      - "5452:5452"

Re: Filebot: Node. Lastest Docker failing to start.

Posted: 29 Sep 2026, 15:55
by vdera
Looks like there's been another update. I've re-pulled the image and it appears to be working again!

Re: Filebot: Node. Lastest Docker failing to start.

Posted: 29 Sep 2026, 16:02
by rednoah
Yep, Ubuntu 26.04 seems to have replaced sudo with sudo-rs which is not fully compatible. We may have to revert to Ubuntu 24.04 for the base image.

Re: Filebot: Node. Lastest Docker failing to start.

Posted: 29 Sep 2026, 16:29
by vdera
rednoah wrote: Today, 16:02 Yep, Ubuntu 26.04 seems to have replaced sudo with sudo-rs which is not fully compatible. We may have to revert to Ubuntu 24.04 for the base image.
Hey - thanks for the fast response! Glad it's working again; I'd only just got my Docker setup fully working and was sad when it broke :(