Collection language sometimes wrong

Support for Windows 10 users and the Microsoft Store package
Post Reply
Bazzu85
Posts: 44
Joined: 16 Nov 2016, 19:28

Collection language sometimes wrong

Post by Bazzu85 »

Here's my actual script:

Code: Select all

{f[0..1]}/
{
	String x = self.collection ?: n;
	x = x.charAt(0)
	ArrayList<String> array = new ArrayList<String>()
	array.add('1')
	array.add('2')
	array.add('3')
	array.add('4')
	array.add('5')
	array.add('6')
	array.add('7')
	array.add('8')
	array.add('9')
	array.add('0')
	array.add('[')
	array.add('.')
	array.add('(')
	if ( array.contains(x))'#' else x}
/{ny.replace(':','').replace('?','')}
{if (self.collection > '') (' [' + collection.replace(':','').replace('?','') + ']') else ''}
/ {n.replace(':','').replace('?','') /*n.replaceFirst(/^(?i)(The|)\s(.+)/, /$2, $1/)*/} ({y})
{
	ArrayList<String> array = new ArrayList<String>()
	array.add('VERSIONE INTEGRALE');
	array.add('EXTENDED');
	array.add('ULTIMATE EDITION');
	array.add('DIRECTOR\'S CUT');
	array.add('UNRATED');
	for (int i=0; i < array.size(); i++){
		if (fn.contains(array.get(i))){
			return ' [' + array.get(i) + '] '
		}
	}
}
 [{if (source != '') source else ''}{if (vf != '') ' ' + vf else ''}
{if (vc == 'x265' || vc == 'HEVC') ' HEVC' else if (vc == 'AVC') ' x264' else ' '+vc}] {if(audioLanguages != '') '[' + audioLanguages.collect { i -> "$i" }.join('+').upper().replace('ZHO', 'CHI') + ']'}
BTW I'm seeing in certain movies that I request italian infos and the Collection name is retrieved in english.
fObviously checking on tmdb the collection is translated and for the actual example the italian translation is not touched from 2016
https://www.themoviedb.org/collection/1 ... on/changes

how can be resolved?
are there some cache issue or something similar?
here's a couple of screens: https://imgur.com/a/HdjbNi0
thx
Bazzu85
Posts: 44
Joined: 16 Nov 2016, 19:28

Re: Collection language sometimes wrong

Post by Bazzu85 »

additionally trying the second Pocahontas movie the collection is correctly grabbed in italian:
https://imgur.com/a/JzyRRoV
User avatar
rednoah
The Source
Posts: 19917
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Collection language sometimes wrong

Post by rednoah »

Looks like requesting information with language=it instead of language=it-IT somehow makes TheMovieDB return English search results sometimes. I'll look into it.


EDIT:

FileBot r8700 should work better.
:idea: Please read the FAQ and How to Request Help.
Bazzu85
Posts: 44
Joined: 16 Nov 2016, 19:28

Re: Collection language sometimes wrong

Post by Bazzu85 »

rednoah wrote: 24 Jun 2021, 12:08 Looks like requesting information with language=it instead of language=it-IT somehow makes TheMovieDB return English search results sometimes. I'll look into it.


EDIT:

FileBot r8700 should work better.
thx, how can I update to r8700?
User avatar
rednoah
The Source
Posts: 19917
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Collection language sometimes wrong

Post by rednoah »

:idea: Please read the FAQ and How to Request Help.
Bazzu85
Posts: 44
Joined: 16 Nov 2016, 19:28

Re: Collection language sometimes wrong

Post by Bazzu85 »

rednoah wrote: 24 Jun 2021, 13:16 :arrow: viewtopic.php?t=1609
thx, what about the installation version? are there only the portable one for windows?
edit: sorry, I didn't read the 2nd point
Post Reply