Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Support for Windows 10 users and the Microsoft Store package
Post Reply
Yousty
Posts: 11
Joined: 07 Mar 2017, 13:40

Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Yousty »

So I have been happily using Filebot for several years now and decided to pay for the version in the Windows app store to support you guys. However one thing I would always change after installing new versions was to go into the filebot.l4j.ini file and edit the line DuseExtendedFileAttributes from "true" to "false" because I transfer my files to Unraid which doesn't support NTFS extended attributes. Unfortunately in Windows 10 it appears that this is now impossible to do because no matter what Security settings you change in Windows it will not let you modify any files in the C:\Program Files\WindowsApps folder which is where Filebot gets automatically installed.

Is there any way I can disable NTFS extended attributes?
User avatar
rednoah
The Source
Posts: 19349
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by rednoah »

What's the problem? If you copy files with xattr to a filesystem that doesn't support xattr, then the xattr will just get silently lost.
:idea: Please read the FAQ and How to Request Help.
Yousty
Posts: 11
Joined: 07 Mar 2017, 13:40

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Yousty »

Because every single time I go to copy a file to Unraid that was renamed using FileBot I get the popup window "Are you sure you want to copy this file without its properties?" and I have to click Yes. For somebody who is copying dozens of files every day that is unbelievably annoying.
User avatar
rednoah
The Source
Posts: 19349
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by rednoah »

Strange. I don't get that behaviour when copying files from NTFS drives to FAT drives.

If you really need to disable xattr (not recommended), then you can pass in system properties via the JAVA_OPTS environment variable.

i.e. open CMD and run this:

Code: Select all

setx JAVA_OPTS -DuseExtendedFileAttributes=false
:idea: Please read the FAQ and How to Request Help.
Yousty
Posts: 11
Joined: 07 Mar 2017, 13:40

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Yousty »

I ran that command, restarted Windows, renamed a file in FileBot, tried copying it to Unraid and am still getting the popup window :(
User avatar
rednoah
The Source
Posts: 19349
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by rednoah »

What does the sysinfo output say?

EDIT:

Setting JAVA_OPTS does indeed not seem to have any effect anymore. Unfortunately, that means that you won't be able to disable xattr via environment variables.

You can create a New Shortcut and then use this command though:

Code: Select all

filebot.launcher.exe -no-xattr
:idea: Please read the FAQ and How to Request Help.
Yousty
Posts: 11
Joined: 07 Mar 2017, 13:40

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Yousty »

rednoah wrote: You can create a New Shortcut and then use this command though:

Code: Select all

filebot.launcher.exe -no-xattr
That worked!!! Thank you SO much for your help! This solution also means that I won't have to go in and edit the filebot.l4j.ini every time a new version gets installed anymore either. :D
User avatar
rednoah
The Source
Posts: 19349
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by rednoah »

Nice! Yep, modifying the install directory was never a good idea. :P
:idea: Please read the FAQ and How to Request Help.
Haroldkidd
Posts: 3
Joined: 28 May 2018, 20:53

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Haroldkidd »

I’m sorry I’m new to all of this and I’m having the same issue copying to my unraid server. What are the steps to go about this, making a shortcut to where and how do you enter the cmd. Sorry I’m not real savvy
You can create a New Shortcut and then use this command though:

Code: Select all

filebot.launcher.exe -no-xattr
User avatar
rednoah
The Source
Posts: 19349
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by rednoah »

The correct way of passing additional command-line options is using the FILEBOT_OPTS environment variable. FILEBOT_OPTS will automatically be added to any FileBot command / launch.

You can set environment variables via the Windows Settings GUI, or via CMD:

Code: Select all

setx FILEBOT_OPTS -no-xattr
:idea: Please read the FAQ and How to Request Help.
Yousty
Posts: 11
Joined: 07 Mar 2017, 13:40

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Yousty »

rednoah wrote: 02 Jun 2018, 05:07 The correct way of passing additional command-line options is using the FILEBOT_OPTS environment variable. FILEBOT_OPTS will automatically be added to any FileBot command / launch.

You can set environment variables via the Windows Settings GUI, or via CMD:

Code: Select all

setx FILEBOT_OPTS -no-xattr
So I ran the suggested command in CMD and now Filebot won't even launch. I get a popup saying:
Error. Could not create the Java Virtual Machine.
Error. A fatal exception has occurred. Program will exit.

Help!

Edit: I was able to find the environment variable and delete and now Filebot is loading again. Any suggestions on what I did wrong or how I can disable xattr in Filebot?
Yousty
Posts: 11
Joined: 07 Mar 2017, 13:40

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Yousty »

Would it be possible to add a setting in Filebot's settings to disable xattr? It is so annoying having to hit yes on a popup box every single time I transfer a file to my unraid NAS (which is dozens of times per day). I used to be able to use one of the workarounds above but none seem to work anymore.
User avatar
rednoah
The Source
Posts: 19349
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by rednoah »

1.
What version of Windows are you using?


2.
I recommend trying the latest FileBot 4.8.5 pre-release build. You can use the new -Dnet.filebot.xattr.store=.xattr option to store xattr as plain text files instead of NTFS alternative streams.

Code: Select all

setx FILEBOT_OPTS -Dnet.filebot.xattr.store=.xattr

3.
You can strip existing xattr with the xattr script:
viewtopic.php?f=4&t=5
:idea: Please read the FAQ and How to Request Help.
Yousty
Posts: 11
Joined: 07 Mar 2017, 13:40

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Yousty »

1. Windows 10

I purchased Filebot through the Windows app store, how do I get a license key to be able to try out the pre-release build?
User avatar
rednoah
The Source
Posts: 19349
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by rednoah »

I see. Let's work with FileBot 4.8.2 then. In that case you can just disable xattr like so:

Code: Select all

setx FILEBOT_OPTS -DuseExtendedFileAttributes=false
:idea: Please read the FAQ and How to Request Help.
Yousty
Posts: 11
Joined: 07 Mar 2017, 13:40

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by Yousty »

rednoah wrote: 15 Feb 2019, 19:06 I see. Let's work with FileBot 4.8.2 then. In that case you can just disable xattr like so:

Code: Select all

setx FILEBOT_OPTS -DuseExtendedFileAttributes=false
That worked! Thank you so much!!!
User avatar
rednoah
The Source
Posts: 19349
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Windows 10 - Disable NTFS Extended Attributes for Storing Metadata?

Post by rednoah »

You're welcome. :)

Once 4.8.5 is released, and auto-updates via the Store, then I recommend enabling xattr but storing them to plain text files as previously discussed.
:idea: Please read the FAQ and How to Request Help.
Post Reply