deluge not calling the deluge-postprocess script

Support for Ubuntu and other Desktop Linux distributions
Post Reply
hieste
Posts: 1
Joined: 27 Mar 2021, 06:48

deluge not calling the deluge-postprocess script

Post by hieste »

Hi. I checked the forum and found a similar issue, but mine is slightly different. I'm not running as root as the last post was.

When I run the run from the command line:

Code: Select all

filebot -script fn:amc --output "/home/hieste/Media" --action duplicate -non-strict "/home/hieste/torrents/deluge/download/complete" --log-file amc.log --def excludeList=amc.txt
Every thing works OK and sorts the files appropriately.


When I use the directions from the deluge install (CLI) my post-process file located at /home/hieste is:

Code: Select all

#!/bin/sh -xu

# Input Parameters
ARG_PATH="$3/$2"
ARG_NAME="$2"
ARG_LABEL="N/A"

# Configuration
CONFIG_OUTPUT="/home/hieste/Media" # if this script is called by the deluge user, then $HOME will NOT refer to YOUR user home, but paths such as /var/lib/deluge instead

filebot -script fn:amc --output "$CONFIG_OUTPUT" --action duplicate --conflict skip -non-strict --log-file amc.log --def unsorted=y music=y artwork=y excludeList=".excludes" ut_dir="$ARG_PATH" ut_kind="multi" ut_title="$ARG_NAME" ut_label="$ARG_LABEL"
The execute plugin in deluge is directed towards /home/hieste/deluge-postprocess.sh at completion of the download. Deluge is set up to download into incomplete and move to complete when finished.

For some reason it won't trigger the script at completion.

Here is my sysinfo:

Code: Select all

[[email protected]]:(1.1kb)~$ filebot -script fn:sysinfo
FileBot 4.9.3 (r8340)
JNA Native: 6.1.0
MediaInfo: 20.09
7-Zip-JBinding: 16.02
Tools: fpcalc/1.4.3
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2021-02-22 (r738)
Groovy: 3.0.7
JRE: OpenJDK Runtime Environment 11.0.10
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 8 Core / 4.1 GB Max Memory / 31 MB Used Memory
OS: Linux (amd64)
HW: Linux Dasboot 5.4.0-65-generic #73-Ubuntu SMP Mon Jan 18 17:25:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
CPU/MEM: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz [MemTotal: 16 GB | MemFree: 169 MB | MemAvailable: 13 GB | SwapCached: 5.0 MB | SwapTotal: 17 GB | SwapFree: 17 GB]
STORAGE: ext4 [/] @ 5 TB
USER: hieste
DATA: /home/hieste/filebot-portable/data/1000
Package: TAR
License: FileBot License PX23102362 (Valid-Until: 2071-02-17)
Done ヾ(@⌒ー⌒@)ノ
My only clue is in the filebot -script fn:log. It shows all the content moved via the console script, but at the end it says:

Code: Select all

/home/hieste/filebot-portable/data/1000/logs/error.log'
I've tried to open it, but there doesn't seem to be anything there.

Any suggestions on how to get deluge to execute the script?
User avatar
rednoah
The Source
Posts: 19585
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: deluge not calling the deluge-postprocess script

Post by rednoah »

I'd start by checking if Deluge is calling your code, or not:
viewtopic.php?t=3067

If Deluge is indeed not calling your code, then you'll want to ask the Deluge community for troubleshooting advice. I'd expect Deluge keep a log file somewhere that might shed some light on the issue.
:idea: Please read the FAQ and How to Request Help.
Post Reply