"Load" Button does not work (Linux Mint 19.1)

Support for Ubuntu and other Desktop Linux distributions
Post Reply
Burdarper
Posts: 4
Joined: 23 May 2019, 06:25

"Load" Button does not work (Linux Mint 19.1)

Post by Burdarper » 23 May 2019, 07:03

Hello everybody,

in order to finally get completely rid of windows I also wanted to install filebot to linux.

I did so via commands:

Code: Select all

bash -xu <<< "$(curl -fsSL https://raw.githubusercontent.com/filebot/plugins/master/installer/deb.sh)"
check up with:

Code: Select all

sudo apt-get install filebot   
( 0 missing )

continueing with command:

Code: Select all

sudo apt-get install openjfx
and starting with command:

Code: Select all

filebot

giving out this java error

Code: Select all

Failed to initialize JavaFX
java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel
	at net.filebot.util.ui.SwingUI.initJavaFX(SwingUI.java:582)
	at net.filebot.Main.onStart(Main.java:196)
	at net.filebot.Main.lambda$null$0(Main.java:162)
	at net.filebot.util.ui.SwingUI$SwingRunnable.doInBackground(SwingUI.java:472)
	at net.filebot.util.ui.SwingUI$SwingRunnable.doInBackground(SwingUI.java:462)
Caused by: java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
	... 5 more
The program is starting, but the load button below the "original files" section is not reacting.


Java --version sais:

openjdk 11.0.3 2019-04-16
OpenJDK Runtime Environment (build 11.0.3+7-Ubuntu-1ubuntu218.04.1)
OpenJDK 64-Bit Server VM (build 11.0.3+7-Ubuntu-1ubuntu218.04.1, mixed mode)

and changing them via

Code: Select all

sudo update-alternatives --config java
also showed no effect.

Could anyone please help me out here ?

Greetings
Thomas

User avatar
rednoah
The Source
Posts: 16434
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: "Load" Button does not work (Linux Mint 19.1)

Post by rednoah » 23 May 2019, 07:32

What version of OpenJFX is being used on your platform?
:idea: Please read the FAQ and How to Request Help.

Burdarper
Posts: 4
Joined: 23 May 2019, 06:25

Re: "Load" Button does not work (Linux Mint 19.1)

Post by Burdarper » 23 May 2019, 11:55

Hello, thank you for your answer.

I assume its the latest one:11.0.2+1-1~18.04.2

Code: Select all

[email protected]:~$ sudo apt-get install openjfx
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
openjfx ist schon die neueste Version (11.0.2+1-1~18.04.2).

User avatar
rednoah
The Source
Posts: 16434
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: "Load" Button does not work (Linux Mint 19.1)

Post by rednoah » 23 May 2019, 14:16

That should work out of the box then. Strange.


What's the output for these commands?


Check OpenJFX package details:

Code: Select all

apt-cache show openjfx
Check OpenJFX install folder:

Code: Select all

tree /usr/share/openjfx/lib
Check FileBot launcher script:

Code: Select all

cat `which filebot` | grep MODULE_PATH
:idea: Please read the FAQ and How to Request Help.

Burdarper
Posts: 4
Joined: 23 May 2019, 06:25

Re: "Load" Button does not work (Linux Mint 19.1)

Post by Burdarper » 23 May 2019, 17:15

Code: Select all

[email protected]:~$ apt-cache show openjfx
Package: openjfx
Architecture: amd64
Version: 11.0.2+1-1~18.04.2
Priority: optional
Section: universe/java
Origin: Ubuntu
Maintainer: Debian Java Maintainers <[email protected]>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 30
Depends: libopenjfx-java
Recommends: openjfx-source
Filename: pool/universe/o/openjfx/openjfx_11.0.2+1-1~18.04.2_amd64.deb
Size: 9032
MD5sum: a00d06f94dcfa8b579065f958dd76027
SHA1: d875edfa1ed5beb651dd8e90f8bea56c133e85af
SHA256: 0feec068c025efee496e34af33238422fc506fdbfcec6a4e334d228a07d38ea6
Homepage: https://openjfx.io
Description-en: JavaFX/OpenJFX - Rich client application platform for Java
 JavaFX/OpenJFX is a set of graphics and media APIs that enables Java developers
 to design, create, test, debug, and deploy rich client applications that
 operate consistently across diverse platforms.
Description-md5: c81023d9b26926c1219881c76843995a

Package: openjfx
Architecture: amd64
Version: 8u161-b12-1ubuntu2
Priority: optional
Section: universe/java
Origin: Ubuntu
Maintainer: Ubuntu Developers <[email protected]>
Original-Maintainer: Debian Java Maintainers <[email protected]>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 76
Depends: libopenjfx-java, openjdk-8-jre
Filename: pool/universe/o/openjfx/openjfx_8u161-b12-1ubuntu2_amd64.deb
Size: 33636
MD5sum: 24c95f135a166dcf06d00942dc496a6e
SHA1: bb91d4dad8de36a66c30991afb6c0bdbad7875ef
SHA256: b421da0f5d47014c0a6f833bb61e010e99cb1653e628d74553b10dbe81e1ba34
Homepage: http://openjdk.java.net/projects/openjfx/
Description-en: JavaFX/OpenJFX 8 - Rich client application platform for Java
 JavaFX/OpenJFX is a set of graphics and media APIs that enables Java developers
 to design, create, test, debug, and deploy rich client applications that
 operate consistently across diverse platforms.
Description-md5: 14290b0606b913e5c6a77c5ac642635d

Code: Select all

[email protected]:~$ tree /usr/share/openjfx/lib
/usr/share/openjfx/lib
├── javafx.base.jar -> ../../java/javafx-base.jar
├── javafx.controls.jar -> ../../java/javafx-controls.jar
├── javafx.fxml.jar -> ../../java/javafx-fxml.jar
├── javafx.graphics.jar -> ../../java/javafx-graphics.jar
├── javafx.media.jar -> ../../java/javafx-media.jar
├── javafx.properties
├── javafx.swing.jar -> ../../java/javafx-swing.jar
└── javafx.web.jar -> ../../java/javafx-web.jar

0 directories, 8 files

Code: Select all

[email protected]:~$ cat `which filebot` | grep MODULE_PATH

#Anm.: das gab kein Ergebnis, daher : 

[email protected]:~$ cat `which filebot`
#!/bin/sh
FILEBOT_HOME="/usr/share/filebot"

if [ -z "$HOME" ]; then
	echo '$HOME must be set'
	exit 1
fi

# select application data folder
APP_DATA="$HOME/.filebot"

# select libjnidispatch.system.so from $(uname -m)-linux-gnu folder
LIBRARY_PATH=$(echo /usr/lib/*-linux-gnu*/jni | tr ' ' ':')

java -Dapplication.deployment=deb -Djna.boot.library.name=jnidispatch.system -Dnet.filebot.archive.extractor=ShellExecutables -Dunixfs=false -DuseExtendedFileAttributes=true -DuseCreationDate=false -Djava.net.useSystemProxies=true -Djna.nosys=true -Djna.nounpack=true -Djna.boot.library.path="$LIBRARY_PATH" -Djna.library.path="$LIBRARY_PATH" -Djava.library.path="$LIBRARY_PATH" -Dapplication.dir="$APP_DATA" -Dapplication.cache="$APP_DATA/cache" -Djava.io.tmpdir="$APP_DATA/tmp" -Dfile.encoding="UTF-8" -Dsun.jnu.encoding="UTF-8" -Dnet.filebot.UserFiles.fileChooser=JavaFX -DuseGVFS=true -Dnet.filebot.gio.GVFS="$XDG_RUNTIME_DIR/gvfs" $JAVA_OPTS $FILEBOT_OPTS -jar "$FILEBOT_HOME/jar/filebot.jar" "[email protected]"

User avatar
rednoah
The Source
Posts: 16434
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: "Load" Button does not work (Linux Mint 19.1)

Post by rednoah » 23 May 2019, 17:29

If you're using Java 11, then you need the universal build, and not the universal-jdk8 build:
viewtopic.php?f=11&t=6028

What does the output say?

Code: Select all

bash -xu <<< "$(curl -fsSL https://raw.githubusercontent.com/filebot/plugins/master/installer/deb.sh)"
The very first line should ensure that you're getting the right repository, so I'm not sure what went wrong there:
https://github.com/filebot/plugins/blob ... /deb.sh#L4
:idea: Please read the FAQ and How to Request Help.

Burdarper
Posts: 4
Joined: 23 May 2019, 06:25

Re: "Load" Button does not work (Linux Mint 19.1)

Post by Burdarper » 23 May 2019, 22:14

Hi,

here is the output and it solved the problem ;-) thank you very much.

Code: Select all

[email protected]:~$ bash -xu <<< "$(curl -fsSL https://raw.githubusercontent.com/filebot/plugins/master/installer/deb.sh)"
+ apt-cache show openjfx --no-all-versions
+ grep 'Version: 8'
+ REPO='deb [arch=all] https://get.filebot.net/deb/ universal main'
+ echo 'Use Repository: deb [arch=all] https://get.filebot.net/deb/ universal main'
Use Repository: deb [arch=all] https://get.filebot.net/deb/ universal main
+ sudo apt-get install -y dirmngr gnupg-curl
[sudo] Passwort für burdarper:             
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket gnupg-curl kann nicht gefunden werden.
+ sudo apt-key adv --fetch-keys https://raw.githubusercontent.com/filebot/plugins/master/gpg/maintainer.pub
Executing: /tmp/apt-key-gpghome.N879YTijlX/gpg.1.sh --fetch-keys https://raw.githubusercontent.com/filebot/plugins/master/gpg/maintainer.pub
gpg: fordere Schlüssel von https://raw.githubusercontent.com/filebot/plugins/master/gpg/maintainer.pub an
gpg: key 4E402EBF7C3C6A71: 4 Beglaubigungen wegen fehlender Schlüssel nicht geprüft
gpg: Schlüssel 4E402EBF7C3C6A71: "Reinhard Pointner <[email protected]>" nicht geändert
gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
gpg:              unverändert: 1
+ echo 'deb [arch=all] https://get.filebot.net/deb/ universal main'
+ sudo tee /etc/apt/sources.list.d/filebot.list
deb [arch=all] https://get.filebot.net/deb/ universal main
+ sudo apt-get update
OK:1 http://ftp-stud.hs-esslingen.de/ubuntu bionic InRelease
OK:2 http://linux.teamviewer.com/deb stable InRelease                          
Ign:3 http://mirror.bauhuette.fh-aachen.de/linuxmint tessa InRelease           
Holen:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]  
OK:5 http://ftp-stud.hs-esslingen.de/ubuntu bionic-updates InRelease           
OK:6 http://archive.canonical.com/ubuntu bionic InRelease                      
OK:7 http://repo.steampowered.com/steam precise InRelease                      
OK:8 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease     
OK:9 http://mirror.bauhuette.fh-aachen.de/linuxmint tessa Release              
OK:10 http://ftp-stud.hs-esslingen.de/ubuntu bionic-backports InRelease        
Ign:11 http://dl.google.com/linux/chrome/deb stable InRelease                  
OK:12 http://ppa.launchpad.net/lutris-team/lutris/ubuntu bionic InRelease      
OK:13 https://deb.opera.com/opera-stable stable InRelease                      
OK:14 http://dl.google.com/linux/chrome/deb stable Release                     
Ign:17 http://download.virtualbox.org/virtualbox/debian tessa InRelease        
Ign:18 https://get.filebot.net/deb universal InRelease
Holen:19 https://get.filebot.net/deb universal Release [1.160 B]
Fehl:20 http://download.virtualbox.org/virtualbox/debian tessa Release
  404  Not Found [IP: 2.19.100.195 80]
Holen:21 https://get.filebot.net/deb universal Release.gpg [862 B]
Holen:22 https://get.filebot.net/deb universal/main all Packages [544 B]
Paketlisten werden gelesen... Fertig
E: Das Depot »http://download.virtualbox.org/virtualbox/debian tessa Release« enthält keine Release-Datei.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).
+ sudo apt-get install -y filebot
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libclass-data-inheritable-perl libcrypt-openssl-bignum-perl
  libcrypt-openssl-rsa-perl libdata-random-perl libfile-which-perl
  libgnome2-canvas-perl libgnome2-gconf-perl libgnome2-perl libgnome2-vfs-perl
  libgnome2-wnck-perl libgtk2-imageview-perl libgtk2-unique-perl
  libgtkimageview0 libhttp-server-simple-perl libimage-magick-perl
  libimage-magick-q16-perl libjson-perl libmouse-perl libnet-dropbox-api-perl
  libnet-oauth-perl libpath-class-perl libproc-processtable-perl
  libproc-simple-perl libsort-naturally-perl libunique-1.0-0
  libwine-development libwnck-common libwnck22 libwww-mechanize-perl
  libx11-protocol-other-perl wine64-development
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Empfohlene Pakete:
  mediainfo libchromaprint-tools
Die folgenden Pakete werden aktualisiert (Upgrade):
  filebot
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 17 nicht aktualisiert.
Es müssen 25,4 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 615 kB Plattenplatz freigegeben.
Holen:1 https://get.filebot.net/deb universal/main all filebot all 4.8.5 [25,4 MB]
Es wurden 25,4 MB in 21 s geholt (1.227 kB/s).                                 
(Lese Datenbank ... 316538 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../archives/filebot_4.8.5_all.deb ...
Entpacken von filebot (4.8.5) über (4.8.5) ...
Trigger für mime-support (3.60ubuntu1) werden verarbeitet ...
Trigger für desktop-file-utils (0.23+linuxmint5) werden verarbeitet ...
Trigger für shared-mime-info (1.9-2) werden verarbeitet ...
Trigger für gnome-menus (3.13.3-11ubuntu1.1) werden verarbeitet ...
filebot (4.8.5) wird eingerichtet ...
Trigger für hicolor-icon-theme (0.17-2) werden verarbeitet ...
[email protected]:~$ 

User avatar
rednoah
The Source
Posts: 16434
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: "Load" Button does not work (Linux Mint 19.1)

Post by rednoah » 24 May 2019, 03:19

I see. I've added --no-all-versions to the apt-cache show openjfx to make sure it doesn't choose the Version: 8 packages due to some older Java FX 8 packages being available in your repository.
:idea: Please read the FAQ and How to Request Help.

Post Reply