Snap no more working :(

Support for Ubuntu and other Desktop Linux distributions
Post Reply
vincen
Posts: 32
Joined: 12 Sep 2017, 07:25

Snap no more working :(

Post by vincen »

Hi

I'm using the 4.7.9 snap release on my Ubuntu 16.04 since weeks without problems. Suddenly today the app refuses to start with that error:

Code: Select all

[email protected]:~$ filebot 
failed to create prefix path: /tmp/snap.rootfs_jSwbZJ/var/lib/snapd/lib/vulkan/icd.d: Permission denied
[email protected]:~$ 
Even as root it's same problem so doesn't look to be really a permission problem ! I changed nothing on my system compared to yesterday out of regular system updates through apt !

Made some quich search on Internet but not much success :( Someone else with same problem ?

Thanks

Vincèn
User avatar
rednoah
The Source
Posts: 19127
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Snap no more working :(

Post by rednoah »

Looks like a snapd problem. Maybe you can get help if you ask the snapd developers?
:idea: Please read the FAQ and How to Request Help.
vincen
Posts: 32
Joined: 12 Sep 2017, 07:25

Re: Snap no more working :(

Post by vincen »

rednoah wrote: 25 Mar 2018, 11:07 Looks like a snapd problem. Maybe you can get help if you ask the snapd developers?
Yep it's a bug in latest update of snapd and here is temporary fix if other users have same problem (fix tested on Ubuntu 16.04):

Code: Select all

edit the apparmor profile of snap-confine in /etc/apparmor.d to be permissive (effectively switching them into complain mode). You can do that by editing the files so that they have the text ,complain just immediately after attach_disconnected. After doing that please run sudo apparmor_parser -r with the pathname of the file you edited.
Original post: https://forum.snapcraft.io/t/all-the-sn ... 8?u=vincen
User avatar
Mustang
Posts: 19
Joined: 07 Aug 2017, 15:50

Re: Snap no more working :(

Post by Mustang »

Unfortunately, I am having the same problems. I have spent the last 4 hours trying to fix snap. The internet is helpful, but not that helpful. To be honest snap has created more problems than any other package I use on Ubuntu.

rednoah, is there any way I can manually install Filebot. I'm tired of using snap. :(
vincen
Posts: 32
Joined: 12 Sep 2017, 07:25

Re: Snap no more working :(

Post by vincen »

Mustang wrote: 05 Apr 2018, 01:17 Unfortunately, I am having the same problems. I have spent the last 4 hours trying to fix snap. The internet is helpful, but not that helpful. To be honest snap has created more problems than any other package I use on Ubuntu.
Did you follow the explanations I gave above to fix the temporary problem ?
User avatar
rednoah
The Source
Posts: 19127
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Snap no more working :(

Post by rednoah »

Mustang wrote: 05 Apr 2018, 01:17 rednoah, is there any way I can manually install Filebot. I'm tired of using snap. :(
Unfortunately no, but you may be interested in supporting FileBot on Linux on Patreon to make things more easy in the future:
https://www.patreon.com/filebot
:idea: Please read the FAQ and How to Request Help.
vincen
Posts: 32
Joined: 12 Sep 2017, 07:25

Re: Snap no more working :(

Post by vincen »

rednoah wrote: 05 Apr 2018, 07:15Unfortunately no
In this case stop complaining and try it and see if it works ;)
rednoah wrote: 05 Apr 2018, 07:15but you may be interested in supporting FileBot on Linux on Patreon to make things more easy in the future:
https://www.patreon.com/filebot
Already a supporter since Filebot is on Patreon ;)
User avatar
Mustang
Posts: 19
Joined: 07 Aug 2017, 15:50

Re: Snap no more working :(

Post by Mustang »

vincen wrote: 05 Apr 2018, 04:46
Mustang wrote: 05 Apr 2018, 01:17 Unfortunately, I am having the same problems. I have spent the last 4 hours trying to fix snap. The internet is helpful, but not that helpful. To be honest snap has created more problems than any other package I use on Ubuntu.
Did you follow the explanations I gave above to fix the temporary problem ?
Sorry, vincen, I am not in the practice of using temporary fixes. I just want products to work as they were intended.

@rednoah, I have donated in the past, purchased on Windows and now contributing on Patreon. You have a great product and I will continue to do so mate! I realize this isn't a Filebot problem per se, but a Snap problem. It would be nice to free myself from Snap though. Thanks again for your time and hard work. And as I said in your Patreon post, please don't forget us Linux (Ubuntu) users.
vincen
Posts: 32
Joined: 12 Sep 2017, 07:25

Re: Snap no more working :(

Post by vincen »

Mustang wrote: 05 Apr 2018, 09:34Sorry, vincen, I am not in the practice of using temporary fixes. I just want products to work as they were intended.
In that case just wait for next update of snap daemon that will fix the problem ;)
Post Reply