no xattr written… no media info found

Support for macOS users and the Mac App Store package
Post Reply
keyman
Posts: 3
Joined: 25 Sep 2019, 19:22

no xattr written… no media info found

Post by keyman » 15 Feb 2020, 05:44

Hi
I am on mac os x 10.13.6
it seems filebot doesn't write any xattr (extended attribute) when renaming or using amc or even standalone filebot app.
So a lot of scripts dosn't work at all
ie:

Code: Select all

filebot -mediainfo -r /path/to/files
Failed to read xattr: ExceptionInInitializerError
then for every files I got blank space inside brakets like that:

Code: Select all

Parallels (2015) [    ]
Failed to read xattr: NoClassDefFoundError: Could not initialize class com.sun.jna.platform.mac.XAttr
OR
when I try to use filebot -script fn:mi
to get movies files info save as an TSV file
I only get the filename and the file size but no other media info...
and a lot of these error in my console :
Failed to read xattr: ExceptionInInitializerError
Failed to read xattr: NoClassDefFoundError: Could not initialize class com.sun.jna.platform.mac.XAttr


Here is my version info :

Code: Select all

filebot -version
FileBot 4.7.9 (r4984) / Java(TM) SE Runtime Environment 13.0.1 / Mac OS X 10.13.6 (x86_64)

java -version
java version "13.0.1" 2019-10-15
Java(TM) SE Runtime Environment (build 13.0.1+9)
Java HotSpot(TM) 64-Bit Server VM (build 13.0.1+9, mixed mode, sharing)
Thanks in advance

User avatar
rednoah
The Source
Posts: 17863
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: no xattr written… no media info found

Post by rednoah » 15 Feb 2020, 06:04

Please try the latest beta to see if that works better on your machine:
viewtopic.php?t=1609


:idea: After installing the latest and greatest, please run filebot -script fn:sysinfo and paste the console output.
:idea: Please read the FAQ and How to Request Help.

Post Reply