java.nio.file.AccessDeniedException: /.filebot

Support for macOS users and the Mac App Store package
Post Reply
Posts: 2
Joined: 30 Aug 2018, 09:04

java.nio.file.AccessDeniedException: /.filebot

Post by aibynn » 30 Aug 2018, 09:33

Thought I had this fixed, but...

I have a script that runs perfectly well from the terminal.

When I run it from inside uTorrent, I get the following error:

Code: Select all

Error during startup
	at net.filebot.Main.main(
Caused by: net.sf.ehcache.CacheException: java.nio.file.AccessDeniedException: /.filebot
	at net.filebot.CacheManager.<init>(
	at net.filebot.CacheManager.<clinit>(
	... 1 more
Caused by: java.nio.file.AccessDeniedException: /.filebot
	at net.filebot.util.FileUtilities.createFolders(
	at net.filebot.CacheManager.acquireDiskStore(
	at net.filebot.CacheManager.<init>(
	... 2 more
I'm assuming it's some kind of permission error, but as far as I can tell, everything is running from the same account.

Any and all advice welcome.


User avatar
The Source
Posts: 18357
Joined: 16 Nov 2011, 08:59
Location: Taipei

Re: Filebot won't run from inside uTorrent

Post by rednoah » 30 Aug 2018, 09:34

/.filebot is not a valid folder anyway, so the error message is effective telling us that something is wrong with the environment, because FileBot shouldn't create folders in / in the first place anyway, even if it had permission to do so.

Like any application, filebot uses ~/.filebot for it's application data:

Code: Select all

You need to make sure that the $HOME environment variable is set correctly before calling filebot. Usually not an issue for your Desktop user. Might be an issue for limited service users though, where important environment variables aren't set for some reason.
:idea: Please read the FAQ and How to Request Help.

Posts: 2
Joined: 30 Aug 2018, 09:04

Re: java.nio.file.AccessDeniedException: /.filebot

Post by aibynn » 30 Aug 2018, 10:14

Yup, setting the $HOME directory worked fine.

You must be correct that it wasn't set for uTorrent, which I find strange since it's running under the same account, but it's working, so...


Post Reply