Can't update to 4.8.5 on Synology NAS

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
Post Reply
CrowleyAJ
Donor
Posts: 4
Joined: 20 May 2016, 18:17

Can't update to 4.8.5 on Synology NAS

Post by CrowleyAJ » 09 Apr 2019, 13:34

I tried to update Filebot on my Synology from version 4.8.2 to 4.8.5, but it fails because it says the package has been published by an unknown publisher.
It is a Synology DS213, running DSM 6.2.1-23824 Update 6. I'd like to provide more details, but I'm not sure where to look.

Verbatim error message in german:
Paket-Zentrum
Aktualisierung von "FileBot" fehlgeschlagen. Dieses Paket wurde von einem unbekannten Herausgeber veröffentlicht.

Any suggestions, what I can do?

User avatar
rednoah
The Source
Posts: 16925
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Can't update to 4.8.5 on Synology NAS

Post by rednoah » 09 Apr 2019, 13:58

There's a setting where you can enable non-Synology packages.
:idea: Please read the FAQ and How to Request Help.

CrowleyAJ
Donor
Posts: 4
Joined: 20 May 2016, 18:17

Re: Can't update to 4.8.5 on Synology NAS

Post by CrowleyAJ » 09 Apr 2019, 14:12

Ok, thank you. I set the trust level to "any publisher" and the update went through. Afterwards I set the trust level back to "Synology and trusted publishers".
Does that mean FileBot is not a trusted publisher anymore or is this an one-off issue?

User avatar
rednoah
The Source
Posts: 16925
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Can't update to 4.8.5 on Synology NAS

Post by rednoah » 09 Apr 2019, 16:40

I don't know. By adding the repository source, you're also adding the repository public key, i.e. adding a trusted publisher, and packages are then signed accordingly, making it possible for Synology to verify that the package has been signed with the known public key, i.e. is from trusted publisher.

Maybe a DSM update purged the known public keys. You could try removing both filebot and the filebot repository, and then starting from scratch, to see if it works with "Synology and trusted publishers" out of the box then.
:idea: Please read the FAQ and How to Request Help.

Post Reply