[QNAP] Service Unavailable: /usr/local/bin/node: Permission denied

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
Post Reply
Wezuwiusz
Posts: 2
Joined: 10 Jun 2019, 01:38

[QNAP] Service Unavailable: /usr/local/bin/node: Permission denied

Post by Wezuwiusz » 17 Jul 2019, 04:47

Hello recently i can't use my filebot on qnap ts-128a, been fine for few weeks and suddenly the node gives me the 'Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.'

trying to get the logs i get this.

Code: Select all

 '[~] # find /share -iname '*filebot*log*'
/share/CACHEDEV1_DATA/.qpkg/filebot-node/filebot-node.log
[~] # cat /share/CACHEDEV1_DATA/.qpkg/filebot-node/filebot-node.log
/share/CACHEDEV1_DATA/.qpkg/filebot-node/start: line 34: /usr/local/bin/node: Permission denied

Code: Select all

Apache Ent 1.10.5
Filebot 4.8.5
Filebot Node 0.2.8.3
Java Installer 1.9
JRE 8.151.2.1
Node.js 8.9.4.0.1

User avatar
rednoah
The Source
Posts: 16419
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Service Unavailable

Post by rednoah » 17 Jul 2019, 05:13

1.
QNAP is giving you a misleading message. The filebot-node service is permanently unavailable because isn't running in the first place, because it crashes on startup because node isn't working:

Code: Select all

/share/CACHEDEV1_DATA/.qpkg/filebot-node/start: line 34: /usr/local/bin/node: Permission denied
:idea: No idea. I have a QNAP TS-228A and it works out of the box. Since node isn't working, try uninstalling and then re-installing node.


2.
Here's what it looks like if node is working:

Code: Select all

/usr/local/bin/node -v
v8.9.4

Code: Select all

ls -l /usr/local/bin/node
lrwxrwxrwx 1 admin administrators 50 2019-07-16 13:46 /usr/local/bin/node -> /share/CACHEDEV1_DATA/.qpkg/nodejsv8/node/bin/node

Code: Select all

ls -l /share/CACHEDEV1_DATA/.qpkg/nodejsv8/node/bin
total 34708
-rwxr-xr-x 1 me 1000 35538848 2018-01-03 18:01 node
lrwxrwxrwx 1 me 1000       38 2018-07-10 18:01 npm -> ../lib/node_modules/npm/bin/npm-cli.js
lrwxrwxrwx 1 me 1000       38 2018-07-10 18:01 npx -> ../lib/node_modules/npm/bin/npx-cli.js
:idea: Please read the FAQ and How to Request Help.

Wezuwiusz
Posts: 2
Joined: 10 Jun 2019, 01:38

Re: Service Unavailable

Post by Wezuwiusz » 17 Jul 2019, 05:22

very strange behaviour but i've uninstalled filebot node and node.js and its all good now, it was working fine few days ago and it stopped, thanks for the help

Post Reply