[BETA] FileBot for Synology DSM 7.0

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

[BETA] FileBot for Synology DSM 7.0

Post by rednoah »

⭑⭑ FileBot packages for Synology DSM 7.0 are in beta and available for testing ⭑⭑


Packages for DSM 7.0:
Add Package Source:
  • Package Center ➔ Settings ➔ Package Sources ➔ Add ➔ Name: FileBot Node

    Code: Select all

    https://raw.githubusercontent.com/filebot/filebot-node/master/syno-dsm7.json
  • Package Center ➔ Settings ➔ Package Sources ➔ Add ➔ Name: Java Installer

    Code: Select all

    https://raw.githubusercontent.com/rednoah/java-installer/latest/syno-dsm7.json
:idea: Please read the FAQ and How to Request Help.
Friends4U
Posts: 20
Joined: 25 Mar 2016, 23:44

Re: [BETA] FileBot for Synology DSM 7.0

Post by Friends4U »

This does not work :(
They all give an error...
Friends4U
Posts: 20
Joined: 25 Mar 2016, 23:44

Re: [BETA] FileBot for Synology DSM 7.0

Post by Friends4U »

Ok, it does... Just run the Java installer twice :)
popinho
Posts: 5
Joined: 18 May 2021, 20:16

Re: [BETA] FileBot for Synology DSM 7.0

Post by popinho »

Hi, I updated but when I open the UI still says "Unauthorized". I tryed also with the admin user and no luck!
Last edited by popinho on 18 May 2021, 20:40, edited 1 time in total.
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

Re: [BETA] FileBot for Synology DSM 7.0

Post by rednoah »

You may or may not need to disable CSRF authentication token feature for Synology authentication integration to work:
Image
:idea: Please read the FAQ and How to Request Help.
popinho
Posts: 5
Joined: 18 May 2021, 20:16

Re: [BETA] FileBot for Synology DSM 7.0

Post by popinho »

I have also disable logout and login and no luck. So update to DSM 7 and install all the files above and still no way to make it work :cry: Any other solution?
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

Re: [BETA] FileBot for Synology DSM 7.0

Post by rednoah »

Well, it works for my DSM 7.0 and others as well, so it can fundamentally work, but why it doesn't work on your device specifically, no idea.


:idea: You could check the network requests via Developer Tools to see if something odd sticks out.


:idea: Make sure you're logging in via HTTP (and not HTTPS) otherwise your browser might not send the login cookie along when you access FileBot Node via HTTP.
:idea: Please read the FAQ and How to Request Help.
popinho
Posts: 5
Joined: 18 May 2021, 20:16

Re: [BETA] FileBot for Synology DSM 7.0

Post by popinho »

I go to DSM packages and click on "Open" in filebot. Then a new window is opened and seconds latter it says "Unauthorized". I disable the cross origin, check the http, log with admin... no luck. When I search in the network this is the response:

Code: Select all

Request URL: http://XXX:XX/execute?_dc=XXXXX
Request Method: GET
Status Code: 401 Unauthorized
Remote Address: XXX:XX
Referrer Policy: strict-origin-when-cross-origin
and from the console:

Code: Select all

[Violation] 'setTimeout' handler took 234ms
app.js?_dc=XXXXX:X GET http://XXXXX:XX/tasks 401 (Unauthorized)
any other ideas? Before all this updates the program will open within DSM environment (without external windows) and worked fine.
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

Re: [BETA] FileBot for Synology DSM 7.0

Post by rednoah »

FileBot Node 0.4.1 for DSM 7 is now available for testing:
https://github.com/filebot/filebot-node/releases
:idea: Please read the FAQ and How to Request Help.
popinho
Posts: 5
Joined: 18 May 2021, 20:16

Re: [BETA] FileBot for Synology DSM 7.0

Post by popinho »

Hi Rednoah,

Image

Now it opens inside DSM 7 but still with admin login it popups like that.
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

Re: [BETA] FileBot for Synology DSM 7.0

Post by rednoah »

popinho wrote: 23 May 2021, 00:28 Now it opens inside DSM 7 but still with admin login it popups like that.
If you have installed FileBot Node pre-DSM 6.2.4 and then upgraded to DSM 7 directly, then this might be relevant:
viewtopic.php?p=54677#p54677
:idea: Please read the FAQ and How to Request Help.
Twingo12
Posts: 2
Joined: 29 May 2021, 20:01

Re: [BETA] FileBot for Synology DSM 7.0

Post by Twingo12 »

Hey,
I'm quite new to all this but I'd appreciate it if you could help me. I've been trying for a few hours to install Java 8 on my NAS since I wanna run a Minecraft Server with mods. I'm running DSM 7.0 which means most of the recommended packages in other forums don't work. I've finally found this mentioned package but it only installs Java 16.
Could you @rednoah make another 1.8.0 package that's compatible with DSM 7.0? Or could anyone tell me a way to install it manually?
All this Java stuff is really confusing to me honestly.
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

Re: [BETA] FileBot for Synology DSM 7.0

Post by rednoah »

Twingo12 wrote: 29 May 2021, 20:06 All this Java stuff is really confusing to me honestly.
It's just generic (1) download a file, (2) extract an archive, and (optionally) (3) symlink executable into /usr/local/bin, so any tutorial on how to use a Linux shell will teach you the skills you need. ;)


If you can find compatible binaries on the internet, for Java 8 or any other program, then you can always install (i.e. download, extract, link executable into $PATH) them manually.
:idea: Please read the FAQ and How to Request Help.
popinho
Posts: 5
Joined: 18 May 2021, 20:16

Re: [BETA] FileBot for Synology DSM 7.0

Post by popinho »

Hi all,

I finally figure it out, I don't know where but somebody said that the "Unauthorized" error comes from the uBlocking or Adblock Plus and he nailed it. Instead of accesing from my computer I tryed to start Filebot from my tablet and it worked. So my main issue was that the chrome plugin (uBlocking or Adblock Plus) was blocking Filebot.

BR!
keepwalking
Posts: 3
Joined: 09 Dec 2020, 12:53

Re: [BETA] FileBot for Synology DSM 7.0

Post by keepwalking »

Working great with DSM 7 Release Candidate !

The only thing is that the system asked to use sudo to remove dsm.filebot-node.conf manually before installing Filebot Node 0.4.1.1. and, after updating it, I had to RESTART the NAS so Filebot Node could work again. Then everything back to normal.
Twingo12
Posts: 2
Joined: 29 May 2021, 20:01

Re: [BETA] FileBot for Synology DSM 7.0

Post by Twingo12 »

rednoah wrote: 30 May 2021, 05:41 It's just generic (1) download a file, (2) extract an archive, and (optionally) (3) symlink executable into /usr/local/bin, so any tutorial on how to use a Linux shell will teach you the skills you need. ;)


If you can find compatible binaries on the internet, for Java 8 or any other program, then you can always install (i.e. download, extract, link executable into $PATH) them manually.
Awesome it worked! Thank you very much, you were a great help.
davemccreath
Posts: 26
Joined: 08 Oct 2019, 12:03

Re: [BETA] FileBot for Synology DSM 7.0

Post by davemccreath »

Just upgraded to the release candidate version DSM 7.

I uninstalled Java, FileBot and Filebot Node prior to the upgrade. Completed the upgrade then reinstalled (manual install of correct files), had to remove Node.js v8 as it was no longer supported in the new DSM version and installed Node.js v12/v14. Rebooted.

Had to adjust the Schedule syntax and reinsert my FIleBot license.

FileBot up and working fine.

Dave
davemccreath
Posts: 26
Joined: 08 Oct 2019, 12:03

Re: [BETA] FileBot for Synology DSM 7.0

Post by davemccreath »

For Info.

DSM 7 just prompted me to update FileBot Node v0.4.1 to v0.4.2.

Updated, all fine.

Ta.
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

Re: [BETA] FileBot for Synology DSM 7.0

Post by rednoah »

davemccreath wrote: 08 Jun 2021, 17:40 DSM 7 just prompted me to update FileBot Node v0.4.1 to v0.4.2.
Cheers, 0.4.2 is likely going to stick around unchanged for a while, unless we find additional issues.
:idea: Please read the FAQ and How to Request Help.
abescalamis
Posts: 30
Joined: 26 Jan 2018, 04:10

Re: [BETA] FileBot for Synology DSM 7.0

Post by abescalamis »

Do you guys know where can I can the Mediainfo for DSM7, is the only thing that I still need, if im not mistaken is needed for fileboot, right?
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

Re: [BETA] FileBot for Synology DSM 7.0

Post by rednoah »

abescalamis wrote: 27 Jun 2021, 18:48 Do you guys know where can I can the Mediainfo for DSM7, is the only thing that I still need, if im not mistaken is needed for fileboot, right?
libmediainfo is optional as far as FileBot is concerned, but if your custom format uses MediaInfo-based bindings then those will of course not work if libmediainfo is missing, so libmediainfo may or may not be needed depending on what want to do.
:idea: Please read the FAQ and How to Request Help.
abescalamis
Posts: 30
Joined: 26 Jan 2018, 04:10

Re: [BETA] FileBot for Synology DSM 7.0

Post by abescalamis »

Code: Select all

filebot -rename -r '/volume1/AMC/Auto/Bluray' --db xattr -non-strict --format "{def m = net.filebot.media.MediaDetection.guessMovieFolder(f); m/m.name}{subt}"
filebot -rename -r '/volume1/AMC/Auto/Kids' --db xattr -non-strict --format "{def m = net.filebot.media.MediaDetection.guessMovieFolder(f); m/m.name}{subt}"
filebot -rename -r '/volume1/AMC/Auto/Webrip Kids' --db xattr -non-strict --format "{def m = net.filebot.media.MediaDetection.guessMovieFolder(f); m/m.name}{subt}"
filebot -rename -r '/volume1/AMC/Auto/Webrips' --db xattr -non-strict --format "{def m = net.filebot.media.MediaDetection.guessMovieFolder(f); m/m.name}{subt}"
filebot -script 'fn:amc' '/volume1/AMC/Auto/Bluray' --output '/volume1/Data/Media/Movies/Blu-ray' --action move -non-strict --conflict skip --def 'ut_label=movie' 'clean=y' 'deleteAfterExtract=y' 'movieFormat={ny}/{ny}{'\''.'\''+lang.ISO2}' --log-file amc.log --def excludeList=amc.txt
filebot -script 'fn:amc' '/volume1/AMC/Auto/Kids' --output '/volume1/Data/Media/Movies/Kids Movies' --action move -non-strict --conflict skip --def 'ut_label=movie' 'clean=y' 'deleteAfterExtract=y' 'movieFormat={ny}/{ny}{'\''.'\''+lang.ISO2}' --log-file amc.log --def excludeList=amc.txt
filebot -script 'fn:amc' '/volume1/AMC/Auto/Webrip Kids' --output '/volume1/Data/Media/Movies/Webrip Kids' --action move -non-strict --conflict skip --def 'ut_label=movie' 'clean=y' 'deleteAfterExtract=y' 'movieFormat={ny}/{ny}{'\''.'\''+lang.ISO2}' --log-file amc.log --def excludeList=amc.txt
filebot -script 'fn:amc' '/volume1/AMC/Auto/Webrips' --output '/volume1/Data/Media/Movies/Webrips' --action move -non-strict --conflict skip --def 'ut_label=movie' 'clean=y' 'deleteAfterExtract=y' 'movieFormat={ny}/{ny}{'\''.'\''+lang.ISO2}' --log-file amc.log --def excludeList=amc.txt
filebot -rename -r '/volume1/AMC/Auto/TV Shows' --db file --file-filter "folder.name =~ /Subs/" --format "{folder.dir/fn}" --action move
filebot -script 'fn:amc' '/volume1/AMC/Auto/TV Shows' --output '/volume1/Data/Media/TV Shows' --action move -non-strict --order Airdate --conflict skip --def 'ut_label=TV' 'clean=y' 'deleteAfterExtract=y' 'seriesFormat={n}/{'\''Season '\''+s}/{n} - {s00e00} - {t}{'\''.'\''+lang.ISO2}' --log-file amc.log
This are the commands I run, but now that I updated to dsm 7 don't work, I have not been able to find Mediainfo spk for DSM 7

1) for the rename command I get - Failed to identify or process any files Failure (×_×)⌒☆

2) for the Script commad I get - No files selected for processing Done ¯\_(ツ)_/¯

Any suggestion
User avatar
rednoah
The Source
Posts: 20177
Joined: 16 Nov 2011, 08:59

Re: [BETA] FileBot for Synology DSM 7.0

Post by rednoah »

Re: MediaInfo
What does filebot -script fn:sysinfo say?


Re: Permissions
What $USER is filebot running as? Does this $USER have permission to read the given folders?


:?: Does the log indicate a permission issue?

Code: Select all

Permission denied: /path/to/folder

Image
:idea: Please read the FAQ and How to Request Help.
Tdoc
Posts: 39
Joined: 20 Feb 2018, 08:19

Re: [BETA] FileBot for Synology DSM 7.0

Post by Tdoc »

Good Day Red Noha

thanks for the update.

I have uninstalled everything and manually installed the java script 2.16, filebot 4.9.3, filebot-node 0.4.1

I had the "Not Found" error, but solution was already in this forum

all the best
abescalamis
Posts: 30
Joined: 26 Jan 2018, 04:10

Re: [BETA] FileBot for Synology DSM 7.0

Post by abescalamis »

rednoah wrote: 30 Jun 2021, 03:50 Re: MediaInfo
What does filebot -script fn:sysinfo say?


Re: Permissions
What $USER is filebot running as? Does this $USER have permission to read the given folders?


:?: Does the log indicate a permission issue?

Code: Select all

Permission denied: /path/to/folder

Image
I'm running filebot using the admin account, and yes it has read and write permissions to the folder

I did changed the permissions as in the picture, the problem is that it doesn't give me any error, but if I use filebot note it works but if I run the same command using SSH it doesn't.

I'm scratching my head on this
Post Reply