FileBot Node doesn't start on DSM 6

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
yahooeyu
Posts: 6
Joined: 26 Jul 2016, 20:03

Re: FileBot Node doesn't start on DSM 6

Post by yahooeyu »

Have same problem, Node doesnt start =(

log
2016/07/26 22:10:52 start filebot-node: begin to start version 0.2.0
2016/07/26 22:10:52 stop filebot-node: begin to stop version 0.2.0
2016/07/26 22:10:53 stop filebot-node: stop version 0.2.0 successfully, result 0
2016/07/26 22:11:03 start filebot-node: start version 0.2.0 failed, result 0
[email protected]:~#

[email protected]:~# curl -v https://10.10.1.8:5452/auth
* TLSv1.2 (OUT), TLS header, Certificate Status (22):
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* Unknown SSL protocol error in connection to 10.10.1.8:5452
curl: (35) Unknown SSL protocol error in connection to 10.10.1.8:5452
[email protected]:~# curl -v http://10.10.1.8:5452/auth
> GET /auth HTTP/1.1
> Host: 10.10.1.8:5452
> User-Agent: curl/7.47.0
> Accept: */*
>
< HTTP/1.1 200 OK
< Content-Type: text/json
< Access-Control-Allow-Origin: *
< Date: Tue, 26 Jul 2016 20:16:37 GMT
< Connection: keep-alive
< Content-Length: 51
<
{"success":true,"data":{"auth":"SYNO","user":null}}[email protected]:~#



# curl -v https://10.10.1.8:5453/auth
* TLSv1.2 (OUT), TLS header, Certificate Status (22):
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* TLSv1.2 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (OUT), TLS alert, Server hello (2):
* SSL certificate problem: unable to get local issuer certificate
* TLSv1.2 (OUT), TLS alert, Client hello (1):
curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
the -k (or --insecure) option.




have no idea how to make its work =(
invis
Donor
Posts: 24
Joined: 04 Apr 2016, 10:07

Re: FileBot Node doesn't start on DSM 6

Post by invis »

recently after synology updated it self, filebot stopped worked again.
when login and try starting it pushing "execute" nothing happens :(
p.s. the filebot log file is empty, so nothing I can put it :(
User avatar
rednoah
The Source
Posts: 18986
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: FileBot Node doesn't start on DSM 6

Post by rednoah »

yahooeyu wrote:{"success":true,"data":{"auth":"SYNO","user":null}}
The logs say that it works via HTTP but it doesn't work via HTTPS. That's easily explained by DSM using self-signed certificates and curl naturally not trusting those (you'll have to use the --insecure option for that, which is the same as clicking "I trust this site" in your browser when your browser encounters a self-signed certificate).
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 18986
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: FileBot Node doesn't start on DSM 6

Post by rednoah »

invis wrote:pushing "execute" nothing happens
There's 2 possible reasons:

A. The filebot node service is not running (see filebot node log)

B. Your network/firewall blocks your browser from sending requests to the filebot node service (use curl to test this, try accessing DSM from the local network)
:idea: Please read the FAQ and How to Request Help.
yahooeyu
Posts: 6
Joined: 26 Jul 2016, 20:03

Re: FileBot Node doesn't start on DSM 6

Post by yahooeyu »

Thanks for help.
I don't know how it happened,
but in 2 hours after it, i just reinstall NODE, and everything is work =)
magic!
invis
Donor
Posts: 24
Joined: 04 Apr 2016, 10:07

Re: FileBot Node doesn't start on DSM 6

Post by invis »

rednoah wrote:
invis wrote:pushing "execute" nothing happens
There's 2 possible reasons:

A. The filebot node service is not running (see filebot node log)

B. Your network/firewall blocks your browser from sending requests to the filebot node service (use curl to test this, try accessing DSM from the local network)
I have DS213 and previous issue was - it was not working at all.
after that you helped me install it and make it work without node.
it was running without any problem until 2-3 weeks ago, probably some update from DSM came out
so my automated scheduler stopped working too :
Locking /volume1/@appstore/filebot/data/root/logs/amc.log
Cannot cast java.net.URI to [B
java.lang.ClassCastException: Cannot cast java.net.URI to [B
at net.filebot.CachedResource.get(CachedResource.java:107)
at net.filebot.MemoizedResource.get(Resource.java:36)
at net.filebot.cli.ScriptBundle.getScript(ScriptBundle.java:34)
at net.filebot.cli.ScriptShell.runScript(ScriptShell.java:72)
at net.filebot.cli.ArgumentProcessor.runScript(ArgumentProcessor.java:114)
at net.filebot.cli.ArgumentProcessor.run(ArgumentProcessor.java:29)
at net.filebot.Main.main(Main.java:120)
Failure (°_°)
Firewall is off, tried different was to execute filebot, nothing :(
Godlyone
Posts: 1
Joined: 29 Jan 2017, 10:55

Re: FileBot Node doesn't start on DSM 6

Post by Godlyone »

tedrogers61 wrote:
rednoah wrote:1.
1. Install Chromaprint and Media Info.
2. Install FileBot (and allow it to install Java and Node.js)
3. Install Filebot-Node.
I've tried this on my DS213J and I can't reproduce any issues. Works right out of the box.

2.

Code: Select all

./var/packages/filebot-node/scripts/start-stop-status start
You can't just call it like this. You'll have to set certain environment variables to call it as if DSM was calling it:

Code: Select all

export SYNOPKG_PKGNAME="filebot-node"
Re: 1...I can't explain it either...doesn't work one way, but works if I let filebot-node install everything for me.

Re: 2...thanks, this will come in useful should I need to start / stop manually. Is that the full command for both start and stop toggle?
Hi,

Is it possible to provide some clarity on how to use this export command that will allow the start-stop-status command to work.

I have tried using it in PuTTY by first running your export command then running the start-stop-status command but I get the following error:

initctl: Rejected send message, 1 matched rules; type="method_call", sender=":1.4146" (uid=1024 pid=3451 comm="initctl start filebot-node ") interface="com.ubuntu.Upstart0_6.Job" member="Start" error name="(unset)" requested_reply="0" destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init ")

Any help would be greatly appreciated.
User avatar
rednoah
The Source
Posts: 18986
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: FileBot Node doesn't start on DSM 6

Post by rednoah »

Add a printenv > /path/to/output.txt in start-stop-status and then start/stop the service via DSM.

@see viewtopic.php?f=4&t=3067
:idea: Please read the FAQ and How to Request Help.
Post Reply