node: command not found

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
Post Reply
spikemixture
Posts: 13
Joined: 17 Jun 2018, 13:28

node: command not found

Post by spikemixture » 28 Aug 2018, 15:42

Greetings,

I have followed the instructions and all installs smoothly.
Installed the 4 apps from the filebot app center
And Node.js and java 8

But on clicking filebot node I get -

Code: Select all

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Suggestions?

User avatar
rednoah
The Source
Posts: 15960
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Installing FileBot on QNAP NAS

Post by rednoah » 29 Aug 2018, 04:24

Can you log in via SSH and check the logs?

You can find the logs with the find command:

Code: Select all

find /share -iname '*filebot*log*'
:idea: Please read the FAQ and How to Request Help.

spikemixture
Posts: 13
Joined: 17 Jun 2018, 13:28

Re: FileBot Node Troubleshooting on QNAP

Post by spikemixture » 29 Aug 2018, 06:21

Code: Select all

+ export FILEBOT_NODE_HOST=127.0.0.1
+ FILEBOT_NODE_HOST=127.0.0.1
+ export FILEBOT_NODE_AUTH=QNAP
+ FILEBOT_NODE_AUTH=QNAP
+ export FILEBOT_NODE_HTTP=YES
+ FILEBOT_NODE_HTTP=YES
+ export FILEBOT_NODE_HTTP_PORT=5452
+ FILEBOT_NODE_HTTP_PORT=5452
+ export USER=admin
+ USER=admin
++ awk -vm=1024 -vp=0.7 '/Mem:/ {printf "-Xmx%dm", ($2*p)/m; exit}'
++ free
+ export JAVA_OPTS=-Xmx22469m
+ JAVA_OPTS=-Xmx22469m
+ export FILEBOT_TASK_CMD=/opt/filebot-node/task
+ FILEBOT_TASK_CMD=/opt/filebot-node/task
+ export FILEBOT_CMD=filebot
+ FILEBOT_CMD=filebot
+ export FILEBOT_CMD_CWD=/share/CACHEDEV1_DATA
+ FILEBOT_CMD_CWD=/share/CACHEDEV1_DATA
++ id -u admin
+ export FILEBOT_CMD_UID=0
+ FILEBOT_CMD_UID=0
++ cat /etc/group
++ cut -d: -f3
++ grep administrators
+ export FILEBOT_CMD_GID=0
+ FILEBOT_CMD_GID=0
+ export FILEBOT_NODE_CLIENT=client
+ FILEBOT_NODE_CLIENT=client
+ cd /share/CACHEDEV1_DATA/.qpkg/filebot-node
+ node --optimize_for_size --use_idle_notification server/app.js
/share/CACHEDEV1_DATA/.qpkg/filebot-node/start: line 26: node: command not found

User avatar
rednoah
The Source
Posts: 15960
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: FileBot Node Troubleshooting on QNAP

Post by rednoah » 29 Aug 2018, 07:14

According to the log, node is not installed, or not installed correctly:

Code: Select all

node: command not found
This thread will help:
viewtopic.php?f=4&t=6084
:idea: Please read the FAQ and How to Request Help.

spikemixture
Posts: 13
Joined: 17 Jun 2018, 13:28

Re: node: command not found

Post by spikemixture » 30 Jan 2019, 14:52

Reporting back.
All working well.

Just gotta work out how to set to run automatically 2 (or 3) times a day

spikemixture
Posts: 13
Joined: 17 Jun 2018, 13:28

Re: node: command not found

Post by spikemixture » 01 Apr 2019, 07:48

Just gotta work out how to set to run automatically 2 (or 3) times a day ???

Can this be done?

User avatar
rednoah
The Source
Posts: 15960
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: node: command not found

Post by rednoah » 01 Apr 2019, 09:35

There is a Schedule button that you can click to create a Scheduled Task in Synology Task Manager.
:idea: Please read the FAQ and How to Request Help.

Post Reply