Artwork stopped downloading

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
mikejandreau
Posts: 23
Joined: 07 Jun 2017, 16:50

Artwork stopped downloading

Post by mikejandreau » 06 Aug 2019, 11:37

I've been running an amc script for years at this point and it's always worked flawlessly. Last night, I noticed a few new shows I'd downloaded didn't have artwork in Plex, so I set out to manually update them this morning. When I run the script to fetch artwork, Filebot just comes back as done, but doesn't fetch any artwork, even for shows it already has (Younger, for example, has artwork, so I know it's out there in the database somewhere. The other 3 shows I tried are new to me)

Code: Select all

/usr/local/bin/filebot -script fn:amc --output "$CONFIG_OUTPUT" --action move --conflict skip -non-strict --log-file amc.log --def clean=y unsorted=y music=y artwork=y excludeList=".excludes" ut_dir="$ARG_PATH" ut_kind="multi" ut_title="$ARG_NAME" ut_label="$ARG_LABEL"

Code: Select all

Pennyworth:Tacoma FD Alfred$ filebot -script fn:artwork.tvdb
Done ヾ(@⌒ー⌒@)ノ
Pennyworth:Tacoma FD Alfred$ cd ../Smallville/
Pennyworth:Smallville Alfred$ filebot -script fn:artwork.tvdb
Done ヾ(@⌒ー⌒@)ノ
Pennyworth:Smallville Alfred$ cd ../Younger/
Pennyworth:Younger Alfred$ filebot -script fn:artwork.tvdb
Done ヾ(@⌒ー⌒@)ノ
Pennyworth:Younger Alfred$ cd ../Barry/
Pennyworth:Barry Alfred$ filebot -script fn:artwork.tvdb
Done ヾ(@⌒ー⌒@)ノ
Is something broken somewhere? How should I troubleshoot this?

mikejandreau
Posts: 23
Joined: 07 Jun 2017, 16:50

Re: Artwork stopped downloading

Post by mikejandreau » 06 Aug 2019, 19:56

Weird, it just started working on its own when I ran it again from the CLI.

Must have been something up at TVDb's end in the API.

User avatar
rednoah
The Source
Posts: 16430
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Artwork stopped downloading

Post by rednoah » 07 Aug 2019, 07:50

Yes. TheTVDB is rolling out a new backend, and it seems things have gone wrong somewhere when connecting the current API to the new backend. Please allow them a few days to making things running smoothly again.


EDIT:

Unrelated shameless self-promotion for my newly released (and not quite production ready) Plex Scanners & Plug-ins: [PLEX] FileBot Xattr Metadata Scanners & Plug-ins
:idea: Please read the FAQ and How to Request Help.

rouggy
Posts: 4
Joined: 21 Aug 2019, 11:54

Re: Artwork stopped downloading

Post by rouggy » 21 Aug 2019, 12:00

I am having same issue and for the past few weeks no artwork is being downloaded from AMC...
Any news about this ?

Running from CLI does not help but the script artwork.tvdb works fine anyway i would prefer that AMC download the artwork as it did in the past.

User avatar
rednoah
The Source
Posts: 16430
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Artwork stopped downloading

Post by rednoah » 21 Aug 2019, 12:34

What does the amc script output say?

What does the sysinfo script output say?

:arrow: Please read How to Request Help.
:idea: Please read the FAQ and How to Request Help.

rouggy
Posts: 4
Joined: 21 Aug 2019, 11:54

Re: Artwork stopped downloading

Post by rouggy » 22 Aug 2019, 04:23

Hello these are the outputs:

Image

Image

let me know if this is what you need.

The command line is:

Code: Select all

filebot -script fn:amc "/mnt/Download/finished" --output "/mnt/Multimedia" -no-xattr --log-file "/tmp/amc.log" --action move --conflict override --def exec="curl 'http://localhost:8081/api/****?cmd=show.refresh&tvdbid={info.id}'"  @/home/rouggy/Scripts/FileBot/args.txt
Args.txt

Code: Select all

plex=192.168.1.14:********
pushbullet=o.*****
storeReport=y
extras=y
artwork=y
unsorted=y
music=y
clean=y
seriesFormat=Series/{n}/{'Season '+s}/{n.upperInitial().space('.').replaceAll(/[,]+/)}.{s00e00}.{t.upperInitial().space('.').replaceAll(/[,]+/)}{'.'+vf.match(/720[pP]|1080[pP]/)}{".$source"}{".$vc"}-{group.upper()}/{n.upperInitial().space('.').replaceAll(/[,]+/)}.{s00e00}.{t.$
movieFormat={fn =~ /3D/ ? '3D Movies' : fn =~ /2160/ ? '4K Movies' : fn =~ /4K/ ? '4K Movies' : 'Movies'}/{folder.name =~ /finished/ ? fn.space('.') : folder.name.space('.')}/{folder.name =~ /finished/ ? fn.space('.') : folder.name.space('.')}
musicFormat=Music/{n}/{album} ({y})/{pi.pad(2)+'-'}{t}
Thanks for your time and help

User avatar
rednoah
The Source
Posts: 16430
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Artwork stopped downloading

Post by rednoah » 22 Aug 2019, 10:28

No idea. Works for me.

Here's what I did:

Create sample file:

Code: Select all

touch Firefly.1x01.mkv
Run amc script with artwork enabled:

Code: Select all

filebot -script fn:amc Firefly.1x01.mkv --def artwork=y --def minFileSize=0
Run script [fn:amc] at [Thu Aug 22 17:23:43 ICT 2019]
Parameter: artwork = y
Parameter: minFileSize = 0
Argument[0]: Firefly.1x01.mkv
Input: Firefly.1x01.mkv
Group: [Series:firefly] => [Firefly.1x01.mkv]
Rename episodes using [TheTVDB]
Auto-detected query: [Firefly]
Fetching episode data for [Firefly]
[MOVE] from [Firefly.1x01.mkv] to [TV Shows/Firefly/Season 01/Firefly - S01E01 - The Train Job.mkv]
Processed 1 files
Fetching series artwork for [Firefly / Season 1] to [TV Shows/Firefly/Season 01]
Generate Series NFO: Firefly [78874]
Fetching TV Shows/Firefly/poster.jpg => [poster/680x1000, en, 7.5, https://thetvdb.com/banners/posters/78874-2.jpg]
Fetching TV Shows/Firefly/banner.jpg => [series/graphical, en, 8.7, https://thetvdb.com/banners/graphical/78874-g3.jpg]
Fetching TV Shows/Firefly/fanart.jpg => [fanart/graphical/1920x1080, en, 8.0, https://thetvdb.com/banners/fanart/original/78874-2.jpg]
Fetching TV Shows/Firefly/Season 01/poster.jpg => [season/1, en, 6.1, https://thetvdb.com/banners/seasons/78874-1-2.jpg]
Resource not found: https://api.thetvdb.com/series/78874/images/query?keyType=seasonwide
Banner not found: TV Shows/Firefly/Season 01/banner.jpg / seasonwide:seasonwide
Fetching TV Shows/Firefly/clearart.png => [hdclearart, en, 5.0, https://assets.fanart.tv/fanart/tv/78874/hdclearart/firefly-514555447ca03.png]
Fetching TV Shows/Firefly/logo.png => [hdtvlogo, en, 9.0, https://assets.fanart.tv/fanart/tv/78874/hdtvlogo/firefly-50f883a9e9a4a.png]
Fetching TV Shows/Firefly/landscape.jpg => [tvthumb, en, 5.0, https://assets.fanart.tv/fanart/tv/78874/tvthumb/firefly-50392afed15d2.jpg]
Fetching TV Shows/Firefly/Season 01/landscape.jpg => [seasonthumb/1, en, 3.0, https://assets.fanart.tv/fanart/tv/78874/seasonthumb/firefly-57c3cb6144732.jpg]
Done ヾ(@⌒ー⌒@)ノ
Check output structure:

Code: Select all

tree .
└── TV\ Shows
    └── Firefly
        ├── Season\ 01
        │   ├── Firefly\ -\ S01E01\ -\ The\ Train\ Job.mkv
        │   ├── folder.jpg
        │   ├── landscape.jpg
        │   └── poster.jpg
        ├── banner.jpg
        ├── clearart.png
        ├── fanart.jpg
        ├── folder.jpg
        ├── landscape.jpg
        ├── logo.png
        ├── poster.jpg
        └── tvshow.nfo

3 directories, 12 files
Check version:

Code: Select all

filebot -version
FileBot 4.8.5 (r6224)

:arrow: Use this example and confirm that it fundamentally works, and then use trial & error to figure out what's different in your call.



EDIT:

Might have to do with xattr being disabled. Enable xattr and see if that makes a difference:
viewtopic.php?t=324

:idea: If your output filesystem does not support xattr, then you can still configure FileBot to use .xattr folders and files to store metadata.
:idea: Please read the FAQ and How to Request Help.

rouggy
Posts: 4
Joined: 21 Aug 2019, 11:54

Re: Artwork stopped downloading

Post by rouggy » 22 Aug 2019, 11:11

Thank you so much for the time you spend. I am almost home and will do the testing.

Reverting shortly

rouggy
Posts: 4
Joined: 21 Aug 2019, 11:54

Re: Artwork stopped downloading

Post by rouggy » 22 Aug 2019, 12:07

Ok i have tried your example it works.
I removed the no-xattr parameter and it started downloading the artwork again.

I did setup the .xattr folders as you advised !

Thank you so much for your help

Post Reply