Comments on License Error: Banned due to abuse

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
keteflips
Posts: 8
Joined: 28 Sep 2019, 07:49

Re: License Error: Banned due to abuse

Post by keteflips »

The error its solved in my case.
I dont have more License failures.

Please check it.
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

Yep. Looks good. Last activation is from a few days ago, so it seems to be working correctly now:

Code: Select all

2019-09-28 21:07:47	P9384858
keteflips wrote: 03 Oct 2019, 19:19 The error its solved in my case.
What was the source of the issue?
:idea: Please read the FAQ and How to Request Help.
keteflips
Posts: 8
Joined: 28 Sep 2019, 07:49

Re: License Error: Banned due to abuse

Post by keteflips »

rednoah wrote: 04 Oct 2019, 03:13 Yep. Looks good. Last activation is from a few days ago, so it seems to be working correctly now:

Code: Select all

2019-09-28 21:07:47	P9384858
keteflips wrote: 03 Oct 2019, 19:19 The error its solved in my case.
What was the source of the issue?

Ubuntu Server when its out of memory kills the daemon that causes the problem, and this daemon its my script XD
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

keteflips wrote: 22 Oct 2019, 10:56 Ubuntu Server when its out of memory kills the daemon that causes the problem, and this daemon its my script XD
That's an interesting one! Wouldn't have thought of that. That could cause a problem if it's killed suddenly at an inconvenient time.
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

aaseef021 wrote:27 Dec 2019, 03:38 Hi

I keep getting emails about FileBot License P9982009 has been activated 98 times


Not sure what I am doing wrong, I have have crontab setup to run every 5 minutes for exact and ever 17 minutes for copy to a folder.

I really got no clue why I am being flagged can you please assist I want to solve this. I never had this issue before when using this same exact process
Please read this post thoroughly as it will give you a very good idea what's going on and a general reason why your license may have been flagged:
viewtopic.php?f=4&t=9594#p40629

:idea: The reason is always that FileBot believes it's running for the very first time, each and every time, meaning persistent storage is somehow disabled. A nonexhaustive list of possible reasons for this is given in the post above.

:idea: Perhaps the logs will give some indication as to why. Please read (6.) and (7.) for details on logging, and things you might want to look out for.
:idea: Please read the FAQ and How to Request Help.
aaseef021
Posts: 52
Joined: 08 Nov 2017, 04:08

Re: License Error: Banned due to abuse

Post by aaseef021 »

Hi

Thanks for the response. I didn't see any errors in the log. it seems like it is working fine but still. This is the path to my log file

Code: Select all

/filebot-portable/data/root/logs# ls
amc.log  filebot.log  filebot.txt  log.txt
Aslo I tried this command

Code: Select all

filebot --log-file log.txt
it does't work for me, maybe I am doing it wrong. Can you please assist.
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

Unfortunately, without access to your screen and keyboard, I cannot really help in this case. Perhaps you have a Linux-savvy friend that can help you out?

My first steps towards figuring out the root cause would be as follows:
* Make sure you're using the latest version of FileBot
* According to (7.) confirm the problem for yourself, so that you can later on check if the problem is solved or not
* Read (1.) to (3.) and understand the common theme, and then try to figure out what's going awry in your setup
* Systematically narrow down what's going on, check where filebot is writing application data files, and then trace what's happening to those files before and after filebot is running, to find out why they're magically disappearing between runs.


EDIT:

:idea: Note that I'm happy to just offer a refund if you choose not to investigate the issue. Maybe there's a simple cause. Maybe it'll take many many hours to find this simple cause. Maybe it's not going to be easy.
:idea: Please read the FAQ and How to Request Help.
aaseef021
Posts: 52
Joined: 08 Nov 2017, 04:08

Re: License Error: Banned due to abuse

Post by aaseef021 »

Hi

I am willing to give you remote access to SSH or putty, if you like to take a look.

I actually love filebot, would not want to really use anything else
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

Sorry, that kinda time-intensive one-on-one service is not currently possible.

Perhaps you could create a new thread, describe what you have tried so far, describe your setup, share your logs and scripts and cron config, etc. And then we can try to home in on the cause step by step. It'll be difficult, but you'll learn many useful skills on the way.
:idea: Please read the FAQ and How to Request Help.
aaseef021
Posts: 52
Joined: 08 Nov 2017, 04:08

Re: License Error: Banned due to abuse

Post by aaseef021 »

Hi

Thank you so much for your help, I have created a new thread for my issue. Hoping someone is able to help

viewtopic.php?f=11&t=11377

Thank You so much for your help
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

I don't have an automated setup, I just click on the exe to open Filebot, so I don't know how it possibly could be activated multiple times.....
Well, logs are logs, and I can't tell you what to do since it's definitely a client-side problem. You could check your logs, and see if you get the corresponding "Activate License" entires.

Reasons the system might have flagged your license:
1. Activated from 5+ countries in a short period of time (normal would be 1-2)
2. Activated many times in a short period of time (normal would be 1-5 times per month)

:idea: Note that fixing (2.) will also alleviate (1.) as less activations means less activations from different countries.

The first post of this thread should give you the general idea as what's going on, application state is reset between runs, leading to premature "Activate License" requests. This could be for any number of reasons. Some guy had a 3rd party tool that periodically deleted all application data files. Could be anything though. Keeping logs and checking them would be a good first step to figure it out.

:idea: Some users may have genuine use cases, that are unfortunately virtual indistinguishable for abuse, in which case I'm happy to just offer a refund.
:idea: Please read the FAQ and How to Request Help.
jdcox215
Posts: 1
Joined: 17 Jan 2020, 18:48

Re: License Error: Banned due to abuse

Post by jdcox215 »

I don’t even know how to get into the logs, and I only use a vpn for watching other country’s Netflix so I never use filebot while I’m on it.
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

jdcox215 wrote: 17 Jan 2020, 20:07 I don’t even know how to get into the logs, and I only use a vpn for watching other country’s Netflix so I never use filebot while I’m on it.
Well, now is probably the time to learn how to get into the logs and have a look. See FAQ for details.

:idea: You will have received this weeks "Activate License" logs for your license via email. You can cross-reference that with your local logs and see if it matches up.

:!: If it does not match up, then unauthorized 3rd parties may indeed have had access to your license file one way or another, which would be disturbing to say the least.
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

My script runs the following on a scheduled task every 30 minutes.

Code: Select all

filebot -script fn:amc --output "\\192.168.1.1\data\media\movies" --action move -non-strict "\\192.168.1.1\data\media\moviestobeprocessed" --def movieFormat="\\192.168.1.1\data\media\{plex}"
exit
I cannot see anything wrong with that script based on your linked forum thread.
At first glance. You're not (6.) using a log file, so you won't be able to (7.) check the log to check if everything is in order. Those would be the first steps so you yourself can confirm that things are working correctly / are not working correctly.

The next step would then be to figure out why things are not working on your machine. This could be for any number of reasons, specific to your machine and setup, something only you can figure out. Whatever it may be, it results in FileBot thinking it's running for the first time, every time.

:idea: Among things listed in the OP, it could be running out of disk space, running things as temporary user each time, having 3rd party tools that regularly delete %APP_DATA% files, etc. Anything that could lead to FileBot not being able to remember things. On Windows this is extremely rare, but it's your machine, so you have, directly or indirectly, absolute control over FileBot's memory / persistent storage and something is off in this regard.
:idea: Please read the FAQ and How to Request Help.
selfm4n
Posts: 1
Joined: 07 Mar 2020, 08:14

Re: License Error: Banned due to abuse

Post by selfm4n »

Hello,

My license "PX6452933" was recently banned. Indeed, in one of my scripts, the cache was emptied before the process. Sorry for the inconvenience, it's fixed.

Could you reinstate the license? Also, I noticed that the email address associated with my license is an old one that I deleted. Is this likely to be a problem in the future? If yes, could you update it to ".com"?

Thank you in advance and for your great work.
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

selfm4n wrote: 07 Mar 2020, 17:35 Could you reinstate the license? Also, I noticed that the email address associated with my license is an old one that I deleted. Is this likely to be a problem in the future? If yes, could you update it to ".com"?
That would explain why you didn't get any of the automated warning emails. Please PM me your correct email address.
:idea: Please read the FAQ and How to Request Help.
floppy84400
Posts: 1
Joined: 13 Mar 2020, 00:45

Re: License Error: Banned due to abuse

Post by floppy84400 »

hi,

my license PX10567149 have been banned, i don't have any clear cache or other things that can explain for now the issue.
could you unban it ?

regards
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

rednoah wrote: 29 Dec 2018, 06:21 7.
DO check your --log-file once in a while to see if everything is in order:

Code: Select all

grep "Activate License" /path/to/log

Code: Select all

Activate License P1234567
:!: Activate License P1234567 MUST NOT show up in your log for each and every filebot call. You will see this message once or twice per month during normal usage. If you see this message hundreds of times per day, then you need to fix your setup. (NOTE: Activate License logging requires FileBot 4.8.5 or higher)

:!: The FileBot log file does not include system console output. Please read Shell Script Debugging for Beginners on how to collect complete console output including crash dumps and device errors. (NOTE: extremely useful for debugging strange issues)
What does the log say? How many Activate License lines did you find?
:idea: Please read the FAQ and How to Request Help.
mulderonline
Posts: 3
Joined: 11 Nov 2019, 08:42

Re: License Error: Banned due to abuse

Post by mulderonline »

I have no change on my setup since one year i have install new realase please unban my licence: P8498486
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

mulderonline wrote: 01 Apr 2020, 09:08 I have no change on my setup since one year i have install new realase please unban my licence: P8498486
Nevertheless. Your setup is broken now, and has been for the last ~4 weeks, because you have been receiving warning emails every week for the last ~3 weeks with detailed logs about your license activations.

I will manually unban your license, but if you don't resolve the underlying issue, whatever it may be, the system will auto-ban you again.


EDIT: P8498486 has already been unbanned on Monday.
:idea: Please read the FAQ and How to Request Help.
willwrong
Posts: 1
Joined: 30 Apr 2020, 03:12

Re: License Error: Banned due to abuse

Post by willwrong »

Hi there,

Can you please unblock license P9334532? My /data folder dropped out on Docker windows yesterday when fiddling with drives.

Thanks!
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

P9334532 is not currently banned.


If your license was banned, you would see this error message:

Code: Select all

Banned due to abuse. Please read https://www.filebot.net/error/429.html for details.
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

P8461367 is not currently banned. What makes you think that your license is banned?
:idea: Please read the FAQ and How to Request Help.
GoT2020
Posts: 4
Joined: 10 May 2020, 10:33

Re: License Error: Banned due to abuse

Post by GoT2020 »

Hi rednoah,
My PX7006317 license shows a "banned due to abuse" error. Can you review what happens? Thank you
User avatar
rednoah
The Source
Posts: 20995
Joined: 16 Nov 2011, 08:59

Re: License Error: Banned due to abuse

Post by rednoah »

GoT2020 wrote: 10 May 2020, 10:52 My PX7006317 license shows a "banned due to abuse" error. Can you review what happens? Thank you
"banned due to abuse" is preceded by no less than 3 warning emails with detailed license activation logs, so you can review what you're doing, and check that against frequent user errors:
viewtopic.php?t=9594


:idea: Since it's your machine(s), only you can figure out what's going on your machine(s) specifically. The activation logs will help you narrow down on the issue though.
:idea: Please read the FAQ and How to Request Help.
Post Reply