[Filebot Node] How can i set -no-xattr?

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
howdymilsap
Posts: 34
Joined: 14 Jul 2018, 17:22

[Filebot Node] How can i set -no-xattr?

Post by howdymilsap »

how do you set -no-xattr in the filebot node interface?
User avatar
rednoah
The Source
Posts: 19011
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [Filebot Node] How can i set -no-xattr?

Post by rednoah »

1.
Why do you want to turn off xattr? Did you run into any specific issue? Care to elaborate? AFAIK, all Synology devices support xattr just fine.


2.
Unfortunately, FileBot Node does not have a checkbox that corresponds to this option.
:idea: Please read the FAQ and How to Request Help.
howdymilsap
Posts: 34
Joined: 14 Jul 2018, 17:22

Re: [Filebot Node] How can i set -no-xattr?

Post by howdymilsap »

I don't use this on synology, I use the docker filebot node with an rclone mounted filesytem. The destination filesystem doesn't currently support xattr and so I see a lot of error messages in the log. I realize I can just ignore them, but was hoping I could use the -no-xattr option to eliminate them.

btw, the node implementation is pretty flawless. Amazing work. Thanks.
User avatar
rednoah
The Source
Posts: 19011
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [Filebot Node] How can i set -no-xattr?

Post by rednoah »

I see. You should be able to disable the xattr feature by setting the FILEBOT_OPTS environment variable as follows:

Code: Select all

export FILEBOT_OPTS="-DuseExtendedFileAttributes=false"
:idea: I'm no docker expert, but you should be able to set environment variables via the command-line or configuration or docker file or something.
:idea: Please read the FAQ and How to Request Help.
howdymilsap
Posts: 34
Joined: 14 Jul 2018, 17:22

Re: [Filebot Node] How can i set -no-xattr?

Post by howdymilsap »

This solution works perfectly. Thanks again.
User avatar
rednoah
The Source
Posts: 19011
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [Filebot Node] How can i set -no-xattr?

Post by rednoah »

I'd appreciate it if you could share how you implemented this solution, for the next guy that stumbles on this thread. ;)
:idea: Please read the FAQ and How to Request Help.
howdymilsap
Posts: 34
Joined: 14 Jul 2018, 17:22

Re: [Filebot Node] How can i set -no-xattr?

Post by howdymilsap »

rednoah wrote: 26 Sep 2018, 06:38 I'd appreciate it if you could share how you implemented this solution, for the next guy that stumbles on this thread. ;)
I use portainer to manage my docker containers. To fix this issue, I just modified your standard container in the portainer GUI and updated the existing FILEBOT_OPTS environment variable to be the following:

Code: Select all

	-Dapplication.deployment=docker -Duser.home=/data -DuseExtendedFileAttributes=false
I then simply re-deployed the container and the new configuration was in place. I will create an automated deploy for this container (with my modification) to this using Ansible, and will post that script here once I have a bit more time.
Post Reply