Utorrent + amc script not running in 3.6

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
noid
Posts: 5
Joined: 14 Apr 2013, 05:49

Utorrent + amc script not running in 3.6

Post by noid » 14 Apr 2013, 12:16

Just trying out filebot and it works great from the command line, but I seem to be having the same problem as others in that it won't run from uTorrent. I've tried adding cmd \c in front, using filebot.exe, downloading the latest FileBot.jar from the repo, specifying the full filebot path, but I still don't see any activity, although utorrent shows it is run in the logger type. I notice you mention the issue is discussed in the latest documents, but I can't seem to find them on the website, repo, through filebot -help, or install directory - could you point me to the documents you are referring to? Any help is appreciated.

User avatar
rednoah
The Source
Posts: 16810
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Utorrent + amc script not running in 3.6

Post by rednoah » 14 Apr 2013, 13:12

First you run it manually in a new cmd window.

Then you can check with utorrent. If that doesn't work it's a PATH issue. In that case you specify the absolute path to filebot.exe instead of having windows resolve the "filebot" command. Also you may need to restart utorrent so it'll read in the new PATH.

cmd /c is only needed if you wanna use IO redirection. In v3.6 you should specify --log-file for that instead, so no more cmd /c required. The AMC docs have been updated accordingly.
:idea: Please read the FAQ and How to Request Help.

noid
Posts: 5
Joined: 14 Apr 2013, 05:49

Re: Utorrent + amc script not running in 3.6

Post by noid » 15 Apr 2013, 03:10

yeah it's strange, the filebot directory is present in the PATH and if I call "filebot" from the command prompt the program opens, so not sure why it doesn't work from uTorrent. It finally worked by specifying the absolute path - wasn't working initially bc I was using C:/Program Files/Filebot/filebot.exe instead of C:/Progra~1/Filebot/filebot.exe

Could you tell me which AMC docs you are referring to and where I can find them? - do you mean the forum thread or are there some other documents I'm not aware of?

User avatar
rednoah
The Source
Posts: 16810
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Utorrent + amc script not running in 3.6

Post by rednoah » 15 Apr 2013, 03:15

I mean the forum thread, that you seem to have found already. It's full of troubleshooting.

Mind your spaces...

Code: Select all

> "C:/Program Files/Filebot/filebot.exe" -version
:idea: Please read the FAQ and How to Request Help.

Post Reply