_XReply: Assertion `!xcb_xlib_threads_sequence_lost' failed.

All your suggestions, requests and ideas for future development
Post Reply
martinbarlow
Posts: 3
Joined: 27 Apr 2019, 07:35

_XReply: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Post by martinbarlow » 27 Apr 2019, 07:38

Sometimes filebot starts, sometimes it hangs. Sometimes i get this core dump.

Code: Select all

[email protected]:~$ filebot -script fn:sysinfo
FileBot 4.8.5 (r6224)
JNA Native: 5.2.2
MediaInfo: 18.12
7-Zip-JBinding: 9.20
Chromaprint: java.io.IOException: Cannot run program "/usr/share/filebot/lib/fpcalc": error=13, Permission denied
Extended Attributes: OK
Unicode Filesystem: OK
GVFS: PlatformGVFS [/run/user/1100/gvfs]
Script Bundle: 2019-04-23 (r560)
Groovy: 2.5.6
JRE: OpenJDK Runtime Environment 11.0.3
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 4 Core / 3 GB Max Memory / 19 MB Used Memory
OS: Linux (amd64)
HW: Linux sunday 5.0.0-13-generic #14-Ubuntu SMP Mon Apr 15 14:59:14 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
DATA: /home/mbarlow/.filebot
Package: DEB
License: FileBot License P6171956 (Valid-Until: 2019-11-13)
Done ヾ(@⌒ー⌒@)ノ

User avatar
rednoah
The Source
Posts: 16802
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: _XReply: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Post by rednoah » 27 Apr 2019, 08:12

Which Debian package are you using? Can you post the core dump and any other logs on pastebin? Does it crash in response to some specific action, like clicking a button or dropping files?
:idea: Please read the FAQ and How to Request Help.

martinbarlow
Posts: 3
Joined: 27 Apr 2019, 07:35

Re: _XReply: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Post by martinbarlow » 29 Apr 2019, 17:23

Its always when starting. Once started, its fine. Probably happens 50% of time.

I found it occurs less if i start a CPU intensive task at same time.

Code: Select all

apt show filebot
Package: filebot
Version: 4.8.5
Status: install ok installed
Priority: extra
Section: utils
Maintainer: Reinhard Pointner <[email protected]>
Installed-Size: 150 MB
Depends: openjdk-11-jre
Enhances: nautilus-actions
Homepage: https://www.filebot.net/
Download-Size: unknown
APT-Manual-Installed: yes
APT-Sources: /var/lib/dpkg/status
Description: The ultimate TV and Movie Renamer
 FileBot is the ultimate tool for organizing and renaming your Movies, TV Shows and Anime as well as fetching subtitles and artwork. It's smart and just works.


User avatar
rednoah
The Source
Posts: 16802
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: _XReply: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Post by rednoah » 29 Apr 2019, 20:11

Sorry, not much I can do for generic Linux specific issues. It's most likely not something that can be fixed by making code changes in FileBot.

:arrow: You might be able to find possible workarounds by Googling xcb_xlib_threads_sequence_lost, setting environment variables, forcing GDK 2 or 3, etc.

:arrow: Had a quick look at your crash dump, my best guess, it's some strange wayland issue, cause it's new and not so widely used yet.
:idea: Please read the FAQ and How to Request Help.

james.r.barker
Posts: 6
Joined: 27 Jul 2014, 16:52

Re: _XReply: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Post by james.r.barker » 08 Sep 2019, 00:54

It looks like I'm affected by this as well. Sometimes the error is immediately output. Sometimes filebot opens for about 0.5 seconds then immediately closes (with the error, below). If I try multiple times, filebot will eventually open and remain open.
This occurs both while I'm running within X as well as within Wayland.

filebot
[xcb] Unknown sequence number while processing reply
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
java: ../../src/xcb_io.c:643: _XReply: Assertion `!xcb_xlib_threads_sequence_lost' failed.

Post Reply