Licensed docker - node works, watcher doesn't.

All your suggestions, requests and ideas for future development
Post Reply
argonavis
Posts: 2
Joined: 29 Jul 2019, 21:53

Licensed docker - node works, watcher doesn't.

Post by argonavis » 29 Jul 2019, 22:08

Hello, and thank you for Filebot.

First things first, I tried to retrieve the forum password associated to another email today, to no avail. In the eternal words of Mister T, I therefore pity the fool who would lose their forum password.

Something seems not to be working as it should.

For the rest: I am a (paying) customer, and I am using docker containers on a nas. I am pretty impressed with the filebot-node setup.

I ran it a couple of times against my qbittorrent/nas container, all good and dandy. It worked.

The root media volume is shared across containers. I map it as /volume1, and it contains my filebot output folders, plus a folder named "Active" where qbittorrent files are processed.

I started a filebot-watcher container alongside the filebot-node one. But it failed to run when a new file was completed.

It completely failed to run. I didn't get logs, I didn't get anything. Now, the way things are setup, my files are removed from qbittorrent at completion; while incomplete, they are stored in `Active/incomplete`, once complete, they reside in `Active/unsorted`.

That's where the watcher should expect them.

Code: Select all

docker run -dit --restart always -v $PWD:/volume1 -v data:/data rednoah/filebot:watcher /volume1/Active/unsorted --output /volume1 --action move -non-strict --order Airdate --conflict auto --lang en --def 'music=y' 'unsorted=y' 'clean=y' 'skipExtract=y' 'plex=<removed>' 'seriesFormat=Series/{n}/{episode.special ? '\''Specials'\'' : '\''Season '\''+s.pad(2)}/{n} - {episode.special ? '\''S00E'\''+special.pad(2) : s00e00} - {t.replaceAll(/[`´‘’ʻ]/, /'\''/).replaceAll(/[!?.]+$/).replacePart('\'', Part $1'\'')}{'\''.'\''+lang}' 'excludeList=.excludes' --log all --log-file '/data/.filebot-watcher/filebot.log'
But no worky.

Additionally, the data volume is shared, and in it, I find /data/.filebot/history.xml

Which has everything I processed with filebot-node, but nothing from what I tried to process with filebot-watcher.

User avatar
rednoah
The Source
Posts: 16434
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Licensed docker - node works, watcher doesn't.

Post by rednoah » 30 Jul 2019, 04:29

When you start it, it should at least say something:

Code: Select all

docker run --rm -it -v $PWD:/volume1 -v data:/data rednoah/filebot:watcher /volume1/input --output /volume1/output
Setting up watches.
Watches established.
:idea: The process will then keep running indefinitely.


The script is rather simple, maybe you can figure out why it doesn't work for you:
https://github.com/filebot/plugins/blob ... ot-watcher


:!: Note that watching for file system events isn't exactly something that always works reliably, especially not if you're listening to events on the host from within the docker container.


:idea: It's very likely that it doesn't work because docker doesn't work. You could try running inotifywait on your host directly without docker, if it doesn't work from within docker.
:idea: Please read the FAQ and How to Request Help.

argonavis
Posts: 2
Joined: 29 Jul 2019, 21:53

Re: Licensed docker - node works, watcher doesn't.

Post by argonavis » 30 Jul 2019, 14:10

It does give that output when I run it the way you do. In my example, I chose to use it with the d flag for "daemon" (-dit).

I think it might be an inotify issue. I'll run some experiments and let you know what I find.

Post Reply