Issue with n and primaryTitle

All your suggestions, requests and ideas for future development
Post Reply
devster
Posts: 335
Joined: 06 Jun 2017, 22:56

Issue with n and primaryTitle

Post by devster » 01 Sep 2019, 17:14

I'm currently finding that for John Wick Chapter 3 the following happens:

Code: Select all

{assert n == 'John Wick 3 – Parabellum'}
{assert primaryTitle == 'John Wick: Chapter 3 – Parabellum'}
which is not a behaviour I'm expecting.
I'm testing the above on FileBot 4.8.6 (r6582)

This seems a new behaviour as on FileBot 4.8.5 (r6224) the following happens instead:

Code: Select all

assert n == 'John Wick 3 – Parabellum'
       | |
       | false
       'John Wick: Chapter 3 – Parabellum'
I only work in black and sometimes very, very dark grey. (Batman)

User avatar
rednoah
The Source
Posts: 16812
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Issue with n and primaryTitle

Post by rednoah » 02 Sep 2019, 13:34

Looks good to me:

Code: Select all

{n} | {primaryTitle}

Code: Select all

John Wick: Chapter 3 – Parabellum | John Wick: Chapter 3 – Parabellum

:idea: In this case, the English name {n} is the same as the original name {primaryTitle} as per TheMovieDB.
:idea: Please read the FAQ and How to Request Help.

devster
Posts: 335
Joined: 06 Jun 2017, 22:56

Re: Issue with n and primaryTitle

Post by devster » 02 Sep 2019, 18:42

But that's not what I'm getting for some wicked reason.

Code: Select all

filebot -rename --db TheMovieDB --action test john.wick.chapter.3.parabellum.2019.internal.hdr.2160p.web.x265-deflate.mkv --format '{n} | {primaryTitle}'
Rename movies using [TheMovieDB]
Auto-detect movie from context: [/Users/devster/Movies/john.wick.chapter.3.parabellum.2019.internal.hdr.2160p.web.x265-deflate.mkv]
Stripping invalid characters from new path: John Wick 3 – Parabellum | John Wick: Chapter 3 – Parabellum
[TEST] from [/Users/devster/Movies/john.wick.chapter.3.parabellum.2019.internal.hdr.2160p.web.x265-deflate.mkv] to [/Users/devster/Movies/John Wick 3 – Parabellum John Wick Chapter 3 – Parabellum.mkv]
Processed 1 files
Chapter seems missing in the new version
I only work in black and sometimes very, very dark grey. (Batman)

User avatar
rednoah
The Source
Posts: 16812
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Issue with n and primaryTitle

Post by rednoah » 03 Sep 2019, 04:51

Same after clear cache?
:idea: Please read the FAQ and How to Request Help.

devster
Posts: 335
Joined: 06 Jun 2017, 22:56

Re: Issue with n and primaryTitle

Post by devster » 03 Sep 2019, 08:02

Will try again tonight, weird.
For a moment I thought it was a change which applied some default cleaning to {n} in addition to invalid character removal.
I only work in black and sometimes very, very dark grey. (Batman)

User avatar
rednoah
The Source
Posts: 16812
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Issue with n and primaryTitle

Post by rednoah » 03 Sep 2019, 09:55

{plex} does, yes. But {n} should be the raw data from the movie object.

:idea: You can use {json} for debugging so you can see the raw field values.
:idea: Please read the FAQ and How to Request Help.

Post Reply