[Suggestion] Java version support

All your suggestions, requests and ideas for future development
Post Reply
devster
Posts: 388
Joined: 06 Jun 2017, 22:56

[Suggestion] Java version support

Post by devster »

I was planning the update to 4.9.1, mainly for the anime and dual-db features, but I'm struggling a bit to find minimum supported Java release.
I'm on Ubuntu which has openjdk-11 as a package, is that enough or should I go for 13/14?
Also I would suggest adding that in the release posts, would make it easier.
I only work in black and sometimes very, very dark grey. (Batman)
User avatar
rednoah
The Source
Posts: 19015
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [Suggestion] Java version support

Post by rednoah »

OpenJDK 11 is the current LTS release and installed by default, so that'll work. If you're stuck on Java 8 for some reason, then there's compatibility binaries for that as well.

The documentation is up-to-date as far as I can tell:
https://www.filebot.net/linux/apt.html


:idea: OpenJDK 14.0.1 or higher is a good idea if you're running on a single-core armv7 machine, and C2 is randomly crashing things. But that's just an oddly specific personal anecdote. ;)
:idea: Please read the FAQ and How to Request Help.
kim
Power User
Posts: 1027
Joined: 15 May 2014, 16:17

Re: [Suggestion] Java version support

Post by kim »

FYI: version openjdk-13.0.2 worked for me
10.0.2 failed
User avatar
rednoah
The Source
Posts: 19015
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [Suggestion] Java version support

Post by rednoah »

OpenJDK 11+ is indeed required for all builds that aren't explicitly marked as JDK8 compatible.
:idea: Please read the FAQ and How to Request Help.
kim
Power User
Posts: 1027
Joined: 15 May 2014, 16:17

Re: [Suggestion] Java version support

Post by kim »

How to set default Java version on Ubuntu / Debian
https://computingforgeeks.com/how-to-se ... tu-debian/
devster
Posts: 388
Joined: 06 Jun 2017, 22:56

Re: [Suggestion] Java version support

Post by devster »

Thanks v11 is perfectly alright.
I only work in black and sometimes very, very dark grey. (Batman)
Post Reply