Hanging on start

All your suggestions, requests and ideas for future development
Post Reply
doveman
Posts: 11
Joined: 27 May 2012, 16:40

Hanging on start

Post by doveman »

I'm running Filebot fine on my Win7 x64 system by just running the FileBot_2.62.jar file (i.e. I didn't need to install it) but this wouldn't work on my Win7 x86 system (which I access over RDP), so I've installed the full 32-bit version and that doesn't work either.

When I start Filebot, it shows the outline of the window but then I get an error message with the Problem Event Name "AppHangB1" and Application Name "javaw.exe" v7.0.40.22. I have updated to the latest Java.

Hmm, just found that Java Control Panel does the same thing when I try and open that. Maybe Java's not compatible with RDP (it works in Internet Explorer, but maybe outside that it won't work for some reason). Perhaps someone else who uses RDP could test to check?
doveman
Posts: 11
Joined: 27 May 2012, 16:40

Re: Hanging on start

Post by doveman »

I tested Filebot by logging in to another local (i.e non-RDP) account and it works fine there, so it seems it does have an issue running over RDP for some reason. Hopefully there's a way to fix this as this is how I need to use it.
User avatar
rednoah
The Source
Posts: 19141
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Hanging on start

Post by rednoah »

Seems to be a generic Java/RDP issue that probably affects all Java GUI apps. How about you just do your renaming from the cmdline?
:idea: Please read the FAQ and How to Request Help.
doveman
Posts: 11
Joined: 27 May 2012, 16:40

Re: Hanging on start

Post by doveman »

Ah OK thanks, that's a shame. I'm setting up this machine for someone who's not going to be comfortable using the cmdline (doesn't sound much fun to me either frankly) so I'll have to look for something else for him.
User avatar
rednoah
The Source
Posts: 19141
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Hanging on start

Post by rednoah »

Did some googeling and it might be connected with Java using DirectX for its GUI.

You could try disabling HW acceleration via Java system property

Code: Select all

-Dsun.java2d.d3d=false
(in *.launcher.ini)
:idea: Please read the FAQ and How to Request Help.
doveman
Posts: 11
Joined: 27 May 2012, 16:40

Re: Hanging on start

Post by doveman »

Thanks I've just tried that and it works nicely (as long as I start Filebot with the launcher of course).

I did find another solution, which is to disable Aero. Setting WindowArrangementActive=0 in the registry didn't work, nor did killing dwm.exe but if I stop the "Desktop Window Manager Session Manager" service which runs "C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted" then Filebot opens fine.

I have to be careful not to disable Aero for the other user, which is running Mediaportal, as that requires Aero to function properly. Apparently it might be possible to disable Aero for only the current user with

net stop uxsms

which actually just stops the same ""Desktop Window Manager Session Manager" service, but perhaps doing it that way rather than from services.msc leaves it running for any other users. It's hard to tell as there's always a number of svchost.exe running, so it's not obvious which might be this service. I guess the easiest way to check is to look at the Mediaportal user on the TV and see if Aero features are still working. I guess I could use a script to stop this service when the user logs in and restart it when he logs out, as he's not going to be using Mediaportal at the same time as he's using the PC with his other account so that might be a workable compromise.

Anyway, your fix is simpler :)

Apparently this problem only affects users who simultaneously login with two users (using the RDP patch to enable this) and if the local user logs out, Java apps work normally for the RDP user. It also breaks video playback (I tested and youtube works OK, but Media Player Classic just hangs), so I'll probably need to go down the disabling Aero route to avoid the user running into problems.
Post Reply