4.5 Win installer on 8.1 causes spont reboot

All your suggestions, requests and ideas for future development
Post Reply
sanjonny
Posts: 70
Joined: 08 Feb 2012, 02:55

4.5 Win installer on 8.1 causes spont reboot

Post by sanjonny »

I think it tries to update java and in the process it forces a reboot. It went thru uninstall and then immediately went to reboot (I was running older java at the time so I am guessing that is what caused the problem?)

When the computer was rebooted, java was not updated and filebot 4.5 was not installed. I then again tried to install the 64bit installer and this time it tried to uninstall, then downloaded the 64 bit install package and installed it and then finished, but did not install java, instead dumped me out to the download screen for java.

in the past I know it tried to install 32 bit java in the installer (even on a 64 bit win 8.1 machine) which caused problems. I do not know if that is what caused the reboot or exactly what happened as it just went to restarting. I saw the uninstall progress bar for removing the old version of filebot and then restarting.

I will have to look on my computer to see if java 32 is installed or if I can find anything to see what caused the restart. Lets just say it was not a good time because I had several files open and the forced restart does not make for a happy camper!

In installing the latest java, I got a message that it wanted to uninstall old versions which there were 2 on my computer
Java 7 update 45 (64bit) and another Java version without the 64 bit at the end so I guess maybe thats exactly what happened because I think I only had the 64 bit version of java on the computer before running the installer.

If that is the case for 64 bit, if it is not detecting correctly, then it (java install) should be uncoupled from the filebot installer because a forced restart is not a good thing.

I am only guessing what happened and following the breadcrumbs I happened to see, if there are any logs to look at or whatever, please let me know and I will post them.
User avatar
rednoah
The Source
Posts: 19150
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: 4.5 Win installer on 8.1 causes spont reboot

Post by rednoah »

1.
FileBot installer does not install Java. Java 8 is expected to be already installed on the system. And if not FileBot will still install fine but just won't run.

2.
FileBot installer does not initiate a reboot, nor request one, but MSI sometimes does stupid things. There's little I can do about that. :lol:

Suffice to say I can not reproduce any such issue on 64-bit Windows 8.1
:idea: Please read the FAQ and How to Request Help.
sanjonny
Posts: 70
Joined: 08 Feb 2012, 02:55

Re: 4.5 Win installer on 8.1 causes spont reboot

Post by sanjonny »

It did in the past try to install java, though because I remember the installation of java issue in the past. Maybe that was thru chocolatey and not the msi, but there was definitely a problem.

I would think to replicate it, you might have to not have the latest java on the system (I had 7. whatever) If there is anything like a log I can reference, I might be able to provide more detail as it was definitely weird, I cannot think of anything recently in like the last 2 years that forced a restart without even asking. It said uninstalling and then said restarting, as if it was a system command level with no prompts or anything. And I do not have autoupdating on or anything else that would have done the restart so something really strange went on.
User avatar
rednoah
The Source
Posts: 19150
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: 4.5 Win installer on 8.1 causes spont reboot

Post by rednoah »

You could try sending full system info if you got FileBot working:
viewtopic.php?f=6&t=1868

As for MSI Installer issues you might want to Google and see if anyone has any similar issues. Since the issue is limited to your system there is little I can do about it.

You're welcome to review the code if you think there's an issue:
http://code.openhub.net/file?fid=Taq7u8 ... d=true#L20
:idea: Please read the FAQ and How to Request Help.
mdecker
Posts: 1
Joined: 14 Oct 2014, 19:50

Re: 4.5 Win installer on 8.1 causes spont reboot

Post by mdecker »

I have exactly the same problem with Server 2008 R2 - doesn't finish the removal, jumps to an uncommanded reboot (e.g. not a crash).
Post Reply