I may have to go back to 2.2

All your suggestions, requests and ideas for future development
Post Reply
User avatar
ashfallen0
Power User
Posts: 32
Joined: 14 Jan 2012, 10:44

I may have to go back to 2.2

Post by ashfallen0 »

In version 2.2, I was able to drag/drop large numbers of episodes into the renaming dialog, and select tvrage, and filebot would correctly look for each file individually. New for 2.4 is that for some reason, filebot now assumes that the directory name is the title to search for if I drop one file, and if I have 15 different files it assumes that they are all from the same show-popping up a "please enter series title box".
Image PHPBB3 hates me.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: I may have to go back to 2.2

Post by rednoah »

Did change some of the matching logic for 2.4, maybe have broken what you're doing. I'll look into this when I get back.

Donno if it helps but you can enter many show names when filebot asks for input, e.g. Buffy,Angel,Firefly
:idea: Please read the FAQ and How to Request Help.
User avatar
ashfallen0
Power User
Posts: 32
Joined: 14 Jan 2012, 10:44

Re: I may have to go back to 2.2

Post by ashfallen0 »

Actually, pretty much most of the logic is broken, can you please repost up the link for the older version(s)?
I can add that the tags for [{vf}][{resolution}][{vc}-{ac}] are all broken now. I get title, year, imdb#, and that's all right now, regardless of which name engine I choose.
Image PHPBB3 hates me.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: I may have to go back to 2.2

Post by rednoah »

Huh?? If there's problems it should mostly be with 2.4, maybe Java 6 problems. If you revert to 2.3 it should hopefully work fine till I fix things for 2.4.

Btw about the issue above, if you post he file paths I'll add them to my test cases.
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: I may have to go back to 2.2

Post by rednoah »

Just download older revisions directly from sourceforge.
:idea: Please read the FAQ and How to Request Help.
User avatar
ashfallen0
Power User
Posts: 32
Joined: 14 Jan 2012, 10:44

Re: I may have to go back to 2.2

Post by ashfallen0 »

well, reverted back to 2.3, and my broken tag issues went away. went further back to 2.2 and was able to re-tag multiple shows at once without the program assuming that all the listed episodes were from the same series. so it seems that there's an issue for one 2 revisions back that broke, and one on the current revision.

if you could give me an example of what all software versions and which paths you wish to know about, I'll repost them for you.
Image PHPBB3 hates me.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: I may have to go back to 2.2

Post by rednoah »

I'd help me out alot if you post a set of paths and the tell how you think filebot should handle input like that.
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: I may have to go back to 2.2

Post by rednoah »

ashfallen0 wrote:Actually, pretty much most of the logic is broken, can you please repost up the link for the older version(s)?
I can add that the tags for [{vf}][{resolution}][{vc}-{ac}] are all broken now. I get title, year, imdb#, and that's all right now, regardless of which name engine I choose.
Works perfectly for me with 2.4, looks like for some reason it couldn't load the mediainfo native lib. Note that the FileBot install architecture must match the Java runtime architecture in order to load the mediainfo native lib.
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: I may have to go back to 2.2

Post by rednoah »

ashfallen0 wrote:well, reverted back to 2.3, and my broken tag issues went away. went further back to 2.2 and was able to re-tag multiple shows at once without the program assuming that all the listed episodes were from the same series. so it seems that there's an issue for one 2 revisions back that broke, and one on the current revision.

if you could give me an example of what all software versions and which paths you wish to know about, I'll repost them for you.
Tested with multiple shows per folder and works perfectly for me. What kinda input are you talking about? FileBot never assumes all files belong to the same show.

This is my test-set:

Code: Select all

Mixed/freaks.and.geeks.s01e01-vrs
Mixed/freaks.and.geeks.s01e02-vrs
Mixed/freaks.and.geeks.s01e03-vrs
Mixed/freaks.and.geeks.s01e04-vrs
Mixed/freaks.and.geeks.s01e05-vrs
Mixed/gary.unmarried.s01e01.720p.hdtv.x264-ctu
Mixed/gary.unmarried.s01e02.720p.hdtv.x264-ctu
Mixed/gary.unmarried.s01e03.720p.hdtv.x264-ctu
Mixed/gary.unmarried.s01e04.720p.hdtv.x264-ctu
Mixed/gary.unmarried.s01e05.720p.hdtv.x264-ctu
Mixed/my.name.is.earl.s03e01.720p.hdtv.x264-ctu
Mixed/my.name.is.earl.s03e02.720p.hdtv.x264-ctu
Mixed/My.Name.Is.Earl.S04E01.HDTV.XviD-FQM
Mixed/My.Name.Is.Earl.S04E02.HDTV.XviD-NoTV
Mixed/My.Name.Is.Earl.S04E03.PROPER.HDTV.XviD-NoTV
Mixed/My.Name.Is.Earl.S04E04.HDTV.XviD-DOT
:idea: Please read the FAQ and How to Request Help.
Post Reply