History script not working after upgrade to 4.8.2

All your suggestions, requests and ideas for future development
Post Reply
laharah
Power User
Posts: 6
Joined: 22 Oct 2014, 10:06

History script not working after upgrade to 4.8.2

Post by laharah » 03 Jul 2018, 18:42

Just upgraded to 4.8.2 beta, I'm running into a problem with the history script:

Code: Select all

filebot -script fn:history file.mp4
output:

Code: Select all

startup failed:
Script1.groovy: 6: unable to resolve class groovy.text.GStringTemplateEngine
 @ line 6, column 16.
   def template = new groovy.text.GStringTemplateEngine().createTemplate(format)
                  ^

1 error

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
Script1.groovy: 6: unable to resolve class groovy.text.GStringTemplateEngine
 @ line 6, column 16.
   def template = new groovy.text.GStringTemplateEngine().createTemplate(format)
                  ^

1 error

	at net.filebot.cli.ScriptShell.evaluate(ScriptShell.java:64)
	at net.filebot.cli.ScriptShell.runScript(ScriptShell.java:74)
	at net.filebot.cli.ArgumentProcessor.runScript(ArgumentProcessor.java:148)
	at net.filebot.cli.ArgumentProcessor.run(ArgumentProcessor.java:36)
	at net.filebot.Main.main(Main.java:126)

Failure (°_°)
Perhaps it needs to be updated for java 10? I'm not really a java guy so I don't really know.

I've tested on both Linux and OSX, with the same exact error, but here's my sysinfo anyways:

Code: Select all

FileBot 4.8.2 (r5667)
JNA Native: 5.2.0
MediaInfo: 18.05
7-Zip-JBinding: 9.20
Chromaprint: 1.4.2
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2018-07-02 (r528)
Groovy: 2.5.0
JRE: Java(TM) SE Runtime Environment 10.0.1
JVM: 64-bit Java HotSpot(TM) 64-Bit Server VM
CPU/MEM: 4 Core / 3 GB Max Memory / 36 MB Used Memory
OS: Linux (amd64)
HW: Linux MEDIASERVER 3.16.0-6-amd64 #1 SMP Debian 3.16.56-1+deb8u1 (2018-05-08) x86_64 GNU/Linux
DATA: /home/$USER/.filebot
Package: DEB
License: FileBot License P3963424 (Valid-Until: 2019-07-04)

User avatar
rednoah
The Source
Posts: 14376
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: History script not working after upgrade to 4.8.2

Post by rednoah » 03 Jul 2018, 19:30

Thanks for reporting this one. Looks like a dependency is missing. Nothing you can do about it for new. I'll update the release packages tomorrow with a fix.
:idea: Please read the FAQ and How to Request Help.

laharah
Power User
Posts: 6
Joined: 22 Oct 2014, 10:06

Re: History script not working after upgrade to 4.8.2

Post by laharah » 04 Jul 2018, 09:59

No problem. I noticed it when the history wasn't showing up in FileBotTool

User avatar
rednoah
The Source
Posts: 14376
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: History script not working after upgrade to 4.8.2

Post by rednoah » 04 Jul 2018, 10:02

Fixed with r5673 which is being uploaded as we speak.
:idea: Please read the FAQ and How to Request Help.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests