Graphical glitch in the GUI version Windows 10

All your suggestions, requests and ideas for future development
Post Reply
Daemon88
Posts: 2
Joined: 09 Nov 2018, 08:52

Graphical glitch in the GUI version Windows 10

Post by Daemon88 » 09 Nov 2018, 09:00

I've just recently moved to Windows 10 and I've noticed these graphical glitches (typically when hovering over action buttons) whilst using the GUI. The program works fine otherwise, though it can get a little difficult to navigate. Any idea's as to how I might go about rectifying this issue?

Code: Select all

FileBot 4.8.2 (r5789)
JNA Native: 5.2.2
MediaInfo: 18.05
7-Zip-JBinding: 9.20
Chromaprint: 1.4.2
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2018-10-05 (r536)
Groovy: 2.5.1
JRE: Java(TM) SE Runtime Environment 10.0.2
JVM: 64-bit Java HotSpot(TM) 64-Bit Server VM
CPU/MEM: 12 Core / 3 GB Max Memory / 76 MB Used Memory
OS: Windows 10 (amd64)
Package: MSI

Image

User avatar
rednoah
The Source
Posts: 14872
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Graphical glitch in the GUI version Windows 10

Post by rednoah » 09 Nov 2018, 11:18

rednoah wrote:Q: UI is glitching. FileBot crashes on startup. What's wrong?
Graphics glitching all over? FileBot not working via remote desktop (RDP)? You may need to tell Java Swing to turn off Direct3D rendering:

Code: Select all

setx J2D_D3D false
This should do the trick. Just turn off graphics acceleration via the environment variable mentioned above.
:idea: Please read the FAQ and How to Request Help.

Daemon88
Posts: 2
Joined: 09 Nov 2018, 08:52

Re: Graphical glitch in the GUI version Windows 10

Post by Daemon88 » 09 Nov 2018, 11:43

rednoah wrote:
09 Nov 2018, 11:18
This should do the trick. Just turn off graphics acceleration via the environment variable mentioned above.
Thanks, that did it!

Sirillion
Posts: 9
Joined: 23 Feb 2017, 22:17

Re: Graphical glitch in the GUI version Windows 10

Post by Sirillion » 07 Jan 2019, 16:12

Thanks, have had this issue for a while now and never figured I could go here ask about it >_<

I had it worked down to it happening when the mouse over tip displays and that maximizing the window and/or moving it to another monitor would "fix" it for a while.

User avatar
rednoah
The Source
Posts: 14872
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Graphical glitch in the GUI version Windows 10

Post by rednoah » 07 Jan 2019, 16:18

Sirillion wrote:
07 Jan 2019, 16:12
Thanks, have had this issue for a while now and never figured I could go here ask about it >_<

I had it worked down to it happening when the mouse over tip displays and that maximizing the window and/or moving it to another monitor would "fix" it for a while.
For the sake of statistics. Are you using MSI installer or Windows Store? What graphics card / drivers are you using?
:idea: Please read the FAQ and How to Request Help.

Sirillion
Posts: 9
Joined: 23 Feb 2017, 22:17

Re: Graphical glitch in the GUI version Windows 10

Post by Sirillion » 07 Jan 2019, 16:29

I am using the one from the Windows Store with version number 4,8,4,0 and I have a ASUS Strix GTX1080Ti and are currently on nVidia 417.35 drivers with the GeForce Experience software.

I can also mention that when finding the Preset thing you mentioned earlier today this happened instantly when I clicked the Presets button on the main screen.

User avatar
rednoah
The Source
Posts: 14872
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Graphical glitch in the GUI version Windows 10

Post by rednoah » 07 Jan 2019, 16:40

Got it. It seems to be more common for the Windows Store version somehow. Future Windows Store version will disable graphics acceleration by default.
:idea: Please read the FAQ and How to Request Help.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests