Bug? Filebot CLI using directory name to match

All your suggestions, requests and ideas for future development
Post Reply
boredazfcuk
Posts: 1
Joined: 30 Aug 2013, 13:04

Bug? Filebot CLI using directory name to match

Post by boredazfcuk »

Hi,

I downloaded filebot so that I can use it to automatically rename my media files on a headless Debian Linux box.

I have my movies stored in 3 separate folders. Movies, Kids and Collection.

When I run filebot -rename /mnt/HD1/Kids/ -non-strict --action test | grep TEST I get:

Code: Select all

[TEST] Rename [/mnt/HD1/Kids/<MovieName> (1987).mkv] to [Kids (1995), Part 1.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (1995).mkv] to [Kids (1995), Part 2.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2008).mkv] to [Kids (2008), Part 1.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2008).mkv] to [Kids (2008), Part 2.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2008).mkv] to [Kids (2008), Part 3.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2008).mkv] to [Kids (2008), Part 4.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2008).mkv] to [Kids (2008), Part 5.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2008).mkv] to [Kids (2008), Part 6.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2013).avi] to [Kids (2008).avi]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2009).mkv] to [Kids (2009), Part 1.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2009).mkv] to [Kids (2009), Part 2.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2009).mkv] to [Kids (2009), Part 3.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2009).mkv] to [Kids (2009), Part 4.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2009).mkv] to [Kids (2009), Part 5.mkv]
[TEST] Rename [/mnt/HD1/Kids/<MovieName> (2009).mkv] to [Kids (2009), Part 6.mkv]
If I run filebot against all the files in my Collection folder, a lot of stuff gets matched to UB40 - The collection (2002).

It seems that it's using the folder name (or even the entire path?) as part of the search criteria. Is this expected behaviour? I can't see any options in the help section that would appear to give me control over something like this. As a result I'm getting around 30% misnamed files.

Thanks,

Boredazfc
User avatar
rednoah
The Source
Posts: 19140
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Bug? Filebot CLI using directory name to match

Post by rednoah »

Series folder? Movie folder? Specify --db to force movie / series mode.

For any advanced processing "just auto-detect everything" logic use the AMC script.

EDIT: Blacklisted "Kids", try again tomorrow.
:idea: Please read the FAQ and How to Request Help.
Post Reply