Java failure while running script

All your suggestions, requests and ideas for future development
Post Reply
Alfke
Posts: 20
Joined: 24 Jan 2017, 18:11

Java failure while running script

Post by Alfke » 06 Mar 2019, 21:39

On Centos 7,

While running the filebot -script fn:mi command, my output file contained very little information (filebot displayed no errors).

So I ran filebot -script fn:sysinfo and came accross this java error:

Code: Select all

FileBot 4.8.2 (r5789)
JNA Native: 5.2.2
MediaInfo: net.filebot.mediainfo.MediaInfoException: Unable to load amd64 (64-bit) native library libmediainfo.so: Unable to load library 'zen': Native library (linux-x86-64/libzen.so) not found in resource path ([file:/home/computer/filebot/jar/filebot.jar])
7-Zip-JBinding: 9.20
Chromaprint: java.io.IOException: Cannot run program "fpcalc": error=2, No such file or directory
This tells me Media Info has a path issue. Both .so files appear on my system. I'm sure this can be fixed with the EXPORT command, but I'm not clear on the command to correct this using the CLI. Please advise.

Thanks

Alfke
Licensed User

User avatar
rednoah
The Source
Posts: 16984
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Java failure while running script

Post by rednoah » 07 Mar 2019, 04:47

1.
You'll need compatible libmediainfo.so and libzen.so libraries.

You may find compatible libraries here:
https://mediaarea.net/en/MediaInfo/Download


2.
Does CentOS use RPM packages?

There's new RPM packages you can try:
viewtopic.php?f=6&t=9535

Only tested on Fedora though, but might work on CentOS if we're lucky with dependency versions in the OS repo.
:idea: Please read the FAQ and How to Request Help.

Alfke
Posts: 20
Joined: 24 Jan 2017, 18:11

Re: Java failure while running script

Post by Alfke » 07 Mar 2019, 16:28

All fixed with one command from CLI:

yum install mediainfo

For reference, I'm on CentOS Linux release 7.6.1810 (Core)

Thanks for your help!

Alfke
Licensed User

User avatar
rednoah
The Source
Posts: 16984
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Java failure while running script

Post by rednoah » 07 Mar 2019, 16:55

If you could try the RPM package to see if it works out-of-the-box on CentOS, that would be appreciated.
:idea: Please read the FAQ and How to Request Help.

Alfke
Posts: 20
Joined: 24 Jan 2017, 18:11

Re: Java failure while running script

Post by Alfke » 07 Mar 2019, 19:37

Just installed the rpm successfully on Centos:

Installed:
libmediainfo-devel.x86_64 0:18.12-2.2

Dependency Installed:
libcurl-devel.x86_64 0:7.29.0-51.el7 libzen-devel.x86_64 0:0.4.37-1.el7
Licensed User

User avatar
rednoah
The Source
Posts: 16984
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Java failure while running script

Post by rednoah » 07 Mar 2019, 19:52

Please run filebot -script fn:sysinfo to check if everything is working fine.
:idea: Please read the FAQ and How to Request Help.

Alfke
Posts: 20
Joined: 24 Jan 2017, 18:11

Re: Java failure while running script

Post by Alfke » 07 Mar 2019, 19:58

Code: Select all

FileBot 4.8.2 (r5789)
JNA Native: 5.2.2
MediaInfo: 18.12
7-Zip-JBinding: 9.20
Chromaprint: java.io.IOException: Cannot run program "fpcalc": error=13, Permission denied
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2019-02-26 (r552)
Groovy: 2.5.1
JRE: OpenJDK Runtime Environment 1.8.0_201
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 4 Core / 798 MB Max Memory / 23 MB Used Memory
OS: Linux (amd64)
HW: Linux cougar.hunter.ca 3.10.0-957.1.3.el7.x86_64 #1 SMP Thu Nov 29 14:49:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
DATA: /home/plex/filebot/data/plex
Package: TAR

(process:27480): dconf-CRITICAL **: 12:55:36.521: unable to create directory '/run/user/0/dconf': Permission denied.  dconf will not work properly.
: Permission denied.  dconf will not work properly.
License: FileBot License PX7096420 (Valid-Until: 2069-02-26)
Done ヾ(@⌒ー⌒@)ノ
Those are the same errors I received before, but they do not impact filebot from what I can see.
Licensed User

User avatar
rednoah
The Source
Posts: 16984
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Java failure while running script

Post by rednoah » 07 Mar 2019, 21:31

Yep. It's all good. Just warnings that can be ignored. MediaInfo should work fine now out-of-the-box.
:idea: Please read the FAQ and How to Request Help.

Post Reply