OpenSubtitles.org blocked in Denmark

Any questions? Need some help?
Post Reply
EnZo
Posts: 6
Joined: 12 Jan 2020, 13:34

OpenSubtitles.org blocked in Denmark

Post by EnZo »

OpenSubtitles has been blocked here in Denmark for about a month and I am trying to get a workaround for FileBot so it can download subtitles again. The only thing i can make work is via VPN (which isnt good, because it throttles my speed). I tried using a private proxy thats located in england, but i keep getting the error "Not in GZIP format". The website works fine with the proxy, but maybe their API detects that its a proxy?
I tired setting the proxy setting in Java Control Panel, in the filebot.launcher.l4j.ini file and as system properties (dont know if I did that last one right), and the error is still there.
Is there anything i can do to make it work?
User avatar
rednoah
The Source
Posts: 18986
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: OpenSubtitles.org blocked in Denmark

Post by rednoah »

You can set Java System Properties for FileBot via the FILEBOT_OPTS environment variable from CMD like so:

Code: Select all

setx FILEBOT_OPTS="-Dhttps.proxyHost=<HOST> -Dhttps.proxyPort=<PORT>"
:idea: https://docs.oracle.com/javase/8/docs/t ... oxies.html
:idea: Please read the FAQ and How to Request Help.
EnZo
Posts: 6
Joined: 12 Jan 2020, 13:34

Re: OpenSubtitles.org blocked in Denmark

Post by EnZo »

I get invalid syntax error with that command. I tried replacing <HOST> with the IP and <PORT> with the port, with and without "<>".
User avatar
rednoah
The Source
Posts: 18986
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: OpenSubtitles.org blocked in Denmark

Post by rednoah »

Well, I guess setx doesn't like the = then.

Try this:

Code: Select all

setx FILEBOT_OPTS "-Dhttps.proxyHost=<HOST> -Dhttps.proxyPort=<PORT>"
:idea: Please read the FAQ and How to Request Help.
EnZo
Posts: 6
Joined: 12 Jan 2020, 13:34

Re: OpenSubtitles.org blocked in Denmark

Post by EnZo »

The command works now, but it still gives the same error. Is it possible that they can detect proxies in their API? Or maybe it doesn't connect with the proxy. Is there a way to check if it works?

EDIT: After a reboot it started working. Thanks for the help and this great program!
User avatar
rednoah
The Source
Posts: 18986
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: OpenSubtitles.org blocked in Denmark

Post by rednoah »

Windows environment variables can be tricky. Sometimes you need to restart things. At least the process. Sometimes the OS, which in turn means all processes are restarted with the latest environment variables.
:idea: Please read the FAQ and How to Request Help.
EnZo
Posts: 6
Joined: 12 Jan 2020, 13:34

Re: OpenSubtitles.org blocked in Denmark

Post by EnZo »

After more testing, it seems like the problem is still persistant in the amc script. Is there a way to use the proxy with that too?
User avatar
rednoah
The Source
Posts: 18986
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: OpenSubtitles.org blocked in Denmark

Post by rednoah »

FILEBOT_OPTS should be a global environment variable and should work for everything. You can run filebot -script fn:sysenv (e.g. instead of the amc script) to check if the environment / system properties are indeed set.
:idea: Please read the FAQ and How to Request Help.
EnZo
Posts: 6
Joined: 12 Jan 2020, 13:34

Re: OpenSubtitles.org blocked in Denmark

Post by EnZo »

Everything seems to look fine with that script. But it still doesn't seem to work with the amc script (still the GZIP format error). The FileBot (console) works fine but the other launcher without the console doesnt.. This seems very wierd. I think ill do a clean install of FileBot and see if that helps.
EnZo
Posts: 6
Joined: 12 Jan 2020, 13:34

Re: OpenSubtitles.org blocked in Denmark

Post by EnZo »

Okay, after reinstalling and restarting it seems to work fine with the script. Thanks for the help!
Post Reply