amc --def seriesDB="TheMovieDB::TV" not working

Any questions? Need some help?
Post Reply
mike4411
Posts: 2
Joined: 02 Mar 2020, 17:14

amc --def seriesDB="TheMovieDB::TV" not working

Post by mike4411 » 02 Mar 2020, 17:36

Hi,

i have:

Code: Select all

filebot -script fn:amc --action test --def seriesDB="TheMovieDB::TV" --conflict auto -non-strict --def music=y --def extras=y --def tmdbTV=y "/files/TV" --log-file /files/amc-tv.log --def subtitles=y --def clean=y --def "seriesFormat=/files/Plex/TV/{n}/Season {s}/{n} {s00e00} {t} {vf} {vc} {ac} {id}-{s}-{e}" artwork=y --def excludeList=/files/TV/amc.txt --def reportError=y --def mailto=
and the output is:

Code: Select all

Run script [fn:amc] at [Mon Mar 02 17:09:32 UTC 2020]
Parameter: seriesDB = TheMovieDB::TV
Parameter: music = y
Parameter: extras = y
Parameter: tmdbTV = y
Parameter: subtitles = y
Parameter: clean = y
Parameter: seriesFormat = /files/Plex/TV/{n}/Season {s}/{n} {s00e00} {t} {vf} {vc} {ac} {id}-{s}-{e}
Parameter: artwork = y
Parameter: excludeList = /files/TV/amc.txt
Parameter: reportError = y
Parameter: mailto = *****
Argument[0]: /files/TV
Use excludes: /files/TV/amc.txt (1)
Input: /files/TV/Accused/Season 2/Accused S02E01 Tracie's Story 1080p AVC AC3 72663-2-1.mkv
xattr: [Accused S02E01 Tracie's Story 1080p AVC AC3 72663-2-1.mkv] => [Accused - 2x01 - Tracie's Story]
Group: [tvs:accused] => [Accused S02E01 Tracie's Story 1080p AVC AC3 72663-2-1.mkv]
CmdlineException: Illegal language code: y
Rename episodes using [TheTVDB]
Auto-detected query: [Accused]
Fetching episode data for [Accused]
Fetching episode data for [Accusé]
Fetching episode data for [Accused (US)]
Fetching episode data for [Accused (ES)]
Fetching episode data for [The Accused]
[TEST] from [/files/TV/Accused/Season 2/Accused S02E01 Tracie's Story 1080p AVC AC3 72663-2-1.mkv] to [/files/Plex/TV/Accused/Season 2/Accused S02E01 Tracie's Story 1080p AVC AC3 72663-2-1.mkv]
Processed 1 files
Done ヾ(@⌒ー⌒@)ノ
Now i have two questions.

#1 Why i get: CmdlineException: Illegal language code: y

#2 I use --def seriesDB="TheMovieDB::TV" and --def tmdbTV=y but for rename Filebot use: Rename episodes using [TheTVDB]

The output is ... Accused S02E01 Tracie's Story 1080p AVC AC3 72663-2-1.mkv
72663 is the TheTVDB ID but i need the TheMovieDB ID

How can i get the TheMovieDB ID 32940?

How it should be:

Code: Select all

Accused S02E01 Tracie's Story 1080p AVC AC3 32940-2-1.mkv

User avatar
rednoah
The Source
Posts: 17896
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: amc --def seriesDB="TheMovieDB::TV" not working

Post by rednoah » 02 Mar 2020, 18:36

What does filebot -script fn:sysinfo say?


1.
--def subtitles=y is invalid usage. The correct usage is --def subtitles=en or --def subtitles=en,de and so on.


2.
--def tmdbTV=y is not a valid option. --def seriesDB is a valid option but it was only added recently, so you will likely need to upgrade to the latest beta for that one.
:idea: Please read the FAQ and How to Request Help.

kim
Power User
Posts: 900
Joined: 15 May 2014, 16:17

Re: amc --def seriesDB="TheMovieDB::TV" not working

Post by kim » 02 Mar 2020, 20:07

The "--def tmdbTV" part is only valid when using my CUSTOM amc script, look here for more info:
viewtopic.php?f=4&t=5451

mike4411
Posts: 2
Joined: 02 Mar 2020, 17:14

Re: amc --def seriesDB="TheMovieDB::TV" not working

Post by mike4411 » 02 Mar 2020, 21:16

Thank you very much for the fast reply!

filebot -script fn:sysinfo:

Code: Select all

FileBot 4.8.2 (r5789)
JNA Native: 5.2.2
MediaInfo: 18.05
7-Zip-JBinding: 9.20
Chromaprint: 1.4.2
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2019-02-26 (r552)
Groovy: 2.5.1
JRE: Java(TM) SE Runtime Environment 10.0.2
JVM: 64-bit Java HotSpot(TM) 64-Bit Server VM
CPU/MEM: 5 Core / 29 GB Max Memory / 37 MB Used Memory
OS: Linux (amd64)
HW: Linux
EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
DATA: /.filebot
Package: DEB
License: FileBot License XXXXXXX (Valid-Until: 2021-XXXX)

------------------- UPDATE AVAILABLE: FileBot 4.8.5 (r6224) --------------------
So i need to update filebot to use --def seriesDB

To which version i need to update?

Thank you very much!


Post Reply