Banned

Any questions? Need some help?
Post Reply
seibop
Posts: 5
Joined: 08 Mar 2020, 13:33

Banned

Post by seibop » 08 Mar 2020, 13:47

my license got banned for abuse, I have no idea why it was showing as activation. I have a couple of post processing scripts (one that runs after every download) and a couple times per day cleanup script.

I've ran both of these for a while. No where in them am I doing anything that is activating or similar.

Can you tell me what specifically the script was doing that got the license banned?

User avatar
rednoah
The Source
Posts: 17864
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Banned

Post by rednoah » 08 Mar 2020, 15:53

You will have received individual warning emails for weeks before your eventual ban which include all your license activations from our server-side logs. Your logs on the client-side across all your machines will match those one by one.

FileBot License System wrote:FileBot License PX11682235 has been activated 190 times between 2020-02-29 and 2020-03-06 and has been flagged for abuse and may eventually get banned if abuse continues.

Please read this thread for details and fix your setup accordingly:
viewtopic.php?t=9594

Recent activation logs:

Code: Select all

2020-02-29 00:17:20    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 00:52:21    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 01:27:20    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 02:02:20    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 02:34:43    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 03:11:35    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 04:12:21    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 04:47:23    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 05:22:21    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-02-29 05:57:21    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
⋮
2020-03-06 02:21:04    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 02:56:04    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 03:31:04    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 04:06:04    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 04:41:04    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 05:11:33    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 06:16:04    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 06:51:04    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 07:21:08    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2
2020-03-06 14:46:09    [US] 96.44.145.26    [MSI] FileBot/4.8.5 Java/11.0.2

Unfortunately, only you can know what you are doing wrong specifically, though it's always some variation of "persistent storage wiped between runs" described here:
viewtopic.php?t=9594


What do your client-side logs say?
rednoah wrote:
29 Dec 2018, 06:21
7.
DO check your --log-file once in a while to see if everything is in order:

Code: Select all

grep "Activate License" /path/to/log

Code: Select all

Activate License P1234567
:!: Activate License P1234567 MUST NOT show up in your log for each and every filebot call. You will see this message once or twice per month during normal usage. If you see this message hundreds of times per day, then you need to fix your setup. (NOTE: Activate License logging requires FileBot 4.8.5 or higher)

:!: The FileBot log file does not include system console output. Please read Shell Script Debugging for Beginners on how to collect complete console output including crash dumps and device errors. (NOTE: extremely useful for debugging strange issues)
:idea: Please read the FAQ and How to Request Help.

seibop
Posts: 5
Joined: 08 Mar 2020, 13:33

Re: Banned

Post by seibop » 09 Mar 2020, 01:17

no automated script does any of the don't. (IE I'm not activating it, clearing cache, etc)….

Automated Script Call:

Code: Select all

filebot -script fn:amc --output "m:\plexmedia"  --action copy --conflict auto -get-subtitles -non-strict --log-file amc.log --def unsorted=y music=n ut_label=movie  %ut_dir% 
Example log:

Code: Select all

Run script [fn:amc] at [Sat Mar 07 11:11:54 PST 2020]
Parameter: unsorted = y
Parameter: music = n
Parameter: ut_label = movie
Argument[0]: S:\dl\complete\Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO
Skip small video file: Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO.mkv
Input: S:\dl\complete\Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO\Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO.mkv
Group: [Movie:true] => [Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO.mkv]
Rename movies using [TheMovieDB]
Auto-detect movie from context: [S:\dl\complete\Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO\Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO.mkv]
[COPY] from [S:\dl\complete\Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO\Run.This.Town.2019.720p.WEBRip.X264.AC3-EVO.mkv] to [M:\PlexMedia\Movies\Run This Town (2019)\Run This Town (2019).mkv]
Processed 1 files
Done ヾ(@⌒ー⌒@)ノ

seibop
Posts: 5
Joined: 08 Mar 2020, 13:33

Re: Banned

Post by seibop » 09 Mar 2020, 01:26

okay, in checking a different log, I see

Code: Select all

Run script [fn:amc] at [Sun Feb 09 19:23:36 PST 2020]
Parameter: unsorted = y
Parameter: music = n
Parameter: deleteAfterExtract = y
Parameter: clean = y
Argument[0]: D:\Input\movies
Activate License P1234567
Illegal usage: output folder must exist and must be a directory: M:\plexmedia
Abort (×_×)
I did have a couple issues with a networked drive. I am not asking filebot to activate the license... was a failure of the network drive an issue ??

User avatar
rednoah
The Source
Posts: 17864
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Banned

Post by rednoah » 09 Mar 2020, 05:51

1.
What does the complete log say? It should be very long, as you're calling filebot hundreds of times per week.

The complete log will contain at least 190 lines of Activate License logging:

Code: Select all

Activate License P1234567
:idea: Typical users will see this message once a month. You can confirm if your setup is working correctly by yourself by counting how often Activate License appears in your logs per month.

:idea: If you can't find 190 lines of Activate License logging, then you're using filebot without --log-file somehow somewhere.



2.
This just means that --output did not exist when the amc script was called that one time, and so the script aborted immediately. This is completely unrelated to licensing.

Code: Select all

Illegal usage: output folder must exist and must be a directory: M:\plexmedia
:idea: All persistent data related to caching and licensing is in the %APP_DATA% folder, which should be on your local hard drive and thus not be affected by failures in your network drives.



3.
The next step are as follows, I will unban your license, but if you don't fix the under lying issue, it'll just get banned again after a few weeks. I can assure you that this is a unique issue specific to your machine, no other licensee is affected. It could be anything, it's your machine after all.


:idea: You will also need to get into a habit of checking your Junk Email folder and figure out how to configure your email service to make it deliver important emails into your Inbox:
https://outlook.live.com/mail/0/junkemail


EDIT:

:idea: Though one similar case that I can recount was, after wasting lots of time, the user remembered he had some strange program installed that would regularly delete %APP_DATA% files. There was no possible way for anyone to have guessed that.
:idea: Please read the FAQ and How to Request Help.

seibop
Posts: 5
Joined: 08 Mar 2020, 13:33

Re: Banned

Post by seibop » 09 Mar 2020, 16:36

I'm sure its unique to me. I CLEARLY changed something. (And yes my log file was very long, about 2GB in total length). Something I did was screwy. I've added filebot to my safe folder (you were right, the notices were going to junk, and I wasn't seeing them)

I did do a ton of different automation efforts for filebot, and clearly something that I did was in error, and since you're one of the automation scripts I was doing, was deleting files... I may have been deleting the filebot data by mistake.

I've disabled 12 of the 14 automated efforts. So I shouldn't be re-activating the license as I was.

seibop
Posts: 5
Joined: 08 Mar 2020, 13:33

Re: Banned

Post by seibop » 09 Mar 2020, 17:00

okay, I guess for future, and maybe you might want to add this to your banned master thread...

I had multiple automated scripts and processes using AMC.LOG. which made it like impossible to determine WHICH process was doing the deed.

So now, I've renamed all my FileBot Log files to correspond to the process calling them. IE: I have a cleanup process that runs. So Logfile is AMCCLEANUP.LOG. Another is a final process check and verify. that log file is AMCFINAL.LOG... etc... So in the future if I get an error, or make a change, then in looking at the different log files, then I can see which process is the offending process.

Too many computers, executing too many automated process, and one person making a change.. and oops. Maybe I need to schedule a change pre-change process meeting to determine the proper people that should be involved in the actual change process meeting so we can have a project manager assigned, to ensure that as we are selecting the proper change process people in the pre-change process meeting.... (Dilbert/real live... lol)

User avatar
rednoah
The Source
Posts: 17864
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Banned

Post by rednoah » 09 Mar 2020, 17:06

Well, my advice would actually have been using a single log file for all of them, only FileBot instances of course. That will ensure only one instance of FileBot being active at any given time, because FileBot will keep a lock on the log file while it's running.

Plus you can easily grep all logs for all calls. And that information tells us if it's generally working or not. The root cause of the problem would be something external to FileBot thought. The log can really only tell us if it's fixed or not, but perhaps can't tell us the root cause.

Once we find the root cause. We'll add it do the list.



EDIT:

:idea: Using the same --log-file /path/to/log.txt would actually be recommended especially if you're doing lots of filebot calls potentially in parallel. The --log-file due to the file lock will ensure that only one filebot processing is actively running at any given time, while the others wait for the file lock.
:idea: Please read the FAQ and How to Request Help.

Post Reply