Movies has completely wrong association

Any questions? Need some help?
Post Reply
martinorob
Posts: 3
Joined: 05 Jan 2021, 08:48

Movies has completely wrong association

Post by martinorob »

Hi all,
tonight i’ve rename all my movies with this command:

Code: Select all

filebot -d -script fn:amc --action move --conflict override -non-strict --def artwork=y --def clean=y -r --def plex="plex.mydomain.it:mykey" "/volume1/Library/FilmTemp/" --output "/volume1/Library/Film/" --def subtitles=it --lang it -r -no-xattr --format {plex.tail} -non-strict --log-file /volume1/Script/filebot.log
but 1000 movies has been associated with strange Series that aren’t in my library.

Code: Select all

[MOVE] from [/volume1/Library/FilmTemp/C'è tempo (2019).avi] to [/volume1/Library/Film/Gli Zonzoli/Season 01/Gli Zonzoli - S01E19 - Race Around the World.avi]
[MOVE] from [/volume1/Library/FilmTemp/Chloe.Tra.Seduzione.E.Inganno.2009.iTALiAN.DVDRip.XviD-TRL.CD2.avi] to [/volume1/Library/Film/Gli Zonzoli/Season 01/Gli Zonzoli - S01E09 - It's Great to Be a Ghost.avi]
[MOVE] from [/volume1/Library/FilmTemp/Corto Circuito 2.avi] to [/volume1/Library/Film/Gli Zonzoli/Season 02/Gli Zonzoli - S02E11 - Cops and Robots.avi]
[MOVE] from [/volume1/Library/FilmTemp/Fai bei sogni (2016).avi] to [/volume1/Library/Film/Gli Zonzoli/Specials/Gli Zonzoli - S00E16 - Music Video - Can't Stop The Cops.avi]
Now i have 1000 movies with wrong name.
How was this possible? What i have wrong? How i can undo this situation?

Please,
Thanks
User avatar
rednoah
The Source
Posts: 19341
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Movies has completely wrong association

Post by rednoah »

1.
You can use filebot -revert to revert files.

:idea: You'll want to use the GUI in the future if you can. User Interaction is a good thing for one-off tasks.

:idea: Alternatively, if you are keen on using the CLI, then using --action TEST and --mode interactive is highly recommended.



2.
Since each file got matched to the same invalid series, the root cause is likely in your folder structure somewhere, perhaps a misleading folder name, a misleading nfo file, etc. You can use trial & error (e.g. new folder, single file, no extras, etc) to figure out what makes it not work in your case.

e.g.

Code: Select all

filebot -rename -r FilmTemp --output . -non-strict --action TEST --log INFO
[TEST] from [FilmTemp/C'è tempo (2019).mkv] to [C'è tempo (2019).mkv]


3.
If you already know that you're going to process only movies, then you'll want to force Movie mode, otherwise things might awry, especially if you're using -non-strict as well:
rednoah wrote: 01 Aug 2012, 13:04 You can (and should) force Movie / Series / Anime mode or force ignore files via labels, e.g. label as Movie to force TheMovieDB, Series to force TheTVDB, Anime to force AniDB, or other to ignore all files. Alternatively, standard folder names such as Movies / TV Shows / Anime may also be used to force a specific mode.


4.
-d flag has no effect if you're using the amc script.

:idea: filebot -rename -d allows you to literally rename folders, as opposed to renaming the files inside those folders.
:idea: Please read the FAQ and How to Request Help.
martinorob
Posts: 3
Joined: 05 Jan 2021, 08:48

Re: Movies has completely wrong association

Post by martinorob »

Thank you for you explanation
martinorob
Posts: 3
Joined: 05 Jan 2021, 08:48

Re: Movies has completely wrong association

Post by martinorob »

Unfortunately I have the same error:

Code: Select all

filebot -script fn:amc --def "ut_label=Movies" --action TEST --conflict index --def artwork=n --def clean=y -r "/volume1/Library/FilmAggiustati/" --output "/volume1/Library/Film/" -non-strict --format {plex.tail} --log-file /volume1/Script/amc.log --log ALL

Code: Select all

[TEST] from [/volume1/Library/FilmAggiustati/BeforeSunset-.Prima.del.tramonto.2004.avi] to [/volume1/Library/Film/El sur (1983)/El sur (1983).avi]
[TEST] from [/volume1/Library/FilmAggiustati/LaStirpe.Del.Male.avi] to [/volume1/Library/Film/El sur (1983)/El sur (1983) CD1.avi]
[TEST] from [/volume1/Library/FilmAggiustati/Ledonne.del.6.piano.avi] to [/volume1/Library/Film/El sur (1983)/El sur (1983) CD2.avi]
[TEST] from [/volume1/Library/FilmAggiustati/Lafebbre.del.sabato.sera.1977.avi] to [/volume1/Library/Film/El sur (1983)/El sur (1983).avi]
[TEST] from [/volume1/Library/FilmAggiustati/Lamossa.del.cavallo.-.Cera.una.volta.Vigata.2018.avi] to [/volume1/Library/Film/El sur (1983)/El sur (1983).avi]
[TEST] from [/volume1/Library/FilmAggiustati/Legrida.del.silenzio.2018.avi] to [/volume1/Library/Film/El sur (1983)/El sur (1983).avi]
[TEST] from [/volume1/Library/FilmAggiustati/ThePostmanl.uomo.del.giorno.dopo.avi] to [/volume1/Library/Film/El sur (1983)/El sur (1983).avi]
[TEST] from [/volume1/Library/FilmAggiustati/Ilregno.del.fuoco..2002..mkv] to [/volume1/Library/Film/El sur (1983)/El sur (1983).mkv]
[TEST] from [/volume1/Library/FilmAggiustati/Incontriravvicinati.del.terzo.tipo..1977..mkv] to [/volume1/Library/Film/El sur (1983)/El sur (1983).mkv]
[TEST] from [/volume1/Library/FilmAggiustati/Lagrandefuga.del.nonno..2018..mkv] to [/volume1/Library/Film/El sur (1983)/El sur (1983).mkv]
[TEST] from [/volume1/Library/FilmAggiustati/Lemeraviglie.del.mare..2017..mkv] to [/volume1/Library/Film/El sur (1983)/El sur (1983).mkv]
[TEST] from [/volume1/Library/FilmAggiustati/Lultimaruota.del.carro.mkv] to [/volume1/Library/Film/El sur (1983)/El sur (1983).mkv]
What I have do wrong now?
User avatar
rednoah
The Source
Posts: 19341
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Movies has completely wrong association

Post by rednoah »

rednoah wrote: 05 Jan 2021, 09:43 2.
Since each file got matched to the same invalid series, the root cause is likely in your folder structure somewhere, perhaps a misleading folder name, a misleading nfo file, etc. You can use trial & error (e.g. new folder, single file, no extras, etc) to figure out what makes it not work in your case.

e.g.

Code: Select all

filebot -rename -r FilmTemp --output . -non-strict --action TEST --log INFO
[TEST] from [FilmTemp/C'è tempo (2019).mkv] to [C'è tempo (2019).mkv]
We can't know why it doesn't work for you. You're the only person in the world who can find out why it doesn't work for your specific set of files.


:arrow: Please use systematic trial & error to create a reproducible test case. The first step is to create a simple test case to works, to make sure we're on the same page, and then add complexity step by step until we find out what specific step makes it not work.


:idea: If you add -non-strict then you accept mismatches. If you remove -non-strict then you accept that some files cannot be matched reliably. There's pros and cons either way. If all your files a reasonably well-named and have the movie year in the filename, then Strict Mode might work better for you.
:idea: Please read the FAQ and How to Request Help.
Post Reply