Filebot Mismatching Show (when using --q <id> to force a show)

Any questions? Need some help?
Post Reply
brijazz
Posts: 2
Joined: 25 May 2022, 20:53

Filebot Mismatching Show (when using --q <id> to force a show)

Post by brijazz »

I'm reasonably new to Filebot so forgive me if I'm missing something obvious. I use the CLI and am having an issue with the show The Chase.

When I run this:

Code: Select all

filebot -rename The.Chase.US.S03E04.720p.WEB.h264-KOGi.mkv --db TheTVDB --q 393566 --log-file ~/Documents/filebot.log --format "{n}/{n} ({y}) - {s00e00} - {t} [{vf}]"
Filebot returns this:

Code: Select all

Episode numbers do not strictly match: The Baby - 1x04 - The Mother <=> /Volumes/Plex/Plex TV/The.Chase.US.S03E04.720p.WEB.h264-KOGi.mkv
I have used Filebot to rename episodes of "The Baby" previously but not sure why that's impacting my attempt at renaming episodes of "The Chase". Running the same command with -non-strict simply causes Filebot to proceed with renaming the file incorrectly. Any advice?
User avatar
rednoah
The Source
Posts: 20934
Joined: 16 Nov 2011, 08:59

Re: Filebot Mismatching Show

Post by rednoah »

If you force The Baby via --q 393566 then that is what you get. You can solve the problem by forcing the correct series, or by at least not forcing the wrong series.

Code: Select all

--q 271955

Code: Select all

--q "The Chase (US) (2013)"
e.g.

Code: Select all

$ filebot -rename The.Chase.US.S03E04.720p.WEB.h264-KOGi.mkv --db TheTVDB --q 271955 --action TEST --log INFO
[TEST] from [The.Chase.US.S03E04.720p.WEB.h264-KOGi.mkv] to [The Chase (US) (2013) - 3x04 - That's Crackers.mkv]


:idea: If you're manually calling filebot then you'll want to use --mode interactive for tricky cases where you need to force a specific series over some other similarly named one:

Code: Select all

filebot -rename *.mkv --db TheTVDB -non-strict --mode interactive
Image
:idea: Please read the FAQ and How to Request Help.
brijazz
Posts: 2
Joined: 25 May 2022, 20:53

Re: Filebot Mismatching Show (when using --q <id> to force a show)

Post by brijazz »

Code: Select all

If you force The Baby via --q 393566 then that is what you get
Oh man, that is embarrassing! I had copy/pasted my command and totally forgot to replace the series ID. Silly mistake - thanks :P
User avatar
rednoah
The Source
Posts: 20934
Joined: 16 Nov 2011, 08:59

Re: Filebot Mismatching Show (when using --q <id> to force a show)

Post by rednoah »

You can use the series name / year to force a series instead of the numeric ID. The former is bit more human readable. ;)
:idea: Please read the FAQ and How to Request Help.
Post Reply