Unable to launch after upgrade to 4.5

Any questions? Need some help?
Post Reply
Andre-K
Donor
Posts: 49
Joined: 30 Oct 2012, 19:15

Unable to launch after upgrade to 4.5

Post by Andre-K »

Exception in thread "main" java.lang.UnsupportedClassVersionError: net/filebot/Main : Unsupported major.minor version 52.0

[email protected]:~$ java -version
java version "1.7.0_65"
OpenJDK Runtime Environment (IcedTea 2.5.2) (7u65-2.5.2-3~14.04)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)

- Of course, I'd rather not infect computer with any security-hole-collection made by Sun. - they are very well exploited.
User avatar
rednoah
The Source
Posts: 19127
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Unable to launch after upgrade to 4.5

Post by rednoah »

You'll need Oracle Java 8 for FileBot v4.5 or higher. OpenJDK 8 should work as well but I'm not sure if there's packages for that yet.

As for security, that's all Java applets in the browser. Having Java runtime installed itself is zero security risk, same as any other runtime like python or ruby.
:idea: Please read the FAQ and How to Request Help.
Andre-K
Donor
Posts: 49
Joined: 30 Oct 2012, 19:15

Re: Unable to launch after upgrade to 4.5

Post by Andre-K »

reverted to older version. Will need to wait for 4.5.
As for security; you are absolutely correct, but I had some experience that Sun/Oracle updates added the applet to brower behind my back, or - somehow these got installed a few times without me knowing. Thta's a long while ago, but I stayed away since then :)
User avatar
rednoah
The Source
Posts: 19127
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Unable to launch after upgrade to 4.5

Post by rednoah »

I think Ubuntu 14.10 Unicorn has OpenJDK 8 in the repository. So that should be publically available next week.
:idea: Please read the FAQ and How to Request Help.
fbaddict
Posts: 2
Joined: 12 Oct 2014, 13:34

Re: Unable to launch after upgrade to 4.5

Post by fbaddict »

Pretty much a bad idea dropping 1.7 support so soon... can I at least prevent previous versions to nag me every time with "4.5 is available" message, since I cannot afford installing young 1.8 on a "production" system?
User avatar
rednoah
The Source
Posts: 19127
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Unable to launch after upgrade to 4.5

Post by rednoah »

Java 7 End-of-Life is scheduled for March/April 2016 so it's pretty soon, so any issue will solve itself in a few months time.

The update notifications can be disabled by setting this Java property (in filebot.sh)

Code: Select all

-Dapplication.update=skip
:idea: Please read the FAQ and How to Request Help.
urbanriot
Posts: 2
Joined: 12 Oct 2014, 21:28

Re: Unable to launch after upgrade to 4.5

Post by urbanriot »

rednoah wrote:Java 7 End-of-Life is scheduled for March/April 2016 so it's pretty soon, so any issue will solve itself in a few months time.

The update notifications can be disabled by setting this Java property (in filebot.sh)

Code: Select all

-Dapplication.update=skip
Could you please advise as to how to implement this switch / setting in the Windows version? I added the line to the .ini files but it still prompted me to upgrade.

(similar to the OP I am not upgrading to 8.0 on Windows as it's too soon)
User avatar
rednoah
The Source
Posts: 19127
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Unable to launch after upgrade to 4.5

Post by rednoah »

You can add it right where you find all the other Java system properties:

Code: Select all

# FileBot launch4j runtime config
-Dapplication.deployment=msi
Setting it in the *.l4j.ini file will do it you use the corresponding .exe .launcher.
:idea: Please read the FAQ and How to Request Help.
urbanriot
Posts: 2
Joined: 12 Oct 2014, 21:28

Re: Unable to launch after upgrade to 4.5

Post by urbanriot »

Great, thanks! I originally added the line to filebot.l4j.ini but I see the installed program's shortcut corresponds to filebot.launcher.exe and as such edited filebot.launcher.l4j.ini with the suggested lines and I'm no longer harassed to upgrade.
User avatar
rednoah
The Source
Posts: 19127
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Unable to launch after upgrade to 4.5

Post by rednoah »

filebot.l4j.ini corresponds to filebot.exe
filebot.launcher.exe corresponds to filebot.launcher.exe

And so forth; @see viewtopic.php?f=3&t=1961
:idea: Please read the FAQ and How to Request Help.
fbaddict
Posts: 2
Joined: 12 Oct 2014, 13:34

Re: Unable to launch after upgrade to 4.5

Post by fbaddict »

aaand thanks mate :)
Post Reply