well got w7 x64 ultimate sp1 and java 6v30 and 7 no success

Any questions? Need some help?
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

well got w7 x64 ultimate sp1 and java 6v30 and 7 no success

Post by breakdown234 »

filebot wont launch not in cmd nor installed by the 64bit installer , but i can see java running in taskmanager ....very odd its 2.3 filebot btw :cry:
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

What happens if you launch it from the cmdline? There should be some kinda output in the console.

This cmd will launch the GUI:

Code: Select all

filebot
This cmd will print version and jre info:

Code: Select all

filebot -version
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

heres what happens when i launch from cmd

Code: Select all

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\deathnote>cd C:\Downloads

C:\downloads>java -jar FileBot.jar
Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
        at com.sun.java.swing.plaf.windows.XPStyle.getTypeEnumName(Unknown Sourc
e)
        at com.sun.java.swing.plaf.windows.XPStyle.getBorder(Unknown Source)
        at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$XPBorderValue.getX
PValue(Unknown Source)
        at com.sun.java.swing.plaf.windows.WindowsLookAndFeel$XPValue.createValu
e(Unknown Source)
        at javax.swing.UIDefaults.getFromHashtable(Unknown Source)
        at javax.swing.UIDefaults.get(Unknown Source)
        at javax.swing.MultiUIDefaults.get(Unknown Source)
        at javax.swing.UIDefaults.getBorder(Unknown Source)
        at javax.swing.UIManager.getBorder(Unknown Source)
        at javax.swing.border.TitledBorder.getBorder(Unknown Source)
        at javax.swing.border.TitledBorder.getBorderInsets(Unknown Source)
        at javax.swing.border.AbstractBorder.getBorderInsets(Unknown Source)
        at javax.swing.JComponent.getInsets(Unknown Source)
        at java.awt.BorderLayout.preferredLayoutSize(Unknown Source)
        at java.awt.Container.preferredSize(Unknown Source)
        at java.awt.Container.getPreferredSize(Unknown Source)
        at javax.swing.JComponent.getPreferredSize(Unknown Source)
        at net.miginfocom.swing.SwingComponentWrapper.getLayoutHashCode(Unknown
Source)
        at net.miginfocom.swing.MigLayout.checkCache(Unknown Source)
        at net.miginfocom.swing.MigLayout.getSizeImpl(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

com.sun.java.swing.plaf.windows.XPStyle.getTypeEnumName ????

There is something broken with your Java setup. I'll investiage, pretty sure there's no problem FileBot itself.
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

ummm not possible... i just completely wiped java like 1 day ago off of my system and reinstalled java 6v30 and java 7 update2 x64 both 64bit w7 versions -.-'
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

Read that it might be 'caused by using an unusual Windows theme setup, could that be the cause?
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

unusual theme? what does that have to do with what theme i use ? -.-'
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

ok yeah it was my theme what to do to have it fixed why in hell would java have anything to do with my custom theme -.-'

this has to be fixed you gotta be kidding me :cry:
Last edited by breakdown234 on 19 Dec 2011, 07:53, edited 1 time in total.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

I think forcing the Java platform-independet L&F will work around this problem, just specify this:

Code: Select all

-Dswing.systemlaf=javax.swing.plaf.metal.MetalLookAndFeel
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

ummm yeah where do i enter this?
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

With Java 7 Nimbus L&F should also work, that's less ugly and also doesn't rely on your OS theme:

Code: Select all

-Dswing.systemlaf=javax.swing.plaf.nimbus.NimbusLookAndFeel

Code: Select all

java -Dswing.systemlaf=javax.swing.plaf.nimbus.NimbusLookAndFeel -jar FileBot.jar
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

?????????


how? where do i enter this -.-'

btw dont wanna launch cmd for every time i wanna use filebot :roll:
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

Try running from cmdline via and let see if it works

Code: Select all

java -Dswing.systemlaf=javax.swing.plaf.nimbus.NimbusLookAndFeel -jar FileBot.jar
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

and works
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

so now what ? -.-'

btw for some fn reason cant do a complete copy paste from cmd to here -.-'

btw seems as if im still not able to connect still getting that 500 code -.-'
Last edited by breakdown234 on 19 Dec 2011, 08:22, edited 1 time in total.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

I'm checking to see if there's a way to set that Java property permanently.

Says:
* Permanently set the default look and feel to Nimbus by adding the following line to the <JAVA_HOME>/lib/swing.properties file:
swing.systemlaf=javax.swing.plaf.nimbus.NimbusLookAndFeel
If the swing.properties file does not yet exist, you need to create it.

Doesn't seem to work though on my machine...

What u can do is to modify [INSTALL_DIR]/filebot.cmd and add that -D property.
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

Code: Select all

C:\downloads>java -Dswing.systemlaf=javax.swing.plaf.nimbus.NimbusLookAndFeel -j
ar FileBot.jar
Dec 19, 2011 9:18:06 AM com.dmurph.tracking.JGoogleAnalyticsTracker dispatchRequ
est
SEVERE: JGoogleAnalyticsTracker: Error requesting url 'http://www.google-analyti
cs.com/__utm.gif?utmwv=4.7.2&utmn=-588978061&utmhn=filebot.sourceforge.net&utmcs
=Cp1252&utmsr=1920x1080&utmsc=32&utmul=en-US&utmje=1&utmdt=Rename&utmhid=1591884
833&utmp=net%2fsourceforge%2ffilebot%2fui%2frename%2fRenamePanel&utmac=UA-253792
56-3&utmcc=__utma%3D999.1287522503.1324282014.1324282014.1324282686.2%3B%2B__utm
z%3D999.1324282686.1.1.utmcsr%3DJava(TM)%20SE%20Runtime%20Environment%201.7.0_02
%7Cutmccn%3D(organic)%7Cutmcmd%3Dorganic%7Cutmctr%3Dfatjar%3B&gaq=1', received r
esponse code 500
is what i get when i access the renamer or any other option such as analyze etc etc ... :o
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

breakdown234 wrote:unusual theme? what does that have to do with what theme i use ? -.-'
I guess when Java is trying to copy the Windows look it's trying to copy data that's not defined in your theme. Wonder why none of the Java people bothered to fix that bug yet. This affects all Java GUIs that use the Windows look... :/
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

how in hell would i add a d property? -.-' in the directory atm of filebot
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

That's just normal output. Lot's of stuff will be logged but u can ignore everything as long as it works.
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

rednoah wrote:
breakdown234 wrote:unusual theme? what does that have to do with what theme i use ? -.-'
I guess when Java is trying to copy the Windows look it's trying to copy data that's not defined in your theme. Wonder why none of the Java people bothered to fix that bug yet. This affects all Java GUIs that use the Windows look... :/

yeah exspecially crappy for us people using 3rd party themes :x
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

double post
Last edited by breakdown234 on 19 Dec 2011, 08:32, edited 1 time in total.
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

breakdown234 wrote:how in hell would i add a d property? -.-' in the directory atm of filebot
Change C:/Program Files/FileBot/filebot.cmd to this:

Code: Select all

@ECHO OFF
java -Dswing.systemlaf=javax.swing.plaf.nimbus.NimbusLookAndFeel -Dapplication.deployment=msi -Xmx256m -jar "%~dp0FileBot.jar" %*
And then just use filebot.cmd to run FileBot. I'll keep checking how to configure that directly for the Java install.
:idea: Please read the FAQ and How to Request Help.
User avatar
breakdown234
Posts: 25
Joined: 19 Dec 2011, 07:16

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by breakdown234 »

yes please do so i hate having to look at cmd windows -.-'

always thought there was a specific command to have the cmd window launch silently aka not seeing it :?:
User avatar
rednoah
The Source
Posts: 18823
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: well got w7 x64 ultimate sp1 and java 6v30 and 7 no succ

Post by rednoah »

Check to video tutorial for how it works:
http://www.youtube.com/watch?v=zcSFKiwFLZw

But I guess u already got how it works. Does it just not display any matches? The list to the right should display the proposed names. Just checked anidb and it's up and running. Is anidb connectable from your location?
:idea: Please read the FAQ and How to Request Help.
Post Reply